Jump to content

HWSensors

FakeSMC Plugins Hardware Monitoring Sensors SuperIO Temperature Voltage Tachometer Frequency

  • Please log in to reply
1028 replies to this topic

#241
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

this is the windows data


Please try the new version and tell me what you'll see.

#242
sacaman1

sacaman1

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:www

Please try the new version and tell me what you'll see.


this is the result

Attached Files



#243
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

this is the result


And it's ok? Seems system temperature is lower then it should be..

P.S. Sorry, sacaman1, I erroneously tought that you have Nuvoton chip. Still no changes for you.

#244
sacaman1

sacaman1

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:www
no it's the same wrong value again

don't worry i will wait until a new solution from your side
in all cases thanks a lot for your time and help
;-)

sacaman

#245
PiSToLBR

PiSToLBR

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
  • Gender:Male
  • Location:Brazil - Recife - PE
My results (System specs in my signature):

Build 8d05bbd

Attached File  kozlek-HWSensors-8d05bbd.png   91.72KB   76 downloads


Build 0d2a0b1


Attached File  kozlek-HWSensors-0d2a0b1.png   82.55KB   75 downloads




Localization to PT (Português)


"TEMPERATURES" = "TEMPERATURAS";
"DRIVES TEMPERATURES" = "TEMPERATURAS DOS DISCOS";
"SSD REMAINING LIFE" = "DURAÇÃO PREVISTA DO SSD";
"MULTIPLIERS" = "MULTIPLICADORES";
"FREQUENCIES" = "FREQUêNCIAS";
"VOLTAGES" = "VOLTAGENS";
"FANS" = "VENTILADORES";
"CPU Heatsink" = "Dissipador da CPU";
"GPU %X Board" = "GPU %X Placa";
"GPU %X Core" = "GPU %X Núcleo";
"GPU %X Proximity" = "Sensor %X da GPU";
"Northbridge" = "Northbridge";
"System Chipset" = "Chipset do Sistema";
"Ambient" = "Ambiente";
"CPU Package" = "CPU";
"CPU %X" = "CPU %X";
"CPU Core %X" = "Núcleo da Cpu %X";
"Fan %X" = "Ventilador %X";
"CPU" = "CPU";
"Memory" = "Memoria RAM";
"Power/Battery" = "AlimentaÇÃo/Bateria";
"Quit HWMonitor" = "Sair do HWMonitor";
"No sensors found" = "NÃo há sensores disponíveis";
"Main 12V" = "Principal 12V";
"PCIe 12V" = "PCIe 12V";
"Main 5V" = "Principal 5V";
"Standby 5V" = "Repouso 5V";
"Main 3.3V" = "Principal 3,3V";
"Auxiliary 3.3V" = "Auxiliar 3,3V";
"VRM Supply %X" = "AlimentaÇÃo VRM %X";
"Power Supply %X" = "Fonte de alimentaÇÃo %X";

#246
stefano.85

stefano.85

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
  • Gender:Male
  • Location:Italy
The same situation also on my system in rig. With the latest revision no more power supply voltages

Also another question: how can i force to display all cpu cores in the HWmonitor app?
tnx

#247
leo90

leo90

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
  • Gender:Male
  • Location:Italy

HI! Can you help me to detect my mobility radeon 4570 on GPU stat? (id 95531002)


Thank you very much



#248
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

The same situation also on my system in rig. With the latest revision no more power supply voltages

Also another question: how can i force to display all cpu cores in the HWmonitor app?
tnx


Try latest revision.

HI! Can you help me to detect my mobility radeon 4570 on GPU stat? (id 95531002)


Thank you very much



This ID is already in the supported list in RadeonX plugin. HWMonitor should show GPU temperature and you should see RadeonMonitor related messages in kernel log.

#249
stefano.85

stefano.85

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
  • Gender:Male
  • Location:Italy
Works like a charm, really really a good work kozlek! nothing to say
Attached File  Schermata 03-2456010 alle 11.15.59.png   72.25KB   87 downloads

#250
PiSToLBR

PiSToLBR

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
  • Gender:Male
  • Location:Brazil - Recife - PE
Working fine now.

I have several other fans that are not showing. Is there a way I can contribute ?


Revision c273f7d:


Attached File  kozlek-HWSensors-c273f7d.png   88.48KB   57 downloads

#251
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel
I just added new feature to Super I/O plugins - value modifiers. Modifiers could be set in "Sensors Configuration" section of SuperIOFamily's info.plist.

It's impossible to use universal modifiers because different motherboard manufacturers have different implementations also for the same Super I/O chip models on different mobos. So it's up you to found proper modifiers values. There is couple of well known modifiers values for some mobos and Super I/O chipsets could be obtained from OpenHardwareMonitor project (see SuperIOHardware.cs file).

The formula used is: offset + value + (value - reference) * gain, there is value is the unmodified value read from the registers. The formula used in OpenHardwareMonitor for voltage is a bit different. For example in OpenHardwareMonitor: v.Add(new Voltage("+12V", 5, 27, 9.1f)) , second parameter (5) is VIN5, the 3rd parameter and 4th is the gain = 27 / 9.1 = 2.967. In the info.plist you should set 2.967 * 1000 (because of info.plist's Number could get only integer values):

Attached File  Screen Shot 2012-03-24 at 15.14.20.png   45.95KB   574 downloads

At the end you could get a picture like this:

Attached File  Screen Shot 2012-03-24 at 14.07.06.png   72.04KB   540 downloads

#252
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,406 posts
  • Gender:Male
Hi kozlek..this softwae is not compatible with snow ?

Posted Image

Why?

#253
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

Hi kozlek..this softwae dont compatible for snow ?

Posted Image

Because?


Because ARC - automatic reference counting. I tried but can't compile it for 10.6.

#254
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,406 posts
  • Gender:Male

Because ARC - automatic reference counting. I tried but can't compile it for 10.6.


:|

Sorry for OT
Hi Kozlek,
Please i see in your signature whyle you use soundblaster usb creative.
But if i buy this hardware , i need patch for apple hda ?
I need a ssdt write good for this hardware?
Thanks for you interested...and sorry for my bud english
PS: Disabled from bios audio?

#255
Navi

Navi

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Because ARC - automatic reference counting. I tried but can't compile it for 10.6.

That's wrong Mozo - just change deployment target to 10.6 (not an SDK) and application will work in 10.6 :wink2:

#256
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,406 posts
  • Gender:Male

That's wrong Mozo - just change deployment target to 10.6 (not an SDK) and application will work in 10.6 :wink2:


How ?

#257
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

:|

Sorry for OT
Hi Kozlek,
Please i see in your signature whyle you use soundblaster usb creative.
But if i buy this hardware , i need patch for apple hda ?
I need a ssdt write good for this hardware?
Thanks for you interested...and sorry for my bud english
PS: Disabled from bios audio?


SoundBlaster Recoon3D USB works OOB, plug-and-play. Also I use built-in audio with patched AppleHDA for fun.

That's wrong Mozo - just change deployment target to 10.6 (not an SDK) and application will work in 10.6 :wink2:


XCode 4.3.2:
Attached File  Снимок экрана 2012-03-24 в 19.40.08.png   237.84KB   116 downloads

#258
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,406 posts
  • Gender:Male

SoundBlaster Recoon3D USB works OOB, plug-and-play. Also I use built-in audio with patched AppleHDA for fun.


Also if i dont use patch Apple hda , work never patch?
Sorry again for OT

#259
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

Also if i dont use patch Apple hda , work never patch? Sorry again for OT


yes

#260
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,406 posts
  • Gender:Male

yes

Thanks friend
Return on topic , on snow my HwMonitor work
Posted Image





Also tagged with one or more of these keywords: FakeSMC, Plugins, Hardware Monitoring, Sensors, SuperIO, Temperature, Voltage, Tachometer, Frequency


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy