Jump to content

[GUIDE] How to fix [spdisplays_display] in About This Mac window 2012.08.20 update - tiny app added

atm spdisplays_display fix lion

  • Please log in to reply
27 replies to this topic

#21
philip_petev

philip_petev

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
  • Gender:Male
  • Location:Haskovo, Bulgaria

I have new information, booting in verbose mode, I noticed that the kext RadeonMonitor.kext I do not recognize the video card even if the kext correctly recognize all Ati6000controller.kext, I must see if not having the monitor configured correctly or if this happens I have to add something to the kext, tonight I will try to create a log file of the boot, about chameleon some settings may prevent proper recognition? I turned PciRoot because if you do not active the screen stays black.


Dude, I think you have a serious problem. According to this dump, you don't have laptop display at all!!! The laptop displays in the IO register are named "AppleBacklightDisplay", but according to the dump, you don't have object with that name in the register. I found object named AppleDisplay and usually this is the name for the external displays, this object has Vendor ID 0x756e6b6e and Product ID 0x717, but there is no IODisplayEDID key for this object. Honestly, I don't know what to say.

#22
HackMan85

HackMan85

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts
  • Gender:Male
  • Location:napoli
  • Interests:Computer e sapere informatico.
I thank you very much for your help, I was hoping that you could risolvermi the problem but I think there is too little support for these video cards in the family RadeonMonitor.kext 6400 series does not even exist, but I tried to create it no expert on mac and I could not do, I think you have to adjust several things to run well on my monitor.

#23
TheRacerMaster

TheRacerMaster

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
I don't really know what to do with the DSDT edit. Where should I put it under GFX0? Can you do it for me? Another thing - I don't have QE/CI yet. Will that cause it not to work? This is my unedited DSDT.

#24
dayday85

dayday85

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hello everybody,

I don´t know if this is the right place but i do not know where to ask else :)

I managed to run mountain lion on a notebook with an i7 3610qm and HD4000 with qe / ci.

The only problem I have is that my internal display is recognised as spdisplays_display and I cannot change brightness, no controls in system settings, the hardware keys fn+up/down also do not work.

I need to mention that my display only started working when I inserted an HDMI cable to my laptop on boot....now it is working all the time, but before I had to boot with -x and GraphicsEnabler=No because Osx did not know there to draw the window server and I got a black screen (seen in system.log)

Do you maybe have an idea?

I also have attached my ioreg.txt :)

Attached Files



#25
joshhh

joshhh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 210 posts
  • Gender:Male
  • Location:Russia, Israel
You need complex dsdt edits to get brightness control and some patch needs to be applied to get correct output to LCD without connecting HDMI

Hello everybody,

I don´t know if this is the right place but i do not know where to ask else :)

I managed to run mountain lion on a notebook with an i7 3610qm and HD4000 with qe / ci.

The only problem I have is that my internal display is recognised as spdisplays_display and I cannot change brightness, no controls in system settings, the hardware keys fn+up/down also do not work.

I need to mention that my display only started working when I inserted an HDMI cable to my laptop on boot....now it is working all the time, but before I had to boot with -x and GraphicsEnabler=No because Osx did not know there to draw the window server and I got a black screen (seen in system.log)

Do you maybe have an idea?

I also have attached my ioreg.txt :)



#26
xmen107

xmen107

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
Thanks you, worked for me. ;)

#27
macphreak4evr

macphreak4evr

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Awesome! super fast and works like a charm! cheers

#28
ssgoku129

ssgoku129

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

This script did not work on my Dell XPS L702x with 3D Display (it read the product and vendor ID as blank),

 

But I did it manually and got it working, it is detected as LCD Display but not built-in,

 

I think I need to get the built-in monitor to get the brightness slider








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy