Jump to content

Lion, Ati 4850 and Sleep

Lion Ati 4850 Sleep

  • Please log in to reply
No replies to this topic

#1
uzmi

uzmi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 254 posts
Hi:
I have a graphic Ati 4850 1GB ( http://es.gigabyte.c...r485mc-1gh.html ).
I modified the ATI4800Controller.kext to make it work with Lion .I added the graphic card ID.

Posted Image

I also modified Name (_UID, Zero) by Name (_UID, One) in DSDT file.

Posted Image

Finally I added "Graphics Enabler->Yes" in the org.chameleon.Boot.plist file.

Posted Image

Everything works but Sleep-Wake. When he wakes up, the monitor does not turn on. The screen resolution is 1440x900

Posted Image

As the graph has two DVI connectors, connects the monitor to the second DVI port.
Sleep-Wake now works fine but the resolution changed to 1400x1050 and everything looks blurred.

Posted Image

I tried to add the resolution 1440x900x32 in org.chameleon.Boot.plist file, but no image appears when I restart and get a message "Out of range"
I also tried the program SwitchResX4 but this is what I got:

Posted Image

I added the graphic in the DSDT file and delete the line "Graphics Enabler-> Yes" in the org.chameleon.Boot.plist file.

Posted Image

It is the same as before, the connector @0 does not work, and the connector @1, does.

Posted Image

IORegistryExplorer image partial with Chameleon injecting the graphic:

Posted Image

and here's another picture with the DSDT and Ati graphics:

Posted Image

I share a link, in case you want to check it out, please feel free to suggest any idea.

www.megaupload.com/?d=5PWJAK1I

Thanks.
Uzmi.

P.D. Use 10.7.2 Retail with Chameleon 2.1 rev 1768






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy