Jump to content

Sleep Lion y Ati 4850 (Solucionado)

- - - - - Ati 4850 Sleep Lion

  • Please log in to reply
8 replies to this topic

#1
uzmi

uzmi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 274 posts
Hola:
Tengo una grafica Ati 4850 1GB ( http://es.gigabyte.c...r485mc-1gh.html ).
Para que funcione en Lion, modifiqué el archivo plist de ATI4800Controller.kext agregando el ID de la gráfica.

Posted Image

También modifiqué Name (_UID, Zero) por Name (_UID, One) en el archivo DSDT.

Posted Image

Y por último agregué "Graphics Enabler->Yes" al archivo org.chameleon.Boot.plist

Posted Image

Funciona todo perfecto excepto el Sleep-Wake. Se duerme pero cuando despierta, el monitor no enciende.
La resolución de la pantalla es de 1440x900
Posted Image

Como la gráfica tiene dos conectores DVI, conecté el cable del monitor al otro puerto DVI.
Ahora el Sleep-Wake funciona PERFECTO pero la resolución cambió a 1400x1050 y se ve todo muy achatado.

Posted Image

Intenté agregar la resolución 1440x900x32 al org.chameleon.Boot.plist, pero cuando reinicio no aparece imagen y sale un aviso de "Fuera de rango"
También intenté con el programa SwitchResX4 pero esto es lo que obtuve:

Posted Image

Busqué otro camino y agregué la gráfica al DSDT y borré la línea "Graphics Enabler->Yes" del archivo org.chameleon.Boot.plist

Posted Image

Ocurre exactamente lo mismo que antes, conector @0 no funciona, conector @1 si funciona (sleep-wake).

Posted Image

Aquí una imagen parcial del IORegistryExplorer con Chameleon inyectando la gráfica:

Posted Image

y aquí otra con el DSDT a cargo de la gráfica:

Posted Image

Al final pongo un enlace a un archivo con los 2 IORegystryExplorer completos y el DSDT incluyendo la gráfica, por si alguien quiere echar una mirada mas completa y pueda aportar alguna idea al respecto.

www.megaupload.com/?d=5PWJAK1I

Gracias.
Uzmi.


P.D.
Instalé Lion 10,7,2 retail (método Maldon) con Chameleon 2.1 rev 1768 (pero he probado con varias versiones anteriores), smbios.plist con iMac 10,1.
Desde Snow 10.6.7/8 tengo ese problema con la Ati.
He usado una Nvidia 9400 y el sueño funciona perfecto.
Ahora con Lion esto es lo mas cerca que he llegado a lograr que funcione el sleep.
He probado a reinstalar desde cero usando el puerto DVI@1 y es mas de lo mismo.

Nueva edición de la P.D.
No dejo de darle vueltas pensando que si funciona en un conector si y en otro no, en teoría si se modificase los parámetros del DSDT, (donde va la gráfica) debería funcionar, pero por desgracia no se como hacerlo. De ahí que pongo la imagen de Motmot@0 y Motmot@1 del IORegistryExplorer.

#2
ruben rodenas cebrian

ruben rodenas cebrian

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
ami me pasaba exactamente lo mismo con una 6870 dormia bien entero y luego al despertaba oia los discos duros funcionando pero la grafica no respondia ... , al final tube q optar por un semi sueño , modificando el DSDT , as tenido q liar una buena para que te fuera la grafica , felicidades

si quieres echarle un ojo ami dsdt te lo mando de todos modos tienes la bios en s3 no ? imagino q si pero nunca esta de mas asegurarse

#3
uzmi

uzmi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 274 posts

ami me pasaba exactamente lo mismo con una 6870 dormia bien entero y luego al despertaba oia los discos duros funcionando pero la grafica no respondia ... , al final tube q optar por un semi sueño , modificando el DSDT , as tenido q liar una buena para que te fuera la grafica , felicidades

si quieres echarle un ojo ami dsdt te lo mando de todos modos tienes la bios en s3 no ? imagino q si pero nunca esta de mas asegurarse


Hola Ruben:
Si, tengo la bios en S3, lo increible es que funciona perfecto en un conector dvi pero la resolución está cambiada y a mi gusto está todo muy chato.
Y en el otro conector se ve perfecto pero no enciende el monitor (luego del reposo).
Si puedes enviarme el dsdt, le echo un ojo, a ver si me ayuda en algo.
Gracias.

#4
ruben rodenas cebrian

ruben rodenas cebrian

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
La verdad que es jodidamente raro ... pero tranquilo aqui estamos para ayudarte a ver si conseguimos que saques ese sueño para alante ;-) voy a buscar info sobre la grafica a ver que encuentro , porcierto no estaria nada mal que pusieras todas la características de tu pc asi podremos ayudarte mejor

aqui tienes mi DSDT http://www.multiupload.com/7JV73QG78V

una cosa en q version de lion estas ?

#5
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,486 posts
  • Gender:Male
  • Location:Tru, Venezuela
Hola amigo Uzmi, en mi humilde opinión, no siendo experto en el tema de las gráficas en lo absoluto, he revisado tu DSDT (junto con el ioreg) y te digo que se ve suficientemente bien el código de la inyección, así que no se me ocurre algún ajuste o modificación del hack. Sin embargo, te recomendaría dejarle la detección de la gráfica al bootloader, en este caso por lo extenso de la inyección. Ahora bien, si quieres seguir probando cosas, "tal vez" quieras usar combinaciones de estos flags específicos para levantar la gráfica sólo con Chameleon (sin inyección DSDT), a ver si con eso se genera algún código o entrada útil adicional en el ioreg para portar a la DSDT, me llaman la atención el "AtiConfig=Motmot" y el "AtiPorts=X", ambos tomados/generados con Chameleon Wizard:
<key>AtiConfig</key>
<string>Motmot</string>
<key>AtiPorts</key>
<string>2</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>UseAtiROM</key>
<string>Yes</string>
Saludos.

P.D. Has descartado un posible fallo de hardware en la salida DVI que mencionas, pero desde windows?

Has leído algún reporte genuino de Imac 9,1-10,1 (2009-2010) con tu misma gráfica y problemas de reposo? que puedieran atribuirse a algún BUG desde los propios drivers de Apple, específicamente el ATIFramebuffer.kext (que gestiona la energía de las gráficas ATI) afectando la función de reposo al despertar, tanto en Lion como Snow. Por ahí leí algo viejo sobre el tema y el firmare update (1.4) del 2009 para corregir un fallo con esas gráficas 4850 y el sleep.

#6
uzmi

uzmi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 274 posts
Hola Juanerson:

La detección de la gráfica se la dejo siempre a cargo de Chameleon, probé lo del DSDT como un recurso mas para tratar de solucionar este problema.
Probare los flags que mencionas a ver que pasa y de paso buscaré información acerca de posibles bugs, como bien dices.

En Seven funcionan los dos puertos DVI perfectamente.

Sin embargo hay un pequeño detalle del DSDT que me mosquea:

Posted Image

¿Porque sale Display CRT si le pongo NONE?

En fin, como verás también lo he posteado en el foro inglés, no tanto con la esperanza de resolverlo (aunque lo cierto es que no las pierdo), si no también para ver si le pasa a alguien mas.
Es que, he buscado información y es raro que nadie use una 4850 como para confirmar si le va bien o no el sleep.

Un saludo y gracias.

P.D.
Tampoco estoy muy al tanto de como usar el ATI.rom.
Tengo un RV770.bin que debo pasar a ATI.rom (creo) y no se como hacerlo.
Lei que mencionan usar el IORegistry (para sacar la info) para luego parsarlo a un editor Hexadecimal y renombrarlo como .rom pero no le encuentro la
vuelta.
Tengo bastante para investigar.

Ah, de paso menciono que cambié cable (VGA-VGA con adaptador DVI a uno nuevo VGA-DVI, que puse el adaptador en el puerto libre (por si las moscas, solo me faltó un poco de vudu)

#7
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,486 posts
  • Gender:Male
  • Location:Tru, Venezuela

Sin embargo hay un pequeño detalle del DSDT que me mosquea:
...
¿Porque sale Display CRT si le pongo NONE?

Pero es el mismo comportamiento / resultado con Chameleon, cierto? A mi también me llamó la atención ese valor, pero luego me doy cuenta en los ioregs adjuntos de tu primer post que también lo hace Chameleon de esa forma. Según entiendo aparece CRT en X puerto DVI (Motmot) cuando conectas el monitor en ese puerto, o me equivoco? Por lo tanto, esa parte de la inyección podría ser innecesaria, ya que dicha información la detecta / toma "en teoría" en presencia física de hardware (en este caso el monitor) directo del firmware de la tarjeta gráfica, es así?

P.D. El ATI rom pudiera ayudarte, pero tampoco sé cómo se aplica, sólo tengo alguna idea... si necesitas ayuda con el ioreg me avisas, es fácil transformar los datos decimales a hexadecimales con PlistEdit Pro. Supongo, tal vez me equivoque, sólo estoy usando la lógica, que ese .bin se podrá renombrar a .aml por ejemplo (tal como la DSDT de AIDA64) para obtener los datos decimales, luego se pasaría por PlistEdit Pro para transformarlos en hexadecimales, mi duda es cómo se cargan después, desde dónde? Creo que ahí es donde entra en acción el flag de Chameleon. Saludos.

#8
uzmi

uzmi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 274 posts
Hola:
De nuevo por aquí.
Me autocito y paso a comentar:

...
Sin embargo hay un pequeño detalle del DSDT que me mosquea:

Posted Image

¿Porque sale Display CRT si le pongo NONE?
...



En el momento de realizar las pruebas mencionadas arriba, contaba con un monitor Asus19 ( http://www.asus.es/D...#specifications )
Por un designio afortunado compré un Asus 22 de segunda mano ( http://www.asus.es/D...#specifications ) a una persona fantástica (Tonyi - Micajita a quien siempre estaré agradecido).

Mi sorpresa fue mayúscula al comprobar que ahora está solucionado el problema de Sleep en Lion.
Al mirar en el IORegistry veo que Chameleon toma el tipo de display como LCD en lugar de CTR como salía antes.

Posted Image

Aparte de la diferencia de tamaño este de 22 tiene conexión DVI-D, el de 19 era VGA.

Hago este comentario para dejar constancia de este hecho, porque llevo mucho tiempo investigando y sufriendo con este problema y ahora quedó resuelto por casualidad, y en definitiva el problema no era ni de la gráfica, ni del DSDT ni de Chameleon.

Un saludo y gracias a todos aquellos que se interesaron por mi problema.

#9
surfcaster

surfcaster

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 520 posts
jodo, deteccion del monitor, hay sistemas operativos demasiado listos cuando siempre fue mas fácil manejarlos cuando eran tontos pero bueno en algún sitio debía estar la "salsa", me alegro que lo tengas solucionado, un saludo compi






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy