Jump to content

[GUIDE] Lenovo ThinkPad T510/510i (plus T410 and W510) 10.6-10.7-10.8-10.9 all working OK! 2013.11.12 Update

lenovo lion t510 osx mountain lion

  • Please log in to reply
466 replies to this topic

#321
jerrywilborn

jerrywilborn

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts

I think it's same kext that was posted few pages before in this thread. Disappoint you, it won't work with Ricoh reader in t510/410 and w510 systems but works fine in my w530.


http://forge.voodoop.../VoodooSDHC.cpp

After reading the VoodooSDHC source, I'm betting you're right. Tailing the system.log while inserting a card shows the lines "in power_sd(slot) / baseclock / sd clock" then the machine locks. Mac development is far from my area of expertise, but I'm to tinker around with it and see if I have any luck.

#322
jerrywilborn

jerrywilborn

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
If you're ever having trouble falling asleep, this helps: https://developer.ap...troduction.html

Got Xcode and subversion installed so I could fetch the source. Maybe I'll get to actually work on some code now. =)

#323
Ryanjames170

Ryanjames170

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hello guys i have tryed a few difrent ways of installing OSX and i keep getting suck at iobluetoothhcicontroller start completed i have a Intell I5 M540 with Intell HD graphics on my T510.. i have had no LUCK at all with making this thing boot past that i have evan tryed deleating NVDA and ATI Kexts and booting with GraphicsEnabler=No

Should i maybe redo my USB stick with myhack and just run GraphicsEnabler=No and see whath happens?

currently i am running this type of installer using the T510 kexts http://thetecherra.c...rt-to-finish-2/

thank you for the help

i am trying to install a retail version i just got of 10.8

i am currently working for a old laptop with 10.6.8 that works good.

#324
Ryanjames170

Ryanjames170

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
well i got eveything working good ecept sleep and blacklight.. thank you goses out to jerrywillborn thank you again for the help would not of gotten anywhere with out it..

#325
phoTWOgrapher

phoTWOgrapher

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hey Guys, please be kind, i´m new to Hackintosh (but i learn fast and know what to do on Windows ;) )
Is there somewhere a real Guide for installing osx on a W510 or is it only the kext files and modded bios?
And after modding the bios, is it still able to be used with Windows 7?

#326
M4ng03z

M4ng03z

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Just use this:
http://myhack.sojugarden.com/guide/
I've used [a process from an other forum] for my desktop but couldnt get the laptop options to work. I tried to follow the guide posted in this thread, but the link above is the easiest thing I've found. It works perfectly on my W510. Followed the directions exactly and it worked the first time I think.

What I do and don't have working:

Wifi is via USB dongle without BIOS editing
Trackpad works
Sound works with VooDooHDA
Ethernet works
Keyboard light works
Battery level works
USB 3.0 works
Webcam and mic work


Trackpoint does not
Touch screen registers as a click but not a mouse
Brightness control is not working (The only thing I really want to get fixed!)
Shutdown doesn't finish all the way (lights turn off but cpu fan still runs until forced off)
I don't even want to try to see if sleep is working right now (does not work for many hackintoshes)

I hope this helps. Feel free to PM me.

IMPORTANT: use the rear yellow powered usb port with the install thumbdrive. it's the only one that will work until the 3.0 ports are enabled.

#327
phoTWOgrapher

phoTWOgrapher

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Thanks M4ng03z,

the tip with the rear yellow usb really helped ;)
Im writing this from my new Macbook pro ;)
The only thing not working currently is the resolution and hardware acceleration of my graphics card...
But i think i can solve that too ;)

#328
phoTWOgrapher

phoTWOgrapher

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Well... i can´t seem to get it to work :hammer:
I have no mac around me so i have to use the iatkos ML2.
Every time i "install" the dsdt File by putting it in the extras folder the reboot hangs at PCI configuration End.
Before that the Graphics card is displayed correctly in the boot...

I always have to reinstall the whole thing, because i can´t seem to get it to boot up ...


EDIT: Finally i got it to work.
I changed the VT-d Bios setting to disabled and installed the whole thing again.
I also unclicked the nvidia drivers in the iatkos install options!

And whooza... that is a fast Thing! Adobe Lightroom runs like a dream!

#329
phoTWOgrapher

phoTWOgrapher

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Ok i still have problems getting the dsdt file to run.
i downloaded dsdt editor, loaded the dsdt from the first post and when i hit compile i get 1 error and 2 warnings:

https://dl.dropboxus.../dsdterror.tiff

can anybody help me here?
when i use this dsdt the system hangs after PCI END

#330
tluck

tluck

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 732 posts
  • Gender:Male
  • Location:NC, USA
@photo2grapher

To get your dsdt to compile change MONITOR to MON0000
Ignore the warnings

#331
sirfergy

sirfergy

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Is there a text based guide for getting Mountain Lion 10.8.3 on the W510 using the custom DSDTs on this thread? I don't see any new kexts posted for 10.8.3 either.

#332
markbelf

markbelf

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Location:Sydney, Australia
First post here, so please be patient :-)
I have followed this guide by joshhh and now have a working T510 (4313-CTO) with 10.8.3. Everything is working except for wireless. I have purchased a Broadcom mini-pci card to use for wireless, but without flashing the BIOS I cannot install it.
Since my system is now OS X only now, I wanted to flash the BIOS back to the version joshhh has posted. However I cannot find a DOS tool to flash the bios. What and where can I find a program to do this? I have hunted the forums, however most people seem to boot into windows to load the bios, which I can't do. I can boot Ubuntu linux or DOS.
Can someone please point me in the right direction?

Thanks.

Lenovo T510, 8Gb RAM, 500Gb 7200rpm HDD, Nvidia NV3100 512Mb graphics, Broadcom bluetooth

#333
joshhh

joshhh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 210 posts
  • Gender:Male
  • Location:Russia, Israel
Try to find or make live CD/Flash Windows XP or Win7 and flash bios from it.

First post here, so please be patient :-)
I have followed this guide by joshhh and now have a working T510 (4313-CTO) with 10.8.3. Everything is working except for wireless. I have purchased a Broadcom mini-pci card to use for wireless, but without flashing the BIOS I cannot install it.
Since my system is now OS X only now, I wanted to flash the BIOS back to the version joshhh has posted. However I cannot find a DOS tool to flash the bios. What and where can I find a program to do this? I have hunted the forums, however most people seem to boot into windows to load the bios, which I can't do. I can boot Ubuntu linux or DOS.
Can someone please point me in the right direction?

Thanks.

Lenovo T510, 8Gb RAM, 500Gb 7200rpm HDD, Nvidia NV3100 512Mb graphics, Broadcom bluetooth



#334
Tetonne

Tetonne

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 274 posts
do you know Clover ?
let's have a look here :
http://www.insanelym...with-uefi-only/

#335
joshhh

joshhh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 210 posts
  • Gender:Male
  • Location:Russia, Israel
Got Clover on both Thinkpads in old BIOS mode not UEFI, works fine

do you know Clover ?
let's have a look here :
http://www.insanelym...with-uefi-only/



#336
Erdbeeere

Erdbeeere

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Hi joshhh, whats up? Is there any further development or has the work on this project stopped?

I had several problems with my T510 and the stock BIOS, but with the modded one i have freezes, so i switched back to the stock bios. Maybe you can modify the dsdt, so i am able to use the ethernet card. At the moment i am note able to use network, i only can ping, nothing more. I used a mobile internet device (UMTS) but no chance, it doesnt work. Maybe you know whats wrong here.

#337
f0rcegr0wn

f0rcegr0wn

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Anyone tried updating to 10.8.4 yet?



#338
f0rcegr0wn

f0rcegr0wn

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Anyone tried updating to 10.8.4 yet?

FYI: I just updated without major issues. Needed to rebuild kext cache and copy AppleHDA over again with permission fixing, and all fine (for now)



#339
Michał Mildner

Michał Mildner

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Amazing guide, installed 10.8.4, almost everything is working perfect. Sleep, wake, etc. Had problem with bluetooth keyboard not found, but I just turned it off in system preferences.

The only problem is, when i boot from USB, i have USB 3.0 ports working fine. After installing kext package from this guide, USB 3.0 ports are not working. Only yellow and e-sata USB are ok.

 

Any suggestions? Thanks in advance:)



#340
jetlondon

jetlondon

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

hi All,

 

I'm just wondering, if someone was able to "hackintosh" a t410 with Intel HD graphic card (Intel HD Graphics, Ironlake, Intel Auburndale/Arrandale Processor - Integrated Graphics Controller [Lenovo]).

It seems, that packages attached to the first post work for NVidia graphic only. I found a DSDT which works for the Inter HD graphics somethere in the middle of the thread :)

But: the audio (line-out on the dock) does not work, the external monitor attached to the docking station via DVI can only 1280x800. The DisplayPort on the docking station no signal at all.

Is it possible at all - two external displays attached to a dock?

Thanks!







Also tagged with one or more of these keywords: lenovo, lion, t510, osx, mountain lion


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy