Jump to content

ASUS P5Q PRO e Realtek Audio ALC1200

P5Q Pro Alc1200 7.1surround AppleHDA.kext

  • Please log in to reply
7 replies to this topic

#1
i-NG

i-NG

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Trieste, Italy
Ho una P5Q pro ed ho installato la kext AppleHDA.kext per la Realtek ALC1200 versione 1063 (vedi allegato) e funziona per 2 casse.
Ora volevo abilitare il 7.1 surround della Creative ma da Configurazione Midi Audio non mi permette di scegliere ne 5.1 ne 7.1...
C'è un modo per abilitare la piena funzionalità della scheda audio integrata???

Grazie mille

Attached Files



#2
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,517 posts
  • Gender:Male
  • Location:Italy
Spulcia qui http://www.insanelym...opic=161430&hl=

#3
i-NG

i-NG

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Trieste, Italy
ho cercato ma non ho trovato nulla che mi risolva il problema... :S

#4
Fabio1971

Fabio1971

    InsanelyMac Legend

  • Moderators
  • 6,309 posts
  • Gender:Male
  • Location:Italy
Ciao usa HDA Wizard lo trovi sul forum internazionale

#5
i-NG

i-NG

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Trieste, Italy
Allora ho seguito la guida, ho installato le kext e funziona il 2.0.
Ho riseguito la guida, abilitato HDA dal dsdt.aml e aggiornato tramite terminale ma il risultato non cambia.
Schermata 12-2455916 alle 12.04.50.png
Schermata 12-2455916 alle 12.06.09.png

#6
Fabio1971

Fabio1971

    InsanelyMac Legend

  • Moderators
  • 6,309 posts
  • Gender:Male
  • Location:Italy
Devi patchare l'AppleHDA da terminale :
sudo perl -pi -e 's|\x85\x08\xec\x10|\x88\x08\xec\x10|g' /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA

#7
i-NG

i-NG

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Trieste, Italy
Ricapitolando:
- ho scaricato questo file [ LINK ] ALC1200+HDA
- ho rimosso AppleHDA.kext da S/L/E (system/library/extensions)
- ho installato AppleHDA.kext modificata tramite KEXTWIZARD
- ho creato e modificato dsdt.aml del mio bios inserendo la modifica in

SCOPE _SB >

Device PCI0 >

Device HDEF


- ho digitato sudo perl -pi -e 's|\x85\x08\xec\x10|\x88\x08\xec\x10|g' /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA

da terminale


- ho riavviato ma ancora non funziona... -.-' in compenso lo spegnimento lo fa perfetto (e prima non lo faceva così)



#8
Fabio1971

Fabio1971

    InsanelyMac Legend

  • Moderators
  • 6,309 posts
  • Gender:Male
  • Location:Italy
Non devi eliminare Applehda.kext
Hai possibilita' di recuperarlo e installarlo in S/L/E
La modifica al dsdt ho letto che l'hai fatta
Allora scarica HDA Wizard aprilo vedrai ALC1200 con i tre file da patchare
Devi inserire i tre file che ti indica HDA Wizard che sarebbero quelli di Applehda.kext
Finito devi da terminale patchare con il comando che ti ho passato
Riavvia





Also tagged with one or more of these keywords: P5Q Pro, Alc1200, 7.1surround, AppleHDA.kext

  Topic Stats Last Post Info

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy