Jump to content

Voodohda + HDMI sound Nvidia GT 420M ?

acer 5742 g voodohda hdmi

  • Please log in to reply
No replies to this topic

#1
fc bayern

fc bayern

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 214 posts
  • Gender:Male
  • Location:Macedonia
I have a super lappy Acer 5742 g ,running perfectly Lion 10.7.2.Everything works perfect :
Intel i5 460 m(generate p & c states)
Nvidia GT 420m(graphisc enabler=yes, Use Nvidiarom=Yes)
Atheros 9285 wifi,
broadcom lan,
brightness levels
sleep
VGA @ HDMI picture out
sound (voodohda, sound + mic works perfectly)
batery indicator shown in Istat menu 3.19
etc etc....
EXCEPT HDMI sound out together with Soundcard
I have tried all the voodohda versions(0.2.1 ; 0.2.2 ; 0.2.5.6 ; 0.2.6.1 - this one Im currently using ; 0.2.6.2 ; 0.2.7.2 ; 0.2.7.3 ), with all versions less or more I've managed to get HDMI output showned in sound system preferences(also changed in MIDI setup the bitrate to 48.000), but with no one I've menaged to have both sound card + HDMI working together .The only time HDMI works is when I put only the the IOPCIMatch from the Nvidia HDMI (that is 0x0bea10de), i get four digital outs and on the second one - the HDMI works -but no Sound card and mic . This I've tried with VoodoHDA versions 0.2.6.1 and 0.2.5.6 , and with both version HDMI works, but only HDMI, not the Soundcard.
When i edit the voodohda with my Intel HD chipset - <key>IOPCIPrimaryMatch</key>
<string>0x3b568086</string> I get only the Soundcard>
When I add another personality for the nvidia HDMI
<key>IOPCIPrimaryMatch</key>
<string>0x0bea10de</string> I get Digital out in System properties Sound but no HDMI sound.
With only the personality from Nvidia 0x0bea10de , i get only the HDMI out.
This is the only thing not working on my Acer lappy, Im using the HDMI out to connect my lappy to Sony bravia LED.
Have someone managed to get HDMI out working at the same time with the Soundcard thaht is fully working VoodoHDA , pls post back.
Here my voodohda info.plist (0.2.6.1 version of voodohda):

<key>CFBundleDevelopmentRegion</key>
<string>English</string>
<key>CFBundleExecutable</key>
<string>VoodooHDA</string>
<key>CFBundleIdentifier</key>
<string>org.voodoo.driver.VoodooHDA</string>
<key>CFBundleInfoDictionaryVersion</key>
<string>6.0</string>
<key>CFBundleName</key>
<string>VoodooHDA</string>
<key>CFBundlePackageType</key>
<string>KEXT</string>
<key>CFBundleShortVersionString</key>
<string>0.2.61</string>
<key>CFBundleSignature</key>
<string>????</string>
<key>CFBundleVersion</key>
<string>0.2.61</string>
<key>IOKitPersonalities</key>
<dict>
<key>SoundCard</key>
<dict>
<key>CFBundleIdentifier</key>
<string>org.voodoo.driver.VoodooHDA</string>
<key>IOClass</key>
<string>VoodooHDADevice</string>
<key>IOMatchCategory</key>
<string>VoodooHDADevice</string>
<key>IOPCIPrimaryMatch</key>
<string>0x3b568086</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>IOUserClientClass</key>
<string>VoodooHDAUserClient</string>
<key>MixerValues</key>
<dict>
<key>Mic</key>
<string>70</string>
<key>iGain</key>
<string>0</string>
<key>iMix</key>
<string>70</string>
</dict>
<key>NodesToPatch</key>
<array/>
<key>VoodooHDAVerboseLevel</key>
<integer>0</integer>
</dict>
<key>VoodooHDAHDMI</key>
<dict>
<key>CFBundleIdentifier</key>
<string>org.voodoo.driver.VoodooHDA</string>
<key>IOClass</key>
<string>VoodooHDADevice</string>
<key>IOMatchCategory</key>
<string>VoodooHDADevice</string>
<key>IOPCIPrimaryMatch</key>
<string>0x0bea10de</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>IOUserClientClass</key>
<string>VoodooHDAUserClient</string>
<key>NodesToPatch</key>
<array/>
<key>VoodooHDAVerboseLevel</key>
<integer>0</integer>
</dict>
</dict>
<key>OSBundleLibraries</key>
<dict>
<key>com.apple.iokit.IOAudioFamily</key>
<string>1.1fc9</string>
<key>com.apple.iokit.IOPCIFamily</key>
<string>2.1</string>
<key>com.apple.kpi.iokit</key>
<string>9.0.0</string>
<key>com.apple.kpi.libkern</key>
<string>9.0.0</string>
<key>com.apple.kpi.mach</key>
<string>9.0.0</string>
<key>com.apple.kpi.unsupported</key>
<string>9.0.0</string>
</dict>
If someone has an idea , I would be most thankful, been trying for monts to get HDMI sound + Soundcard out working.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy