Jump to content

Anyone with LION on Dell Precision 690 ? -Yes ME :)

Dell Precision 690 Lion

  • Please log in to reply
31 replies to this topic

#21
Tinkergnome

Tinkergnome

    InsanelyMac Protégé

  • Donators
  • 30 posts
  • Gender:Male
  • Location:Pensacola, Fl
Could someone give me a little help I have a 690 dual 5150 xeons 2Gb ram and a zotac 9600gt 512m graphics card.
I have been using various differnt distrubitions as i am unable to get Nawcoms modcd and the retail disk to work.
Typically I end up with a black screen when the system reboots after having to use -v -f flags. I have tried using PCIRootUID=0 and 1 as well as GraphicsEnabler=yes and no with no success. Any ideas would be greatly appriciated.

#22
silicman

silicman

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Could someone give me a little help I have a 690 dual 5150 xeons 2Gb ram and a zotac 9600gt 512m graphics card.
I have been using various differnt distrubitions as i am unable to get Nawcoms modcd and the retail disk to work.
Typically I end up with a black screen when the system reboots after having to use -v -f flags. I have tried using PCIRootUID=0 and 1 as well as GraphicsEnabler=yes and no with no success. Any ideas would be greatly appriciated.




* Install Mountain Lion 10.8.0 > Update to 10.8.2


1. use MyHack 3.2 make usb install key from RETAIL Mountain Lion 10.8.0 source (download from App store).

2. Install the os

3. Install essential kext (Extra folder, DSDT, boot.plist, chameleon, driver for via, audio, network,…)


- FakeSMC.kext : MUST install

- Patched_10.7_AppleRTC.kext : prevent CMOS reset.

- EvOreboot.kext:

….


4. Install the update to up 10.8.2 (DON'T restart the computer)

5. Run MyHack 3.2 > run MyFix > wait till finished

6. Restart the computer.


Done.



* Issue:

Unable to sign in because of a problem communicating with iCloud. thats the message I get when I try to sign in.


Everything is fine... but can someone give me working LAN kext?


My LAN kext is Broadcom BCM5752, I not sure if it likes yours. Try my modded kext.


Put the AppleBCM5701Ethernet.kext and replace the original one inside IONetworkingFamily.kext (the IONetworkingFamily.kext kext which get in S/L/E of 10.8.2)


OR you can mod it yourself.


This is the BCM5722D kext, made by Adlan

http://www.insanelym...river-3264-bit/


I added the device id for the BCM5752 (14e4 1600). This is the network chip that is inside the Dell Precision 490

When you add your device ID, it works (maybe) with this models to:
It should support the following models:
BCM5754
BCM5754M
BCM5755
BCM5755M
BCM5787
BCM5787M #
BCM5906 #
BCM5906M #

Attached Files



#23
shogunofharlom

shogunofharlom

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male

I scored an 8-core dell precision 690, 4gb or ram for $40 the other day!
I installed retail 10.6.4 using ibuut+multibist, windows 7 and linux on it. However, in osX 10.6.4 I have no network and no audio and my 7300gt graphics are wonky.
You guys did help me get my storage working though! Any tips on getting the other stuff going?

btw, I want to keep 10.6.4 cause I have PPC Adobe Creative Suite 2 and I want to keep using it for a little while longer and 10.7 Lion would eat it.
I tried voodoo for audio but I am using the older multibiist and it did not work. Can I use multibiist for lion and not kill my 10.6 install?

Lastly, is everyone here booting to a pata drive ... or just me?

Checkout my vid ...
http://youtu.be/ObYSeMpYPsM

#24
Tinkergnome

Tinkergnome

    InsanelyMac Protégé

  • Donators
  • 30 posts
  • Gender:Male
  • Location:Pensacola, Fl
Hey Shogun here is the kext i use for audio and network they work well i just have issue with the network not showing as built in which i am working on sorting out shortly. hopefully. as far as audio i did have to select my output device and sound effect device as showing the green plug vs my hdmi on my graphics card hope this helps

https://dl.dropboxus...32/690_kext.zip

#25
shogunofharlom

shogunofharlom

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
Thanks man, however, I did get my audio working using voodoohda 2.5.6. Gonna try your networking kext asap. Was gonna buy a usb mini wireless n, but maybe I will put that dough towards a 6670 or something like that. I hear they work oob.

#26
Tinkergnome

Tinkergnome

    InsanelyMac Protégé

  • Donators
  • 30 posts
  • Gender:Male
  • Location:Pensacola, Fl
I think the voodoohda that is in the zip is 2.7it seems to work quite nicely. I have an Asus hd6670 i got from newegg for around 60 i think http://www.newegg.co...N82E16814121442 it has went up by 10 dollars it seems but it appears to work oob for the most part. Just on a 10.8 install remove the ati6000controller.kext or you will get screwed up graphics. Toss it in your extra folder on your usb drive to get around that. Boot with "-f -v maxmem=4096 GraphicsEnabler=yes" and you should be golden. Upon completing your OSX install run kextwizard and install the saved file. I am getting help with the network card and DSDT files. When i get that i will end up making a 10.8 install guide and throw the files up along with the org.chameleon.boot.plist and smbios.plist that i have used. Hopefully that will help others out and keep from spending the weeks of research that I did to cobble the pieces together. If you want them before i make the guide let me know. Hopefully when the dsdt is finished my SAS drive will not show up with a funky remeovalbe icon.

#27
shogunofharlom

shogunofharlom

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
My Ethernet is working bro! I have a real computer here now. Very tempting to use this as my everyday machine. I looked at the asus card, but it is a bit pricey and I don't want to spend much money on this machine. Any thoughts on a gt240? I hear they are oob as well. I spotted one on ebay for $30.

#28
Tinkergnome

Tinkergnome

    InsanelyMac Protégé

  • Donators
  • 30 posts
  • Gender:Male
  • Location:Pensacola, Fl
i have never been a big fan of Nvidia products so i have no idea but the asus card is well worth it as far as power to compliment the rest of the hardware. Side note i do have 2 3Ghz x2 procs and 4 512 1Rx8 pc2 sticks of ram to get rid of if they will help you any. Glad the ethernet is working for you

#29
shogunofharlom

shogunofharlom

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
are those dual or quad-core procs? I could totally use the ram though! oh yeah, just got my graphics working after a morning of hard work. running a asus 210 sient 1gb i got for $30. had to use had to edit com.apple.boot.plist using osx86 tools. acceleration is working and i can now watch dvds. running at 1080p. I now have a fully functioning customac thanks to you guys

#30
Tinkergnome

Tinkergnome

    InsanelyMac Protégé

  • Donators
  • 30 posts
  • Gender:Male
  • Location:Pensacola, Fl
they are dual core procs. The ram is this http://www.ebay.com/...=item257db8d5ec could do 10 and ill cover shipping if you want

#31
queglay

queglay

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

Hey everyone.

 

I recently got Mountain Lion going on a T5400 dual proc machine, so thought I'd try my luck on a Precision 690.  Much harder!

I have a Zotac GTX 660 which I know works in the T5400.   I disabled PATA in the bios and using S3 power save mode.

 

I was hoping to go the myHack way with 10.8 but I get a black screen after the kexts load with nothing.  This is using

-f -v UseKernelCache=No

and tried PCIRootUID=0 and 1

 

I tried using iAtkos 10.8.2, but i get a kernel panic on install after kexts are loaded.  Heres a video I recorded-

using-

-f -v UseKernelCache=No

 

Thanks for any tips or pointers that might send me on the right path!



#32
queglay

queglay

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

Could anyone who has a working build please chime in on their bios versions that they are using?  I'm trying to decide which one to update with but think im going to run with A07.

im running A00 so hopefully that is my problem.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy