Jump to content

ALC8XX Audio Stuttering / shuttering sound fix!


  • Please log in to reply
8 replies to this topic

#1
dlambert

dlambert

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:Galien, Michigan
  • Interests:Computers, Hacking
All of you that have band choppy sound using VoodooHDA, Azalia, or even AppleHDA now have a fix!

I've tried a TON of kexts, with no joy (yes even the idlehalt=0 kernel flag). But i came across a post with a simple command that fixes it. So i made it as a script and ran it as a login item, and now i have perfect sound!!


The command, although I'm sure there are others you can use to keep your CPU a little busy is:

yes > /dev/null

Just make that into a script! and Enjoy!

In the Terminal, create a new file: (ignore ">")
> touch test <ENTER>

Edit that file:
> pico test <ENTER>

Start off by showing it is a shell script:
> #!/bin/sh
> "yes > /dev/null"

Save and exit:
CTRL-O <ENTER>, CTRL-X <ENTER>

Now, make it executable:
> chmod -x test <ENTER>

Test it:
> ./test <ENTER> (if you typed "say hello", your Mac would really say "Hello" to you.

In the Finder you can put ".command" at the end of "test".
If you do that, your script will open the Terminal and run it.

Then make it a login item! If I screwed up let me know! I added & after the command to make it run in the background, and then kill to close the terminal window.
Feel free to post any other commands that can be used! (I'd like to improve upon this too!)


#2
dlambert

dlambert

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:Galien, Michigan
  • Interests:Computers, Hacking
Any other scripts that will just cause a little activity? not alot

#3
cmitch33

cmitch33

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Ok I get thru this to ./test and I get permission denied. Any ideas on how get past this? I know it's something easy but can't figure out what it is.

#4
Mr Props

Mr Props

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
@cmitch33: type "chmod 755 test" in terminal, then it will work!

@dlambert: your script reduces stuttering, but its not completly fixed :( maybe a "harder" script? Thank you alot!

#5
cmitch33

cmitch33

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
@Mr Props Thanks that worked but I'm having the same issue as you. It helped but its still kinda bad even after changing the midi settings.

#6
danageis

danageis

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Works if it uses enough cpu. I have my sound working only if I run it while only using 1 core of my cpu (cpus=1 kernel flag in org.chameleon.Boot.plist) or if I open multiple terminal windows and run 'yes > /dev/null' in each one (to get good sound with all 3 cores in use I need to run the command in 4 windows).

Not the most glamorous solution, but it works, and on my system running with 1 core still give fairly decent performance.

Also there should be some clarification:
This command is NOT a small CPU drain: it will use 100% of each CPU core for every instance it is run. For this reason I do not recommend running it at startup and keeping it going continuously. What I did was create a script like the one listed here to initiate the cpu usage, and another to stop it. the command 'killall yes' will effectively stop this script and bring cpu usage back down to normal levels.

I put both of these scripts in my dock and run each when I start/stop using sound.

I want to thankyou very much for this thread as I too have been trying for a long time to get my sound working, and I hope my additions on this topic will be helpful to others as well :)

P.S. Also to anyone having trouble making the test script yes > /dev/null should not be put in quotation marks

#7
danageis

danageis

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
So I don't entirely understand why this fix works in the first place, but I assume since the 'yes' processes are using all the cpu % and this fixes the sound, is the sound problem due to a process causing sound skipping when it is allowed to use too much cpu?

If so, would this help? http://www.willnolan...puthrottle.html

It's a terminal tool that limits a process to only using a set % of the cpu. I've been testing it out and it is quite effective. Would this be in any way useful towards solving the problem without using 100% cpu at all times in OS X?

#8
Neolo

Neolo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
Jesus... I was almost crazy while searching anything about this bug with voodoohda, finally found al least something here.
This temp solution with CPU load is completely {censored}. I wont load CPU while listening something, especially on laptop running from battery.
Does anybody reported this to voodoo devs? Does anybody tried to swith to AppleHDA without getting this problem?
I have ALC269, so it's cross codec problem, and I assume because AMD CPU? I didn't see anybody with this problem on Intel cpu.
So idlehalt=0 - does nothing, and I don't have in my bios Cool'n'Quiet switch cause I'm on a Aser Aspire 5553G Laptop.

#9
dlambert

dlambert

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:Galien, Michigan
  • Interests:Computers, Hacking
Sorry guys, I have since bought an Intel CPU. But i tried to find a command line task that only ran just enough to make this fix work. I know it's not effiencent. That's why I gave up. -Dlambert





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy