Jump to content

IBM thinkpad T40p


  • Please log in to reply
6 replies to this topic

#1
mikedv6500

mikedv6500

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:Rhode Island
  • Interests:music and computers =)
i would greatly appreciate it if someone could explain to me if i should give up trying to find a wifi fix for my t40p. i have searched these threads for days to find absolutley nothing on a wifi kext or fix for my Philips 11107 wifi card and alternately no useful threads that tell me weather or not an updated osx version will fix this problem. i have however seen that IO80211family.kext works for some thinkpad t41, t42, t60, x60, x31's etc but not others, nowhere have i seen it working on a t40 or t40p. so im kind of at a loss and frustrated. i had an HP dv6605us running osx86 10.5.6 and got everything working in the past by simply scanning threads in this forum, sadly i must have just purchased the wrong model thinkpad.

running Jas 10.4.8 everything running but bluetooth and wifi, not too worried about bluetooth just want my wifi!
any other info needed just ask
TIA (pardon my broken english im slightly retarded i live in rhode island lol)

#2
mikedv6500

mikedv6500

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:Rhode Island
  • Interests:music and computers =)
bump

#3
mikedv6500

mikedv6500

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:Rhode Island
  • Interests:music and computers =)
well this site is not as helpfull as i remember

#4
mikedv6500

mikedv6500

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:Rhode Island
  • Interests:music and computers =)
welp im online via my ethernet jack still no luck with wifi any help is still appreciated

#5
mikedv6500

mikedv6500

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:Rhode Island
  • Interests:music and computers =)
tried swapping the wireless card out with a broadcom card from an old compaq presario 2565us but the bios tells me it is a non authorized wireless device and will not let me boot into osx. i have had luck getting broadcom devices working in the past with my dv6605us but no luck with ibm's strict hardware support. i originally pulled my hp's wireless card out thinking i would be able to use that but that was also a nogo. my hp's card was a mini pci card and not compatible with the older hardware on the ibm. again if anyone has any suggestions it would be awesome to hear them. feels like im talking to myself here.

#6
mikedv6500

mikedv6500

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:Rhode Island
  • Interests:music and computers =)
well this forum has proved to me that it is absolutely useless to try and gather help from others in this community.

#7
davidgurvich

davidgurvich

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
There are a couple of different issues that you have. The first is using a non-ibm branded internal wireless card. That can be done but requires a BIOS hack to get around the error. There's an extensive explanation on the thinkwiki website.

I recommend getting an external USB ralink wireless adapter. Here's a link http://www.ralinktec...port.php?sn=502 to the OSX drivers. You may notice that the older PCI drivers are not supported on recent versions of OSX. Don't get one of those.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy