Jump to content

[Asus U36SD] - a few dsdt questions


  • Please log in to reply
126 replies to this topic

#121
Widefirearm

Widefirearm

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

hey guys, i'm very new to the hackintosh thing

 

sorry for the long post, but i want to give you as much info as possible

if there is still something you want to know, just ask.

 

i also do have an asus u36sd

the model number is U36SD-RX254V (probably it helps)

 

i already installed mavericks 10.9.4, and it works, but not quite as i want it to.

what works out of the box (and what i tested): 

- keyboard

- touchpad (but no multitouch, so no two finger scroll, just the scrolling on the right side of the pad with one finger)

- shutting down and booting (but just with the aid of the bootable stick, there is no bootloader)

- ethernet

 

what does not work (but what i need):

- wifi (x)

- multitouch (x) (for two finger scroll at least, i don't need gesture support)

- sound (x) (speakers and headphone jack)

- sleep / suspend mode (x)

- battery (x)

- can't set the right time zone, always goes back to the default setting

- fn keys (working partially: brightness keys working, volume buttons not working, rest not needed)

 

not tested:

- usb 3.0 (port works, but i don't know if it's using full usb 3.0 speed, but i don't really mind)

- bluetooth (not needed)

- nvidia chip (not really needed, but would be nice, if it worked)

- card reader (not needed)

- hdmi out (would be nice)

- vga out (would be nice)

 

 

i found already some threads. they mostly contain some links to files but i don't really know what to do with them.

could somebody explain me or link me how i can enable my needed functions (marked with an "x"), please?

 

i already tried three times with ##### and some of the files contained in this thread, but every time i broke something and had to start over.

 

hardware info:

cpu: intel core i3 2310m (##### doesnt offer a ssdt for it)

gpu: intel hd 3000, nvidia gt 520m

ram: 4gb original

ssd: samsung 840 (used for linux)

hdd (over usb 3.0): hitachi original 320 gb drive



#122
radargb

radargb

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
  • Gender:Male
  • Location:Krakow, Poland

Yosemite beta is out so i think its time for little update!

 

Yesterday i did fresh install of Yosemite BETA1. 

Prepared installer using this great tool:

http://www.insanelym...-yosemite-beta/

Very easy and fast way to make bootable usb stick!

 

After that ive copied config.plist, patched DSDT and SSDT im using to boot my Mountain Lion partition.

Installation went very smooth. Didnt have to set any of boot arguments.

 

After installation keyboard and touchpad didnt work so ive had to use usb set.

Finally i got to desktop and could install all needed kexts. 

 

Kexts ive used was actually the same im using in MountainLion:
- ApplePS2Trackpad.kext - for touchpad

- ApplePS2Controller.kext - for keyboard and ASUS fn keys

- AppleHDA.kext, IOAudioFamily.kext - for audio

- AppleACPIPlatform, AppleSmartBatteryManager.kext - for battery

- AppleIntelSNBGraphicsFB.kext - for VGA (this is the only 10.10 kext ive installed so far)

 

At the moment i have working full QE/CI with VGA out, wifi, battery, sound, keyboard and touchpad with multitouch.

Today i will try to install kexts for USB3.0, card reader and LAN.

 

There is also very few issues:

- Strange glitches on boot when Apple logo goes to login screen (problem doesnt occur when external monitor is connected) - i will post image later

- Sometimes im having graphic glitches, pretty similar to those i had in MountainLion sometimes but much more. I was searching internet to find solution and looks like the issue is connected somehow with clover. Will search for solution and post here if i find one.

 

I can attach used kexts if needed.

 

Good hack!



#123
Widefirearm

Widefirearm

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

hey radargb,

i would be glad, if you could post your config.plist, dsdt, ssdt and used kexts

 

my u36sd has a core i3-2310m built in, but perhaps i can tweak the dsdt and ssdt so it matches my cpu



#124
Claudio A.

Claudio A.

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:buenos aires

Hi @radargb, I agree, if you can share with us all the files it would be great, did you solve the glitches problem?



#125
radargb

radargb

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
  • Gender:Male
  • Location:Krakow, Poland

Well, i have finally solved both glitches problems ;))

 

Iv managed to fix glitches on boot using solution from this post:
http://www.insanelym...itches-on-boot/

Basically you have to patch iographicsfamily.kext.

 

Another problem - screen artifacts.  I realised that i missed "slide=0" argument. After adding this everything works like a charm!

 

Im kind of busy at the moment and still didnt try to sort out USB3.0, LAN and card reader.

 

Im attaching kexts im using and config.plist.

There is no point to share dsdt and ssdt because of hardware differences.

 

Attached File  kexts YOSEMITE.zip   2.25MB   14 downloads



#126
Claudio A.

Claudio A.

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:buenos aires

Hi all, anyone tried to do a clean install using 10.10? It would be awesome to hear how it went!

 

Thanks a lot!



#127
Claudio A.

Claudio A.

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:buenos aires
I've managed to installed 10.10 and it seems to be working great.
 
Steps (this is not a detailed guide :)):
  • Prepared usb installer (using www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-yosemite/). It was a little more complicated than usual because extracting the kernel file required a specific version of pacifist).
  • Chameleon Enoch R2403 
  • @alianyn dsdt
  • Patched installer to install on mbr.
  • Removed Nvidia Kexts.
  • Usual kexts for a  10.10 usb installer (NullCPUPowerManagement, etc)
Results:
  • Sound: was not working ok:, so I needed to install voodohda. Is not working perfect but is good enough.
  • Battery: Worke with https://github.com/R...-Battery-Driver.
  • Wifi: Was not working initially, so I needed to add device id in AirPortAtheros40.kext/Contents/Info.plist 
  • Power management: used ssdtPRGen to generate SSDT, DropSSDT=yes, GenerateCStates=No, GeneratePStates=No, removed NullCPUPowerManagement.kext.zip. Everything seems to be working ok, but I feel that the cpus are too hot, something like 60C idle... Any hints on how to verify if this is working correctly?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy