Jump to content

Hp nc6320 Lion 10.7.2 Intel GMA 950 LCD off problem


  • Please log in to reply
3 replies to this topic

#1
basharem

basharem

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hello all

I am new (a week old) in this Hackintosh issue but quite old in IT (12 years of Linux/Windows System Admin/It Manager experince).

I got my Old laptop HP nc 6320, to install Lion by iAtkos L1 by disabling dual core and VT from bios flawlessly. I downloaded update pack from Mac no problems there too. After boot all I needed vas Voodoo PS2 and Voodoo Battery. Even my fingerprint reader works... Else I did not care (Lan, Card reader etc...)

I had display res issues Latest Chamelon fixed that, I have full res,No CI/QE in 64 bits.
Display blacks out in after successful boot in 32 bits. Could anybody help or point me in the right direction I am going mad over this?

Update: I can confirm via VNC that the only problem is LCD being off. QE/CI 3d all work under 32 bits

As far as I understand Lion has latest kexts for GMA950 so I should not overwrite them from anything from web. Also I had full res QE/CI once on SL with a mixture of some random kexts from all over the web in 32bits. Never could make it there again... ;)

Is there any way I can motivate anybody to make us 950 GMA 27a2 users a driver for 64 bits ?

Thank you in advance for any clues...

Also Stable Dual Core would be nice to have...


My hw info:

8086:27a2 Intel Corparation Mobile 945GM /GMS, 943/940GML Express Integrated Graphics Controller :D
8086:2448 Intel Corparation 82801 Mobile PCI Bridge - OOB OK
104c:8039 Texas Istruments PCIxx12 Cardbus Controller - Don't care
14e4:169c Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet - Don't care
104c:803d Texas Istruments PCIxx12 GemCore based SmartCard controller - Don't care
104c:803c Texas Istruments PCIxx12 SDA Standart Compliant SD Host Controller - Don't care
104c:803b Texas Istruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) - Don't care
104c:803a Texas Istruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller Works (who needs it?)
8086:27b9 Intel Corparation 82801GBM (ICH7-M) LPC Interface Bridge - OOB OK
8086:27df Intel Corparation 82801G (ICH7 Family) IDE Controller - OOB OK
8086:27c8 Intel Corparation N10/ICH7 Family USB UHCI Controller - OOB OK
8086:27c9 Intel Corparation N10/ICH 7 Family USB UHCI Controller - OOB OK
8086:27ca Intel Corparation N10/ICH 7 Family USB UHCI Controller - OOB OK
8086:27cb Intel Corparation N10/ICH 7 Family USB UHCI Controller - OOB OK
8086:27cc Intel Corparation N10/ICH 7 Family USB2 EHCI Controller - OOB OK
8086:27d0 Intel Corparation N10/ICH 7 Family PCI Express Port 1 - OOB OK
14e4:4312 Broadcom Corporation BCM4312 802.11a/b/g - OOB OK
8086:27d4 Intel Corparation N10/ICH 7 Family PCI Express Port 3 - Don't care
8086:27d6 Intel Corparation N10/ICH 7 Family PCI Express Port 4 - Don't care
8086:27d8 Intel Corparation N10/ICH 7 Family High Definition Audio Controller Works (Voodoo HDA)
8086:27c5 Intel Corparation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (Disabled Sata) Works
8086:27da Intel Corparation N10/ICH 7 Family SMBus Controller Fan Issues
8086:27a6 Intel Corparation Mobile 945GM /GMS/GME, 943/940GML Express Integrated Graphics Controller
8086:27a0 Intel Corparation Mobile 945GM /PM/GMS, 943/940GML and 945GT Express Memory Controller

#2
basharem

basharem

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Some update,

if I boot arch=i386 I get a black (off) LCD. If I press the thingy that tells the laptop the lid is closed and release it I get display for a split second. So some how my LCD is turned off after the GUI loads. VGA out is also fxcked up (don't care)

I tested my theory through vnc. QE,CI etc everything works fine except the LCD is off. Any ideas to turn it on ? Changing the resolution does not help...

Pretty please ;) ???

Fans are ok since I disabled full power when plugged in through the bios... :)

#3
KinkyxD

KinkyxD

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
i have exactly same problem, and the same laptop, i haven't figured out whats wrong , but i installed some snow leopard kext's and its working. just search for GMA950-945 kext on google and you'll find it in Osx86.net i think :D but would be great with a full support of it for lion .

#4
elfox

elfox

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
I know it's an old thread, but hoping someone can help.

I've been trying to install iAtkos L2 (have tried other methods with the same result) on nc6320. All I am getting is black screen when using -v. I've tried all combinations of boot parameters I have come across with the same result.

The boot begins with a few lines going by (too fast for me to see), then the screen clears and goes black. At that point my only option is the power button to turn off the laptop. Caps Lock doesn't respond.

I have 10.6.8 on the laptop running fairly well, but just can't get past the install problem for Lion.

I see people have been able to get through it - can someone help please?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy