Jump to content

[Help] ALC888 with OSX Lion 10.7.2


  • Please log in to reply
4 replies to this topic

#1
quis

quis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts
Back in 10.7.1 I used #####'s rollback AppleHDA+ALC8xx+HDAEnabler, and everything worked really well.
After I update to 10.7.2 though, ##### failed to revive my audio; even tried re-installing 10.7.2 combo and re-install ##### but still to no avail...

Anyone got their ALC888 working on 10.7.2? Please share. Thx!

#2
quis

quis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts

Back in 10.7.1 I used #####'s rollback AppleHDA+ALC8xx+HDAEnabler, and everything worked really well.
After I update to 10.7.2 though, ##### failed to revive my audio; even tried re-installing 10.7.2 combo and re-install ##### but still to no avail...

Anyone got their ALC888 working on 10.7.2? Please share. Thx!


Bump. Anyone? :(

#3
bonebox

bonebox

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I'm having the same problem with my ALC889a after updating to 10.7.2. The OS is no longer recognizing the card.

#4
bonebox

bonebox

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Just wanted to add that a temporary workaround until someone figures this out is to use the VoodooHDA driver instead.

Delete the following files:

/System/Library/Extensions/HDAEnabler889a.kext
/System/Library/Extensions/ALC8xxHDA.kext

Run ##### and check the following boxes. Install and reboot.

System Utilities -> Rebuild Caches
Drivers & Bootloaders -> Kexts & Enablers -> Audio -> Universal -> VoodooHDA 0.2.7.3

This got my sound working again, although I did notice a hissing sound at higher ranges. Going into the VoodooHDA system preferences and checking the "Use SSE2" box seems to have fixed it.

Note: If you have the ALC888 your enabler file will be "HDAEnabler888.kext" instead of "HDAEnabler889a.kext", so you'll need to delete that instead. I've only tested it for the ALC889a so can't verify that it will work for the ALC888 but theoretically it should.

#5
elkotur

elkotur

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
I finally got ALC888 working under 10.7.4 Lion, the sound is clear but sometimes I hear scratch. I think the only definitive solution is a usb soundcard.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy