Jump to content

Boot0:GPT boot0:error


  • Please log in to reply
18 replies to this topic

#1
RecluTa

RecluTa

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
Hola a todos,
el otro dia traté de instalar hackintosh en un ordenador de estas características:
ASUS Barebone V7-P8H67
Intel i7 2600
8GB de RAM DDR3 1333MHz
Gráfica HD2000 (integrada en el procesador)

Probé de instalarlo del mismo modo que lo instale en mi ordenador (exactamente el mismo, pero con el i5 2500 y una grafica ATI Radeon HD6870). Lo que hago para instalar es lo siguiente:
Inserto Andy Boot CD
Arranco el Mac OS X - Snow Leopard (el original, nada de iAtkos, no cosas de esas)
Instalo el SandyBridge
Instalo algunos kexts desde el #####
Instalo el contenido del AndyBoot CD

Y al arrancar (sin CD) me da el siguiente error:
Boot0: test
Boot0: GPT
Boot0: test
Boot0: test
Boot0: error

Alguien tiene alguna idea?? he probado instalando Chimera, Chameleon y nada, puede ser un tema de particiones o algo por el estilo?

Muchas gracias

#2
pgsubuntu

pgsubuntu

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 228 posts
  • Gender:Male
  • Location:Argentina
Es problema del boot, tal vez tu partición de mac no sea la primera, o estas instalando chameleon o chimera en la partición equivocada.

#3
RecluTa

RecluTa

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
He mirado en el hackintosh que tengo funcionando actualmente con el comando "ls /dev/rdisk*" y me saca esto:
/dev/rdisk0
/dev/rdisk0s2
/dev/rdisk1
/dev/rdisk1s2
/dev/rdisk0s1
/dev/rdisk0s3
/dev/rdisk1s1

En cambio en el que no funciona saca esto otro:
/dev/rdisk0
/dev/rdisk0s2
/dev/rdisk0s4
/dev/rdisk1s1
/dev/rdisk1s1s2
/dev/rdisk0s1
/dev/rdisk0s3
/dev/rdisk1
/dev/rdisk1s1s1

me paracen raro /dev/rdisk1s1s1 y /dev/rdisk1s1s2 puede que sea eso? si es así... como lo arreglo?
respecto a instalar chameleon y chimera ya me fijo que se instalen en la partición donde esta Mac OS X!

#4
pgsubuntu

pgsubuntu

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 228 posts
  • Gender:Male
  • Location:Argentina
jamas edite el archivo boot.

donde tenes instalado chameleon? en la misma partición que Snow? o en una partion EFI?

agregaste o cambiaste alguna unidad de lugar?

tenes instalado snow en la primer particion del disco? (esto soluciona muchos problemas de boot)

#5
RecluTa

RecluTa

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
Para instalar hice 3 particiones. La primera formateada en Mac Os X plus con registro que es la que actualmente contiene Snow Leopard, otra formateada con FAT32 y la ultima como espacio libre.
Chameleon esta instalado en la misma partición que Snow Leopard, nada de particiones EFI, de hecho no se lo que son ni donde están! No cambié ninguna unidad de lugar, cosa rara rara!

#6
pgsubuntu

pgsubuntu

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 228 posts
  • Gender:Male
  • Location:Argentina
El disco de Snow esta en el conector sata 0? o sata 1? ... invertilos de lugar.

sino como ultimo recurso trata de instalar otra versión de chameleon.

no se si afectara en algo el espacio no particionado.... :unsure:

#7
RecluTa

RecluTa

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
gracias por la ayuda, intentare cambiar el sata, por cierto, no tendra nada que ver que sea SATA 6GB/s?

#8
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,424 posts
  • Gender:Male
  • Location:Tru, Venezuela
Bueno compañeros cabe recordar que ese error es típico cuando el HDD no posee ninguna partición ACTIVA, lo cual es indispensable para que cualquier disco sea booteable o autoarrancable. En ese sentido, siempre sugiero instalar el bootloader C2RC5 (chameleon 2.1) con la app Chameleon Wizard, usando la opción Boot0 se activará la partición seleccionada... Pero NO es la opción recomendada para multiboot, dual boot, triple boot, o como se llame... en su lugar se debería usar Boot0hfs o Boot0md, es mi caso porque tengo Lion, Snow & Windows (como ACTIVA) en el mismo HDD. Saludos.

Nota importante: Es recomendable desconectar todos los demás discos antes de instalar el bootloader en el HDD principal.

#9
RecluTa

RecluTa

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
Muchisimas gracias! Voy a probarlo y os digo!

#10
pmcnano

pmcnano

    Preguntaaame caom!

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,114 posts
  • Gender:Male
  • Location:Merida, Mexico
Curiosidad, que modelo de disco duro estas usando :D?

#11
RecluTa

RecluTa

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
He probado con todo lo que me habéis dicho y no funciona.
Eld isco duro que uso es un: WD Caviar Green WD10EARX.

#12
pmcnano

pmcnano

    Preguntaaame caom!

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,114 posts
  • Gender:Male
  • Location:Merida, Mexico
Hola Recluta gracias por responder. Lamentablemente no vas a poder bootear desde ese disco duro :(!

Ya cheque la ficha tecnica:

http://www.wdc.com/w...2879-701229.pdf

Este disco duro maneja "Advanced Format" esto quiere decir que sus sectores son de 4kb en vez de 512bytes. Los bootloaders actuales no soportan dicho "formato" por lo cual el bootloader no carga. De hecho si se escribe, pero se borra a los 20 segundos. De hecho si quieres hacer una prueba para confirmar. INstala el chameleon con la utilidad que quieras (Chameleon Wizard si quieres) y va a estar medio drastico esto, pero apenas se instale.......resetea tu computadora a ver si bootea, lo mas seguro es que si bootee porque te digo que tarda unos 20 segundos en borrarse.

Arme hace como 1 mes una computadora y compré un disco duro de 500GB, tuve el mismo problema. No se puede hacer nada por ahora. Lo que pudieras hacer es arrancar desde una memoria USB si quisieras, pero es algo muy tedioso. Asi que si, de ahora en adelante te recomendaría checar la ficha tecnica antes de comprar un disco duro para hackintosh!

Saludos =)

#13
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,424 posts
  • Gender:Male
  • Location:Tru, Venezuela

Hola Recluta gracias por responder. Lamentablemente no vas a poder bootear desde ese disco duro :(!

Ya cheque la ficha tecnica:

http://www.wdc.com/w...2879-701229.pdf

Este disco duro maneja "Advanced Format" esto quiere decir que sus sectores son de 4kb en vez de 512bytes. Los bootloaders actuales no soportan dicho "formato" por lo cual el bootloader no carga. De hecho si se escribe, pero se borra a los 20 segundos. De hecho si quieres hacer una prueba para confirmar. INstala el chameleon con la utilidad que quieras (Chameleon Wizard si quieres) y va a estar medio drastico esto, pero apenas se instale.......resetea tu computadora a ver si bootea, lo mas seguro es que si bootee porque te digo que tarda unos 20 segundos en borrarse.

Arme hace como 1 mes una computadora y compré un disco duro de 500GB, tuve el mismo problema. No se puede hacer nada por ahora. Lo que pudieras hacer es arrancar desde una memoria USB si quisieras, pero es algo muy tedioso. Asi que si, de ahora en adelante te recomendaría checar la ficha tecnica antes de comprar un disco duro para hackintosh!

Saludos =)

De hecho eso NO es del todo cierto compañero, porque mi disco duro por ejemplo, al igual que todos los que soportan "Advanced Format Technology", salen de fabrica listos para el esquema GPT (Guid Partition Table) de Mac OS X. En todo caso sólo requieren ser formateados para instalar windows XP, por ser un S.O. antiguo para dicha tecnología, y luego también necesitan ser alineados a través de la aplicación que se puede descargar en la web de WD. Pero ese es otro tema, porque dicha limitación no aplica en lo absoluto con los bootloaders actuales con sus opciones Boot0hfs y Boot0md. En ese sentido, simplemente lo que hice fue conectarlo, hacer el esquema GPT (con todas sus particiones) y comenzar a instalar: Lion, Snow y windows7, es importante que sea en ese orden, PERO HABIENDO "ACTIVADO" PREVIAMENTE LA PARTICIÓN DE WINDOWS JUSTO ANTES DE INSTALARLO. Por lo tanto, según mi experiencia básicamente siempre he seguido este procedimiento incluso desde que usaba dual boot con XP (kizwan en mi firma). En conclusión, no tuve ningún problema cuando hice la instalación y triple boot en mi HDD WD5000BPVT... siendo lo lógico porque vienen preparados para que la experiencia de instalación y uso sea más fácil y rápida. Por cierto, he realizado pruebas del bootloader Chameleon 2.1 tanto en la primera (disk0s2) como la segunda (disk0s3) partición, y arranca perfecto. NO he probado desde la EFI. Saludos.

#14
pmcnano

pmcnano

    Preguntaaame caom!

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,114 posts
  • Gender:Male
  • Location:Merida, Mexico
http://forum.voodoop...php?topic=568.0

http://www.insanelym...howtopic=267191

http://tonymacx86.co...a...97&start=10

http://tonymacx86.co...p?f=119&t=18765

Puede se que tengas suerte, pero no se puede. no en GUID. Aparentemente en MBR si, pero no lo comprobe yo.

#15
Derty

Derty

    InsanelyMacaholic

  • Donators
  • 3,165 posts
  • Gender:Male
he tenido un problema similar con un WD green de 1,5 Tb, no me agarraba el boot sector, me daba errores según el arranque, quise actualizar el chameleon y me decía que seguía con el anterior..., a veces booteaba a veces no... al final deje el WD 500 black edition como arranque....

pero no se quien de los dos va por la senda correcta, o ambos claro.

o sea no aporto nada útil... a jajaja

miren incluso reformateado y particionado me quedaron sectores inestables....

Nombre : WDC WD15EADS-00P8B0 Media
Tipo : Disco

Esquema del mapa de particiones : Tabla de particiones GUID
Identificador del disco : disk2
Nombre de los soportes : WDC WD15EADS-00P8B0 Media
Tipo de contenido : Genérico
Bus de conexión : SATA
Árbol de dispositivos : IODeviceTree:/PCI0/SATA@1F,2/PRT4@4/PMP@0
Grabable : Sí
Expulsable : No
Ubicación : Interna
Capacidad total : 1,5 TB (1.500.301.910.016 bytes)
Número del disco : 2
Número de partición : 0
Estado S.M.A.R.T. : Verificado
Frecuencia de errores RAW : 000000000000
Tiempo de giro : 0000000016D1
Número de inicios/paradas : 000000000CE3
Sectores reasignados : 000000000000
Frecuencia de errores de búsqueda : 000000000000
Horas en funcionamiento : 00000000188D
Intentos de giros : 000000000000
Intentos de calibración : 000000000000
Temperatura de HDD : 000000000020
Eventos de sectores reasignados : 000000000000
Sectores inestables : 000000000002
Sectores incorregibles de exploración sin conexión : 000000000000
Frecuencia de errores de CRC : 000000000000
Frecuencia de errores multizona : 000000000000

#16
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,424 posts
  • Gender:Male
  • Location:Tru, Venezuela

Puede se que tengas suerte, pero no se puede. no en GUID. Aparentemente en MBR si, pero no lo comprobe yo.

No vale jajaja, nada de suerte... SI se puede, esto es Full GPT: dual y triple boot sin problemas... hay que hacer las cosas bien, eso es todo. En tres discos diferentes (un amigo en España y otro en Ecuador) con el mismo resultado, eso es suerte? A menos que sea un problema exclusivo y común en los discos de desktop, NO de portátil. Sólo suponiendo, claro. Saludos.
Attached File  Captura_de_pantalla_2011_10_17_a_la_s__14.13.44.png   102.8KB   65 downloads

#17
pmcnano

pmcnano

    Preguntaaame caom!

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,114 posts
  • Gender:Male
  • Location:Merida, Mexico
Es cuestión de que haga la prueba que le dije, es eso, o utilizar los comandos de dd if=/dev/xx of/dev bl abla. Despues de escribir el chameleon, esperas 20 segundos y se borran los sectores del boot. Lo intente miles de veces, siempre pasaba lo mismo.

La única manera de bootear es como le comenté que podia probar. Instalar el chameleon y resetear a la mala. Repito, como el tiempo que se queda guardado el boot es como de 20 segundos, da tiempo de cargar el chameleon antes de que se borre de nuevo.

Saludos

edito: para que no haya mas dudas, según todo lo que lei, el problema es definitivamente el advanced format. PERO, por alguna razón en algunos discos funciona. Y para terminar, comentó que yo simplemente compré otro disco duro, misma marca, misma capacidad, solo el modelo sin advanced format y funciono perfecto.

#18
RecluTa

RecluTa

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
Al final uso un HDD: WD SATA 300 de 160 GB
Con este no llego a tanto. Después de instalar el Snow Leopard mediante Andy Boot me sale la típica pantalla en blanco con la manzanita, pero de allí no pasa. Alguna idea?

#19
pmcnano

pmcnano

    Preguntaaame caom!

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,114 posts
  • Gender:Male
  • Location:Merida, Mexico
Inicia en verbose mode ( -v ) y checa en donde se te esta trabando!

Saludos





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy