Jump to content

[Risolto] Dual Boot Win7/Lion e problema AHCI mode


  • Please log in to reply
9 replies to this topic

#1
lupomike

lupomike

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
Ciao a tutti.

La mia configurazione del pc dovrebbe prevedere la simultanea presenza di due hd, uno per Windows 7 (che avevo già installato) e l'altro con Lion 10.7 che pochi giorni fa sono riuscito ad installare con il metodo della chiavetta descritto in questo forum.

Per precauzione quando ho installato Lion sul secondo hd avevo scollegato l'altro, quello con windows 7. Una volta messo a punto Lion ho ricollegato tutti e due e scopro che Windows 7 funziona solo se nel bios la funzione AHCI mode è disabilitata; viceversa Lion non ne vuole sapere di partire (mi si blocca con un kp) se la suddetta modalità non è attiva.

E che faccio ora? Mica posso ogni volta entrare nel bios e modificare il settaggio!
C'è un kext che permette a Lion di avviarsi senza che la modalità ahci sia attiva?
O forse devo cambiare bootloader (ho messo il Chameleon 2.0 RC5)?

:)

#2
eros74

eros74

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:paese dell'amore
reinstalla windows con ahci abilitato

#3
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 8,092 posts
  • Gender:Male
  • Location:Italy
ciao prova a dare un occhiata QUI sotto utility trovi guide per dual boot

#4
pianman

pianman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 404 posts
  • Gender:Male
Ciao Lupomike,

non so se può servirti, ma nella guida postata da j.sparrow su come installare snow leopard su asus p5q pro turbo (la guida puoi trovarla cercando nell'indice delle guide), nel pacchetto da lui postato c'era un file .reg che serviva a win 7 per cancellare i driver per gli hd in uso ed installare quelli in achi. Fai in questa maniera: scarica il pacchetto dalla guida, avvia win 7 con gli hd settatti non in achi, clicca 2 volte sul file .reg e alla domanda rispondi si, riavvia il pc e setta nel bios gli hd in achi e provi ad avviare win 7. Dovrebbe funzionare senza che reinstalli tutto. Facci sapere.

#5
lupomike

lupomike

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
Grande pianman!!

Ha funzionato!

Al riavvio mi ha installato i driver ahci: ora il bios è settato in ahci mode e non lo tocco più!

Grazie mille a tutti!!

:(

#6
pianman

pianman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 404 posts
  • Gender:Male

Grande pianman!!

Ha funzionato!

Al riavvio mi ha installato i driver ahci: ora il bios è settato in ahci mode e non lo tocco più!

Grazie mille a tutti!!

:)



Di nulla, è stato un piacere.

#7
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,042 posts
  • Gender:Male
  • Location:Roma

Domanda

 

io ho istallato tutto in ide native e funge bene tutto

 

pero' se imposto i registri di win 7 in ahci, parte win 7

ma non partono  ne lion ne mavericks mi danno un bel kernel panic

cè modo di poter impostare anche osx in ahci senza reistallare?

 

grazie in anticipo



#8
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,791 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Domanda

 

io ho istallato tutto in ide native e funge bene tutto

 

pero' se imposto i registri di win 7 in ahci, parte win 7

ma non partono  ne lion ne mavericks mi danno un bel kernel panic

cè modo di poter impostare anche osx in ahci senza reistallare?

 

grazie in anticipo

Bisogna vedere il panic, ma penso sia legato ad un kext per rendere compatibile OS X con la modalità non-AHCI



#9
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,042 posts
  • Gender:Male
  • Location:Roma

sai quale potrebbe essere?

nel panic non li vedo

 faccio un po' di prove e vediamo

 

Grazie carbo ;)



#10
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,791 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Vedi se hai installato uno di questi:

JMicron36xATA

AppleIntelPIIXATA2







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy