Jump to content

Workstation 8/9/10, Player 4/5/6 and Fusion 4/5/6 Mac OS X Unlocker


  • Please log in to reply
518 replies to this topic

#501
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,964 posts
  • Gender:Male
  • Location:Manchester UK

Ah we have a common theme Comodo AV. I will install a copy and see if that breaks my test VM. 

 

Yep  Comodo is the problem. You will need to whitelist unlocker.exe in the Comodo Behaviour Blocker or add it to the trusted files list.

 

(Have to say I think it is a pretty obnoxious piece of software, it's installer will put crapware on if you don't read the instructions correctly)



#502
Daveythetechy

Daveythetechy

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Yep  Comodo is the problem. You will need to whitelist unlocker.exe in the Comodo Behaviour Blocker or add it to the trusted files list.

 

(Have to say I think it is a pretty obnoxious piece of software, it's installer will put crapware on if you don't read the instructions correctly)

I uninstalled Comodo and the install.cmd worked, disabling the antivirus didnt work.



#503
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,964 posts
  • Gender:Male
  • Location:Manchester UK

I uninstalled Comodo and the install.cmd worked, disabling the antivirus didnt work.

 

Great. At least we know what the problem is and how to solve it.



#504
wilsonb

wilsonb

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
  • Gender:Male
  • Location:Austin, Texas

Man, thank you so much for figuring out our mishaps.. Iv'e been struggling with this for months now. I even messed with file permissions (and prob screwed them up)

I am now happily back in business with Kali and Mac OS 10.9.1

 

I disabled and killed EVERY Comando firewall service running. Ran the Unlock 1.3 without a problem.

I personally like Comando and avoided to bloatware during install. 

 

Just in case anyone else gets this;

"You have started vmware server with an out-of-date copy of the application" , but researching I found this and fixed it. (You have to add the line to every VM )

http://binyit.blogsp...are-server.html

 

 

Thank you!!!!



#505
Sikh

Sikh

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Yep  Comodo is the problem. You will need to whitelist unlocker.exe in the Comodo Behaviour Blocker or add it to the trusted files list.

 

(Have to say I think it is a pretty obnoxious piece of software, it's installer will put crapware on if you don't read the instructions correctly)

 

I agree but its also free so you can't really blame them. Atleast the crapware / bloatware is just more stuff from them and "privdog" is the only third party utility. At least its not like most companies with the ask bar and {censored} bar and whatever else.

 

Surprising thing is, since I've used comodo for years, I know i've had to whitelist my own programs I've built and some patches, so I believe I whitelisted unlocked.exe already and that didn't work for me too. But ill try that again and report back..

 

Again thanks for the help and I'm glad I could help find the issue. Always forget about AV but thats because I'm mostly a linux / os x user and dislike windows for anything but gaming



#506
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,964 posts
  • Gender:Male
  • Location:Manchester UK

I agree but its also free so you can't really blame them. Atleast the crapware / bloatware is just more stuff from them and "privdog" is the only third party utility. At least its not like most companies with the ask bar and {censored} bar and whatever else.
 
Surprising thing is, since I've used comodo for years, I know i've had to whitelist my own programs I've built and some patches, so I believe I whitelisted unlocked.exe already and that didn't work for me too. But ill try that again and report back..
 
Again thanks for the help and I'm glad I could help find the issue. Always forget about AV but thats because I'm mostly a linux / os x user and dislike windows for anything but gaming


On the plus side it does have a very good hit rate on malware. Like you I am mainly OS X but job also involves coding on Windows and Linux.

Anyway glad we got it resolved. Thanks for bearing with me as we worked it out.

#507
Sikh

Sikh

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

On the plus side it does have a very good hit rate on malware. Like you I am mainly OS X but job also involves coding on Windows and Linux.

Anyway glad we got it resolved. Thanks for bearing with me as we worked it out.

 

So my problem WAS comodo. Even after checking my trusted files, adjusting my behavior exclusions etc nothing. So I stopped the service, restart, ran the patcher, it worked, set the service to start, restarted and bam fully functionally VMware Workstation.

 

Thanks for being here to debug. I respect developers that support all of their projects. Ive met / seen developers put out something like this and NOT support it by being available because "its so simple it should always work and if it doesnt its the user" and while thats true on windows half of the time, its sometime conflicting calls or old code that does it too.

 

Im glad theres another OS X user out there. Getting sick of people saying OS X is for "noobs and the rich". I love OS X for the GUI and Unix Core. Ill always have OS X as client / desktop and unix / linux as backend / servers.



#508
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,964 posts
  • Gender:Male
  • Location:Manchester UK

So my problem WAS comodo. Even after checking my trusted files, adjusting my behavior exclusions etc nothing. So I stopped the service, restart, ran the patcher, it worked, set the service to start, restarted and bam fully functionally VMware Workstation.

 

Thanks for being here to debug. I respect developers that support all of their projects. Ive met / seen developers put out something like this and NOT support it by being available because "its so simple it should always work and if it doesnt its the user" and while thats true on windows half of the time, its sometime conflicting calls or old code that does it too.

 

Im glad theres another OS X user out there. Getting sick of people saying OS X is for "noobs and the rich". I love OS X for the GUI and Unix Core. Ill always have OS X as client / desktop and unix / linux as backend / servers.

 

Excellent - pleased you have it working.

 

Appreciate the comments, and agree that support is important. I have been in commercial software development for 26 years, and research software development for five years before that, and unless you help people use what you create you may as well not bother releasing it in the first place.



#509
davidm71

davidm71

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 167 posts
  • Gender:Male

Hi,

 

New to Unlocker. Installed it onto VMware WS 10 and installed Mavericks. Afterwards installed the VMWare Tools package that was included and noticed that at boot up the spinning wheel at bottom of apple grey screen has a black bar over it. Its probably a graphical anomoly and no big deal but thought to inform anyone interested..

 

Thanks.



#510
yucattan

yucattan

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Thank you so much!



#511
davidm71

davidm71

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 167 posts
  • Gender:Male

That black bar goes away after installing updated video kexts for vmware workstation. FYI.



#512
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,964 posts
  • Gender:Male
  • Location:Manchester UK
Bad news! 
 
VMware have removed the mechanisms used in the patcher to override the SMC and OS X Server checks in new Tech Preview of Workstation 11 and Fusion 7. May have to go back to adding FakeSMC to installation images.
 
Will keep looking but in the meantime do not use the Tech Previews if you want to have OS X guest compatibility.
 
Sorry for posting twice but important news if you rely on the unlocker, Started a thread here.

 

http://www.insanelym...cker/?p=2022388



#513
hidra

hidra

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Oh my God, you are my hero!!!!!!!!!

 

Has been 2 weeks scratching my head, then the solution is rather simple   :drool:



#514
trungpt

trungpt

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

VMware workstation has been updated to 10.0.3. Can anyone confirm it work well with VMware Unlocker v1.3?

 

Thanks in advance.



#515
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 954 posts
  • Gender:Male
  • Location:Darlington UK

VMware workstation has been updated to 10.0.3. Can anyone confirm it work well with VMware Unlocker v1.3?

 

Thanks in advance.

Yes, upgraded to Workstation 10.0.3 and all is well with OS X, since the install process un-installs the previous version as part of the "upgrade" process, the unlocker (1.3.0) needs to be re-installed once the "upgrade" to 10.0.3 has completed. I always do a cold re-boot after a workstation "upgrade" and applying the unlocker, and follow the unlocker install with another cold re-boot, just to make sure all the networking and services are running correctly.

 

This is a duplicate of my post in the following topic:

 

http://www.insanelym...r-56/?p=1936143



#516
netgear

netgear

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male

New unlocker Yosemite...



#517
wilsonb

wilsonb

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
  • Gender:Male
  • Location:Austin, Texas

New unlocker Yosemite...

What does that mean? Are you stating or asking ?

Newer than Version 1.3.0 ?



#518
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 954 posts
  • Gender:Male
  • Location:Darlington UK

New unlocker Yosemite...

The current unlocker 1.3.0 works fine with Yosemite as a Virtual Machine under Workstation 10.0.3, Player 6.0.3 and Fusion 6.0.4, no unlocker support for Fusion 7.0.0.



#519
netgear

netgear

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male

Ok thanks.







4 user(s) are reading this topic

0 members, 4 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy