Jump to content

OpenCL Oceanwave & Bandwidth Bench - 07. March 2013

OpenCL AMD NVIDIA

  • Please log in to reply
343 replies to this topic

#141
DarkUser89

DarkUser89

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 307 posts
  • Gender:Male
  • Location:Germany / Saarbrücken
Posted Image

Q9400 OC2,72GHz
4GB
Zotac GTX 560
MacPro 3,1
10.7.2

#142
Eiszeit

Eiszeit

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
Q6600
HD5450
10.7.2

Attached Files



#143
Shamsu

Shamsu

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
i5-2500
8 GB
GTX 560 Ti
10.7.2
/Users/shamsu/Desktop/Screen Shot 2011-12-28 at 10.00.00 PM.png

OpenCL Oceanwave GPU Benchmark

393.78 FPS

#144
bergoulle

bergoulle

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
Q9400 P5K with AMD6850 ...Attached File  HD6850.tiff   421.61KB   22 downloads

#145
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Thanks , i will update the main list (and app) soon but less frequently than in the past, because we already have lots of results collected.

#146
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,713 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
hy
i've the gtx 460m.. I can have a semistable qe/ci.. but very slow cinebench
so this bench is slow too..
I never see thos hex values in my opencl binary..
I tried to add my devid to nvda100 kext (mine is 10de 0dd1 but.. strange.. I run 1920x1080 without nvda100 !

so what can I do if I have not those hex id in opencl.. ?
where the complete guide also for the dylib ?

#147
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
slow Cinebench tells that also OpenGL is slow.
Perhaps some GPU Powermanagement Problems (gpu runs always on slow MHz, even on load) which does effect both: OpenGL + OpenCL performance
Check + ask:
http://www.insanelym...howtopic=266036
For OpenCL Fermi patching check + ask:
http://www.insanelym...pic=266318&st=0

#148
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,713 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
ok. thanks
i'll discover your posts

apart from it.. I know I cannot 'force the hand' for this driver because everywhere in the net I see that the 460m gtx got frozen after a while.. but only when opengl is invoked
and I tried to replace dp4-->10.7.2..
injecting the 100nvda drv..
injecting the AGPD
and tring to replace with some original invidia driver or cuda driver.

but in 3 days I got (except for black screens or no good starts) only 1 running benchmarks in opengl

and that's ..for me.. a great great goal! (better than anything ok)

so .. i'll try yours

thanks

#149
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
NEW OpenCL Luxmark Bench 2.0 Beta (now with submit result + new SCala scene). Very good (comlex gpu computing) OpenCL Benchmark.

I made an new thread for your results. You can look after the submitted results (fpr 2.0x Version only) but there are only the Top 20 listed.
I got 77 - to slow for the Top 20 ;)

Luxmark 2.0 OS X86 Thread:

http://www.insanelym...howtopic=274549

#150
tilllt

tilllt

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
i have two CUDA / OpenCl capable cards in my machine. How do i specifically run the benchmark on either one of them?

#151
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
You can not select the gpu used. Only if the benches have some code to select the gpu you would so this.
Luxmark for example will use automatic all known OpenCL gpus found - at least it will work if they (all) are from same vendor.
EDIT: In Luxmark V2.0B2 you can select the gpu(s) which you want to use or not. Try that.
YOu must set LUXMARK (after starting) in pause mode (Menue) and then select the gpus on the right side then use in menue "use selected CPU/GPU) and unpause the benchmark again.

#152
Ritz Carltn

Ritz Carltn

    Ritz Carltn

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Interests:HP EliteBook 8540p,i7-820QM, 68CVD Ver F.0F, nVidia NVS5100M, ML with Clover

My results :)



is it good? Or can i do something to improve my fps? Thanks!!


How did you configure GTX 550 Ti in 10.7.2? do you share me the way?

#153
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Mac OS X 10.8 DP1:
My 9600 GT works with OpenCL but shows not correct result.
If you also have DP1 for test please check OceanWave with it.
(Screenshoot mad with the command line OceanWave, but App shows same result - wrong)

Attached Files



#154
stefano.85

stefano.85

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Male
  • Location:Italy

Mac OS X 10.8 DP1:
My 9600 GT works with OpenCL but shows not correct result.
If you also have DP1 for test please check OceanWave with it.
(Screenshoot mad with the command line OceanWave, but App shows same result - wrong)


Same here
Attached File  Schermata 02-2455976 alle 19.39.37.png   520.73KB   29 downloads

#155
diskeeper

diskeeper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
The GeForceGLDriver "78 E8 83 F8 02 7C 11" hex for Fermi cards is not here anymore in 10.8.

#156
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
I researched a bit the problem with 10.8 and OceanWave.
I recomplied it with Xcode 4.4 and OS X 10.8 Frameworks and removed some optimizations (more GLflush than than before).
Now it works again, but results with that version cant be compared with old results because they are little (10% in my case) slower.
I will upload an new 10.8 Version (only will run on 10.8!) soon and attatch it at 1. posting.

#157
diskeeper

diskeeper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male

The GeForceGLDriver "78 E8 83 F8 02 7C 11" hex for Fermi cards is not here anymore in 10.8.


I checked with oclinfo, and says OpenCL works on my GTX460 (without any modifications!).

1 OpenCL platform found!
...
2 OpenCL devices found!
[Device 0]
Name:	Intel(R) Core(TM)2 Quad CPU	Q8300  @ 2.50GHz
Vendor:   Intel
Type:	CPU
Device Version:  OpenCL 1.1
Driver Version:  1.1
Compute Units:   4
Work Group Size:  1024
Clock:	2499 MHz
Global Memory (Total):  4096 MB
Global Memory (Host):  4096 MB
Global Memory (PCIe):  0 MB
Local Memory:   32 KB
Cache Size:   0.0625 KB
Cache Line Size:  2097152 Bytes
Available:   Yes
Double-Precision:  Yes
Extensions: ...
[Device 1]
Name:	GeForce GTX 460
Vendor:   NVIDIA
Type:	GPU
Device Version:  OpenCL 1.1
Driver Version:  CLH 1.0
Compute Units:   14
Work Group Size:  1024
Clock:	1526 MHz
Global Memory:   1024 MB
Local Memory:   48 KB
Cache Size:   0 KB
Cache Line Size:  0 Bytes
Available:   Yes
Double-Precision:  No
Extensions: ...
[shared OpenCL+OpenGL Context]
2 OpenCL devices found!
[Device 0]
Name:	GeForce GTX 460
Vendor:   NVIDIA
Type:	GPU
Device Version:  OpenCL 1.1
Driver Version:  CLH 1.0
Compute Units:   14
Work Group Size:  1024
Clock:	1526 MHz
Global Memory:   1024 MB
Local Memory:   48 KB
Cache Size:   0 KB
Cache Line Size:  0 Bytes
Available:   Yes
Double-Precision:  No
Extensions: ...
[Device 1]
Name:	Intel(R) Core(TM)2 Quad CPU	Q8300  @ 2.50GHz
Vendor:   Intel
Type:	CPU
Device Version:  OpenCL 1.1
Driver Version:  1.1
Compute Units:   4
Work Group Size:  1024
Clock:	2499 MHz
Global Memory (Total):  4096 MB
Global Memory (Host):  4096 MB
Global Memory (PCIe):  0 MB
Local Memory:   32 KB
Cache Size:   0.0625 KB
Cache Line Size:  2097152 Bytes
Available:   Yes
Double-Precision:  Yes
Extensions: ...


#158
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Great!
Some AMD have problems (other than the only cosmetic glitch) , they get OpenCL init failed.
I mad an new OceanWave_ML Mountain Lion ONLY!!! version. Wasnt easy, because it was not only OpenCL 10.8 SDK recompile action, also OpenGL seems to be changed much (also GLUT). Therefor i must enable multisampling to avoid that glitch (flashing + wrong OpenGL window).
The results with multisampling enabled cant be compared with the older version - the slower the gpu the more fps diff between both.
My 9600 GT gone down from 104 to 89 fps using multisampling. Faster gpu may not have that much diff. Diff comes because gpu has a bit more to do - beside OpenCL it must also do the opengl display - and multisampling does take some more gpu time - at least for slow gpus.

OceanWave_ML Mountain Lion ONLY!!! - wont run 10.6 / 10.7
you may need to setup mail account first, if you want to submit results.

Attached Files



#159
diskeeper

diskeeper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
With new Mountain Lion version on EVGA GTX460 SC:

Attached Files



#160
Atomic999

Atomic999

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
Results on 10.7.3 for my 560TI-448 on Q6600/8GB, GA-X38-DS5:

428,43 FPS

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy