Jump to content

nf 208/210 marvell yukon ethernet


  • Please log in to reply
No replies to this topic

#1
andi10

andi10

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
NF 208 loads up straight away with Hazard distro

webcam works

Bluetooth works

Trackpad without using Voodoo kext

Add voodoo power for battery

  • Card Reader works but is not recognised in System Profiler
  • The WiFi will not and probably neverwork because it shares a module with Bluetooth, I cannot switch of Bluetooth but I reckon if I could then the WiFi would work.
I tried everything I even wrote a new kext for the WiFi but it just does not get recognised ever.

Sound is a problem Larsen Effect Not solved it on this the sound is ALC269 everything gets Larson effect(feedback through Mic)



I have tried most solutions and modified kexts no luck

I used Netinstaller 0.8 and this identifies the graphics correctly Intel 3150 but Res stuck @ 800x640 as no one has made drivers

  • Marvel Yukon kext file for Samsung NF208/210 family and Dell M1530

    Ok the easiest way to get this to work instead of replacing the whole kext of Apple Yukon 2 in the IONetworking Family is to go in and change the info.plist

Your card in NF208/210 and maybe 310 is the same as well as Dell M1530In the Samsung models it sees your ethernet but will not connect this is due to the wrong card being recognised.Usually the Z model

So add in your card :

<key>Yukon-88E8040</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.iokit.AppleYukon2</string>
<key>EnableLowPwr</key>
<integer>1</integer>
<key>IOClass</key>
<string>yukon2osx</string>
<key>IOPCIPrimaryMatch</key>
<string>0x435411ab</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>MACNumber</key>
<integer>1</integer>
<key>Model</key>
<string>Yukon Gigabit Adapter 88E8040 Singleport Copper SA</string>
<key>NetworkNumber</key>
<integer>1</integer>
<key>RxDeadman</key>
<integer>0</integer>
<key>RxRingGrowOnPause</key>
<integer>10</integer>
<key>RxRingSize</key>
<integer>0</integer>
<key>RxRingSize_100MBit</key>
<integer>128</integer>
<key>RxRingSize_10MBit</key>
<integer>64</integer>
<key>RxRingSize_GigaBit</key>
<integer>256</integer>
<key>TxRingSize</key>
<integer>256</integer>
<key>Vendor</key>
<string>Marvell</string>
</dict>

After you add in this sometimes the card will be identified as the Y series or your 0 series both connect

I guess it would be easy to delete the Z and Y but that's up to you.the string of the Y is <string>0x435A11ab</string> you can see how OSx makes mistakes the 4 and A being confused for one another!

Copy Plist to desktop edit it replace original Dont close window, run Kext utility to repair permissions.

Reboot

As far as the sound goes I used a Voodoo Installer the one that gives Larsen effect it instals 2.0.6.2 temproraily got rid of Larsen effect by simply plugging a jack into the extenal mic plug, also if you plug in a mic no feedback and it works i think its the mic being set to close to the trackpad, i'm no longer using voodoo trackpad kext as it is not required but am using voodoo power kext for battery





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy