Jump to content

ESXi 5 Mac OS X Unlocker


  • Please log in to reply
803 replies to this topic

#161
sebus

sebus

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 299 posts
  • Gender:Male
  • Location:UK
As I said, without reboot, only /etc/init.d/hostd restart on the affected host DOES allow VM boot or VM vMotion (same host that few seconds before gave general error)

As per this post

sebus

#162
sledgehammer89

sledgehammer89

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
A new ESXi update is released! Does anyone know if the Unlocker 1.0.2 still works and whether the SCSI kernel bug (10.7.2) is fixed? Thanks!

#163
sebus

sebus

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 299 posts
  • Gender:Male
  • Location:UK
And what does that mean? Still only on Apple hardware?

http://kb.vmware.com/kb/2007671

Deployment Considerations

This patch enables support for Mac OS X 10.7 and Mac OS X 10.7.1.
Mac OS X 10.7.2 is not supported by this patch release

#164
sledgehammer89

sledgehammer89

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
I'm just installing ESXi5 in VMware 8 and will try the ESXi update and unlocker. If that works I'll do that on my ESXi running 10.7.2, take a snapshot and install 10.7.2 again without the older 10.7.1 scsi kernel module. "One moment please"...


Edit: I'm back.

The good thing: Unlocker (1.0.2) works with this ESXi update (20111201).
The bad thing: after reinstall 10.7.2, Lion don't boot :(

The downgrade to 10.7.1 AppleLSI.. module is still required...

#165
strannik6

strannik6

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
confirm.
1.0.2 Unlocker works with last ESXi updates. And Lion 10.7.2 with 10.7.1 AppleLSI works too.

#166
sebus

sebus

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 299 posts
  • Gender:Male
  • Location:UK
Unlocker works (at least it runs, inserts the correct wording and makes changes, so Mac can be chosen as OS to install), but my SL Server 10.6.8 will not start on this updated host

General System Error Occured. The virtual machine could not start

.vmx did not change since before update

sebus

Attached Files

  • Attached File  sl.txt   2.95KB   17 downloads


#167
strannik6

strannik6

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Unlocker works (at least it runs, inserts the correct wording and makes changes, so Mac can be chosen as OS to install), but my SL Server 10.6.8 will not start on this updated host

General System Error Occured. The virtual machine could not start

.vmx did not change since before update

sebus


detach ESXi from vCenter and after reboot try again....just to be sure that it's patch, not vCenter.

#168
sebus

sebus

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 299 posts
  • Gender:Male
  • Location:UK
But one does NOT start Mac from vCenter, but from direct connection to the host

Anyway, this VM now does not even start on the previous ESX5i patch (which worked last week)

sebus

EDIT

It is "fascinating"! I stopped usbarbitrator service (as it takes WAYYYYY to long on services restart or ESX boot)
Mac SL config has USB (and hid connected to it)
So without usbarbitrator instead of nice clean error message it just throws the general UGLY one!

That is on build 504890 as well as current build 515841

Starting usbarbitrator on the host makes the VM boot as normal

So Vmware needs to work on error messages!!!!! or checking config & NOT allow something that simply can not work

#169
f0rd42

f0rd42

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hi

I followed all the guidelines and was able to get the installer booting from USB on ESXi 5 :wink2:

My problem is now, that it seems that the Keyboard doesn't work (as does the mouse).
When I come to the first installer screen (choose language), I can't anywhere and also arrow keys or enter seems to be not accepted.

ESXi 5 standalone, vcenter on Windows 7 (virtual on my mac).

Works fine in all other VMs, but not in Mac OS X Lion install screen ...

any help is highly appreciated.

f0rd42

ps: THanks to Donk and all other for the great work!

#170
f0rd42

f0rd42

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
strange ..... could use mouse and keyboard after a while, so seems ok now.

new problem ...

can't see my 40GB Disk in the Install process.

I launched terminal and all I can see is the 4GB USB Stick and the RAM Disks (Screenshot attached).

I used the default in ESX for the disk (also attached)

Am I missing something?

Thanks

f0rd42

Attached Files



#171
infor_mare

infor_mare

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
This is my first post .. hello

I try to install Lion on my whitebox ESXi 5.0 (amd phenom x6).
The esxi works very well, but if i try it after the unlocker procedure , i have a message like screen1.
I have used: Lion and SL with the same problem.
I'm trying with: Boot dvd (usb dvd) , boot usb key , iso dvd

can you help me?
thanks


ps: about the screen : in this case i'm using usb key with Lion. I have this message too in the events:
Message from ZZ.: The CPU has been disabled by
the guest operating system. Power off or reset
the virtual machine.
info
04/01/2012 10.52.43
LION
User

Attached Files



#172
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,071 posts
  • Gender:Male
  • Location:Manchester UK
Mac OS X does not run on AMD CPUs only Intel. There are mods to make it work but I have no experience of them, and can't really help.

#173
XinRen

XinRen

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Mac OS X does not run on AMD CPUs only Intel. There are mods to make it work but I have no experience of them, and can't really help.


But why Intel Xeon CPU E7420@2.13GHz need legacy_kernel-10.6.8.nawcom (SL) or mach_kernel_atom.10.7.1 (Lion) ?
So, now, My ESXi 5.0 server (HP ProLiant BL680c G5), canNot update Lion to 10.7.2, otherwise, hung up.

I can't understand why...

#174
dertbv

dertbv

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Was able to get 10.7 intalled with out to many headaches. How ever like the others 10.7.2 does not seem to boot. Any ideas on what we need to do to make it boot?
thanks

#175
ltickett

ltickett

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
I encountered a few issues when trying to run the lastest v1.0.2 on ESXi 5:

1) open failed Permission denied
2) sed: /bootbank/boot.cfg: No such file or directory

I fixed them by:

1) chmod 777 bin/*
2) touch /bootbank/boot.cfg

I blogged with details and an updated install.sh for anyone that's not comfortable able patching themselves: http://tickett.wordp...ker-1-0-2-esxi/

#176
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,071 posts
  • Gender:Male
  • Location:Manchester UK
It's in the reame file to chmod +x on the file. If you have no bootbank.cfg then sounds like there is something wrong as it is used by default ESXi boot.

Was able to get 10.7 intalled with out to many headaches. How ever like the others 10.7.2 does not seem to boot. Any ideas on what we need to do to make it boot?
thanks


You cannot install 10.7.2 on ESXi there is a bug in ESXi that causes a problem. 10.7.1 is only supported by VMware currently on ESXi on Apple hardware. Has been fixed for WOrkstation and Fusion and guess fix will be coming for ESXi. There are workarounds in the Wok station and Unlocker threads but you have to have a version installed prior to 10.7.2 to make it work.

#177
dertbv

dertbv

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Thanks for the info i will look around and see what i can find.

#178
waldrondigital

waldrondigital

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Thanks for the hard work on the ESXi unlocker, Donk! Still can't believe I'm looking at a VMware ESXi server installing Lion!!! :D

#179
infor_mare

infor_mare

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
hi
i have installed LION on ESXI5 with the unlocker in this forum. All seems good, the installation is finished with success.
But if i power on the VM , the VM remains on the apple logo.
what can i do to use this VM?

#180
Scott Knauss

Scott Knauss

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
OK, I've been using the unlock on my unpatched (from Vmware) esxi 5.0 install for several months. It's awesome. I only ever managed to get Leopard installed though. I've tried several times to upgrade it to snow leopard, but with no luck. That's not that big a deal as its only running itunes and serving videos to my Apple TV2s.

My question though is if it should work with more than one CPU. I'm using a Core2 Quad, but if I try to give the VM more than one CPU or more than one core, it hangs on boot? Is that normal?

Another oddity I ran in to, today I added two drives to my ESXi box. I had previously run all of my VMs from a local NAS, and decided to move them on to storgage hardrives on the ESXi host. My two Linux VMs moved fine, but the OSX would either fail to boot, or would hang almost immeditaly after booting. The copy on the NAS still works fine, so what the????

Thanks,





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy