Jump to content

OS X 10.7 (Lion) install on Dell Optiplex 745


  • Please log in to reply
119 replies to this topic

#1
client00

client00

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
For those interested in getting their Dell Optiplex 745 PC powered by the new Mac OS X 10.7 "Lion", here is the corresponding link to the osx86project wiki, I wrote this entry after successfully getting it to work.

osx86project wiki link for the Optiplex 745

Enjoy.

Please discuss any suggestions/solutions you have in mind.

Edit 17 Apr 2012
For quick results read post #64
Special thanks to my e-friend BugsB.

#2
The Vapper

The Vapper

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

For those interested in getting their Dell Optiplex 745 PC powered by the new Mac OS X 10.7 "Lion", here is the corresponding link to the osx86project wiki, I wrote this entry after successfully getting it to work.

osx86project wiki link for the Optiplex 745

Enjoy.

Please discuss any suggestions/solutions you have in mind.


I just wanted to say, client00, you ROCK! I would probably never have gotten Lion working on my Optiplex without your entry in the HCL. Thank you so much. Everything worked perfectly. I did have a bit of trouble getting the Ethernet adapter recognized, but that was because I was using an older version of the kext. You are awesome!

#3
sabur7

sabur7

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Atlanta
You mention several times about installing kexts in /E/E, but i have used the ##### installation method and don't have an /Extra folder on my installation. Is it okay to creat that folder or do I need to install all the mentioned kexts in /S/L/E?

#4
client00

client00

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

You mention several times about installing kexts in /E/E, but i have used the ##### installation method and don't have an /Extra folder on my installation. Is it okay to creat that folder or do I need to install all the mentioned kexts in /S/L/E?


Either way will work fine.
Reason for placing kexts in /E/E is mainly to keep those extra kexts neat and safe from system updates.
Some kexts require to be installed in /S/L/E, even though it has been reported they work fine when placed in /E/E.

In any case use Kext Wizard (or a similar utility) that will easily take care of repairing file permissions and rebuilding kext cache.

#5
Eds89

Eds89

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:Ipswich
Hi guys,

just curious, as I'm interested in getting a cheap optiplex for a small lion server Id like to set up.

I have seen one on ebay for like £50, has the usual c2d 1.86Ghz, 1gig of ram and about an 80gb hard drive.
However, the one I am looking at is the Ultra Small Form Factor (USFF), which only has integrated graphics with no expansion slots available.

Does anyone know if there is a working solution for the integrated GMA 3000 that this model has?

Id really like to get lion running on this box as it is super small and low powered.
As far as I'm aware, everything else will work correctly.

Will this be ok or will I need to go for the small or desktop form factor versions?

Thanks guys
Eds

#6
client00

client00

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

Does anyone know if there is a working solution for the integrated GMA 3000 that this model has?


Hello Eds.
As of now there is no working solution, you won't be able to even get proper screen resolution (max 1024x768) let alone have hardware acceleration (QE/CI). Needless to say, both are necessary to live the Mac OS X experience.
I've scoured the internet, no kext exists for this graphics controller because it is substantially different from other supported GPUs.
In other words you have to use an add-in PCI-e video card, which forces you to select an upgrade friendly form factor of the Optiplex.
Hope you get one cause they really are reliable machines ;-)

#7
Eds89

Eds89

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:Ipswich

QUOTE (Eds89 @ Nov 17 2011, 10:56 PM)
Does anyone know if there is a working solution for the integrated GMA 3000 that this model has?


Hello Eds.
As of now there is no working solution, you won't be able to even get proper screen resolution (max 1024x768) let alone have hardware acceleration (QE/CI). Needless to say, both are necessary to live the Mac OS X experience.
I've scoured the internet, no kext exists for this graphics controller because it is substantially different from other supported GPUs.
In other words you have to use an add-in PCI-e video card, which forces you to select an upgrade friendly form factor of the Optiplex.
Hope you get one cause they really are reliable machines ;-)


Hi Client,

Thanks for your response.
I've been trying to find some post somewhere, where somebody has attempted installation on this machine.

So far I've got the absolute basics working, it installs fine, and I can boot with the latest 2.1 build of chameleon, and an old IOATAFamily.kext, for the internal drive to be recognised, and have now found a next that works for the Broadcom 5754, although this does not get picked up as built in, therefore the AppStore won't let me sign in.

As for the video (GMA 3000), I have had zero success, and the ADI198 audio driver that i'm using (AppleAC97Codec198x.kext does not seem to work either.

I'm not fussed about the experience for this machine, as i intend for it to be a small, quiet and low powered file server, and I have a macbook and two other i7 hacks that work great. I'd just like to get audio and appstore sign in working and ill be content.

Can anyone point me in the direction of someone that has at least attempted this before?

Thanks
Eds

#8
client00

client00

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

So far I've got the absolute basics working, it installs fine, and I can boot with the latest 2.1 build of chameleon, and an old IOATAFamily.kext, for the internal drive to be recognised, and have now found a next that works for the Broadcom 5754, although this does not get picked up as built in, therefore the AppStore won't let me sign in.

As for the video (GMA 3000), I have had zero success, and the ADI198 audio driver that i'm using (AppleAC97Codec198x.kext does not seem to work either.

I'm not fussed about the experience for this machine, as i intend for it to be a small, quiet and low powered file server, and I have a macbook and two other i7 hacks that work great. I'd just like to get audio and appstore sign in working and ill be content.

Can anyone point me in the direction of someone that has at least attempted this before?

Thanks
Eds


Hello again.
As it's already been mentioned the GMA3100 won't work, so you can forget about it.
As for sound, take a look again at the wiki. You need the patched VoodooHDA kext I have uploaded. It's for ICH8 HD audio which I believe your 745 has (it's not AD1983).
Finally there is a solution for the Mac App Store login problem. Read the relative comment in the wiki. If you do not understand take a look at this post

#9
xk3r

xk3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Albuquerque, NM
I used iAtkos L2 (Lion 10.7.2) and works great.

Used the same as is in the pic:

Works: Sound, Network and Video card.
GeForce 8600 GT WIth Dual Monitor (NVEnabler64.kext with kext ultillity) and for the Ethernet I'm using a Dinex DX-PCIGB PCI and the nic board (BCM5754)

Posted Image

#10
Dragom

Dragom

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I was able to get everything working using the instructions on the osx86 website. and upgraded to 10.7.2

But I have a few problems.

Network doesn't work after waking up from sleep.
can't login to facetime.

Does anyone else have these problems? and can you post your boot.plist and E/E kexts used?

#11
xk3r

xk3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Albuquerque, NM

I was able to get everything working using the instructions on the osx86 website. and upgraded to 10.7.2

But I have a few problems.

Network doesn't work after waking up from sleep.
can't login to facetime.

Does anyone else have these problems? and can you post your boot.plist and E/E kexts used?


I used the BCM5722D.kext

#12
The Vapper

The Vapper

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

can't login to facetime.


I had the same problem
Can you log into the App Store? If so, then I have no clue, but if not, then you need to insert the EFI string of your ethernet device into your Boot.plist
Best way to do this (and probably the only way to get it) is by using EFI Studio, which you can get here.

Hello Eds.
As of now there is no working solution, you won't be able to even get proper screen resolution (max 1024x768) let alone have hardware acceleration (QE/CI). Needless to say, both are necessary to live the Mac OS X experience.
I've scoured the internet, no kext exists for this graphics controller because it is substantially different from other supported GPUs.
In other words you have to use an add-in PCI-e video card, which forces you to select an upgrade friendly form factor of the Optiplex.
Hope you get one cause they really are reliable machines ;-)


There is no solution for the hardware acceleration, but to get higher resolutions, you can use the "Graphics Mode" boot flag in the Boot.plist. That way you can use whatever resolution your monitor and OS X natively support, which for me is up to 1600x1200@32. :) Works fine for me, although it would be nice to have QE/CI...

#13
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
hey friends, may I pls remind everybody that there is 4 (!!) different FF's (form factors) of the 745:
  • USFF: Ultra Small (no slot for extra grfx card)
  • SFF: Small (reduced height - requires reduced height grfx card)
  • DFF: Desktop
  • MFF: Mini
Would from now everybody pls first post which of the FFs you are talking about ..

Also I recommend that everybody above please take a minute, edit their posting(s) and add this missing information, if missing (or simply add that significant info into your signature). Everything else only leads to model confusion again (and we've had way more than enough of that in these forums .....)

Thank you very much,
Bugs

#14
client00

client00

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

hey friends, may I pls remind everybody that there is 4 (!!) different FF's (form factors) of the 745:

  • USFF: Ultra Small (no slot for extra grfx card)
  • SFF: Small (reduced height - requires reduced height grfx card)
  • DFF: Desktop
  • MFF: Mini
Would from now everybody pls first post which of the FFs you are talking about ..


Hi.
We mostly refer to DFF, as it happens to be the most upgrade friendly (regarding RAM, expansion cards etc) form factor of the Optiplex 745.
Thx for your comment.
:-)

#15
pdxxjjeep

pdxxjjeep

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

I used iAtkos L2 (Lion 10.7.2) and works great. Used the same as is in the pic: Works: Sound, Network and Video card. GeForce 8600 GT WIth Dual Monitor (NVEnabler64.kext with kext ultillity) and for the Ethernet I'm using a Dinex DX-PCIGB PCI and the nic board (BCM5754) Posted Image


How did you get it to boot? I burn it to a disk pop it and and NOTHING happens.

#16
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
core 2 duo or quad required, Pentium D don't work ...

also hit a key then boot with -v ...

#17
xk3r

xk3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Albuquerque, NM

How did you get it to boot? I burn it to a disk pop it and and NOTHING happens.


I used a mac to burn the iAtkos DVD because is a DMG file, I did the same the first time: burn the DMG file in windows and didn't work, just make sure you select the NON-AHCI SATA in the Drivers section.

#18
fyangster

fyangster

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts

For those interested in getting their Dell Optiplex 745 PC powered by the new Mac OS X 10.7 "Lion", here is the corresponding link to the osx86project wiki, I wrote this entry after successfully getting it to work.

osx86project wiki link for the Optiplex 745

Enjoy.

Please discuss any suggestions/solutions you have in mind.


client00,
I follow your direction but when I get to the install screen I get a white screen with the rainbow mouse just spinning and hang there.
Any thought I did something wrong.

#19
client00

client00

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

client00,
I follow your direction but when I get to the install screen I get a white screen with the rainbow mouse just spinning and hang there.


Need more info to help.
Please boot in verbose mode using -v switch (type -v at the command prompt and then press ENTER)

...or simply give it some more time, here's something I came across:
"It may pause on the grey apple screen with the spinning wheel for quite some time. Just let it be."

#20
carrick

carrick

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I installed lion successfully on 745 SFF by using iAtkos L2. Graphic card ATI 5450 works out of box.
But I have the same trouble as others. Network stops working after waking up (BCM5722D.kext, have to restarty computer to gain access to internet),
and also can not log in icloud and some other i-stuffs.


I used iAtkos L2 (Lion 10.7.2) and works great.

Used the same as is in the pic:

Works: Sound, Network and Video card.
GeForce 8600 GT WIth Dual Monitor (NVEnabler64.kext with kext ultillity) and for the Ethernet I'm using a Dinex DX-PCIGB PCI and the nic board (BCM5754)

Posted Image







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy