Jump to content

[N210] Snow Leopard


  • Please log in to reply
8 replies to this topic

#1
MakuPL

MakuPL

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Ok, after epic battle with this arctic cat I managed to install 10.6.4 on my Samsung N210.

Mostly everything work:
* WiFi (Really!)
* Webcam
* SD Card Reader
* Ethernet
* Sound (both speakers and headphones - no need to change anything)
* Everything else that is not mentioned below

What doesn't work:
* QE/CE - No graphics acceleration
* Speedstep
* Brightness
* Some of function keys
* Sleep

What you will need:
* Netbook Installer 0.8.4 RC1
* NullCPUPowerManagement.kext
* VoodooHDA.kext
* Atheros.Fix.kext

Usefull boot parameters (belive me, you will NEED them at some points)
arch=i386 (after 10.6.2 update)
DSDT=/null.aml (to override default dsdt which doesn' work at all)

Remember to delete dsdt.aml after every update and most important thing:
DON'T UPDATE PAST 10.6.1 WITHOUT NullCPU!

Good luck, and have fun.

Feel free to ask me for help :)

#2
sjobsfan

sjobsfan

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:NYC
I have a question, I am running Mac OS X 10.6.3 using iAtkos S3 v2 on my n210. What is your resolution? I am stuck at 800 X 600 and I know that there is basically no support for the GMA 3150.

#3
MakuPL

MakuPL

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
1024x600 - drivers for the gfx are in the netbook-installer package. Resolution works but no QE/CI ;)

#4
sjobsfan

sjobsfan

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:NYC
So you actually got the resolution working, great! I tried using Meklort's NBI and it caused a kernal panic. Do you think it's because I have 10.6.3 instead of 10.6.4 like you? How did you set up NBI?

#5
MakuPL

MakuPL

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

So you actually got the resolution working, great! I tried using Meklort's NBI and it caused a kernal panic. Do you think it's because I have 10.6.3 instead of 10.6.4 like you? How did you set up NBI?


I installed it with default options, and then deleted the DSDT.aml file from extra, and installed NullCPUPM.kext with KextHelper, and then started the kernel with -f boot flag :(

Btw, I.m 10.6.7 now :hysterical:

#6
sjobsfan

sjobsfan

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:NYC
Thanks ;) and which version of NBI did you use?

#7
MakuPL

MakuPL

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Thanks ;) and which version of NBI did you use?


I had much more luck with 0.8.4 :rolleyes: Everything is in the first post.

#8
sjobsfan

sjobsfan

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:NYC
Oh right, thanks for your help! I'll try using NBI soon. ;)

#9
andi10

andi10

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
i used netinstaller as well
same grafic different samsung GMA3150 and I also have 800 x 600 I thought this issue had not been resolved as the nearest thing was the 950 but 3150 seems to be a cut down from that and therin lay the problem.

Please tell me if I'm wrong





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy