Jump to content

Sound Issues VMware Snow Lepoard EmpireEFI


  • Please log in to reply
5 replies to this topic

#1
sjburk

sjburk

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
I installed Mac snow leopard as virtual machine in vmware by instructions from this video:



I cant get the audio workin properly though. Its there and i can hear it but its broken, gargled, crackled, whatever just very distorted and lots of pops and crackles plus usaully the audio sounds like its been slowed a bit. I ran the vmtools and the ensoniq audio drivers and rebooted and all but still cannot get the audio working properly. :(

Any ideas??

#2
beecher

beecher

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
Well
I hate to break this to you but unfortultly there is no way to fix it without buying something
Zenith432 stated that because of how vmware works there is now way to fix this without
1: Reverse enginerring the apple core audio framework and making it not check the buffer drain
2: Change something in vmware

But however if you buy a usb sound card you might be able to fix the issue
And when your buying a usb sound card make sure its compadible with os x snow

And then connect the sound card to the virtual machine and install the nessary drivers
And that should fix the issue

#3
sjburk

sjburk

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
So ur sayin that is has to do wit mac and vmwares audio engines and stuff an i need another sound card. Any recommendations for sound cards u think would work good in this situation? Preferably something cheap and usb interface just to be able to use the audio without spendin alot or installin new hardware

#4
beecher

beecher

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
Well on the osx86 wiki they said you can get a x-fi go sound blaster usb card
And its only 40$
link
http://us.store.crea.../B0044DEDC0.htm

#5
RealNC

RealNC

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
You can try this vmx tweak:

http://www.insanelym...howtopic=265809

Works for me.

#6
Darkmystere

Darkmystere

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
This is a really extremely late reply, but I wanted to share my solution:

1) Download & Install Soundflower http://cycling74.com...r-landing-page/
2) In the menubar icon select it for the "2ch" select VMware audio device
3) hover mouse on Soundflower 2ch->
4) Set buffer to 64 if that doesn't work play with settings, 64 works perfectly for me





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy