Jump to content

[Aiuto] Dongle bluetooth non funzionante


  • Please log in to reply
5 replies to this topic

#1
Guest: RawTheOutsider_*

Guest: RawTheOutsider_*
  • Guests
Ho un dongle bluetooth usb esterno che funzionava su Snow Leopard, mentre su Lion no.
È uno di quelli generici che non hanno nome, lunghi un centimetro.

Soluzioni?

#2
giaccaz

giaccaz

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts

Ho un dongle bluetooth usb esterno che funzionava su Snow Leopard, mentre su Lion no.
È uno di quelli generici che non hanno nome, lunghi un centimetro.

Soluzioni?


io usavo un sitecom ( chip cambridge silicon radio) che con SL funzionava egregiamente, ovviamente su lion "ciccia" per fortuna avevo un trust serie 15542-02 (con chip broadcom ) che cmq dava qualche problemuccio con lion.
ho sistemato il tutto cambiando ID prodotto e ID fornitore nel file info.plist che trovi in IOBluetoothFamily
per adesso funziona.
cmq prova a fare una ricerca nel forum internazionale ci sono un paio di post che parlano proprio di dongle bluetooth.

#3
Guest: the_tourist_*

Guest: the_tourist_*
  • Guests

io usavo un sitecom ( chip cambridge silicon radio) che con SL funzionava egregiamente, ovviamente su lion "ciccia" per fortuna avevo un trust serie 15542-02 (con chip broadcom ) che cmq dava qualche problemuccio con lion.
ho sistemato il tutto cambiando ID prodotto e ID fornitore nel file info.plist che trovi in IOBluetoothFamily
per adesso funziona.
cmq prova a fare una ricerca nel forum internazionale ci sono un paio di post che parlano proprio di dongle bluetooth.


Il problema è che non riesco a trovare niente, ho già cercato e la maggior parte sono quasi tutti topic aperti senza risposte.

In quelle stringhe devo inserire l'ID del prodotto e l'ID del fornitore...ok ma come le trovo? le trovo su windows con everest?

#4
giaccaz

giaccaz

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts

Il problema è che non riesco a trovare niente, ho già cercato e la maggior parte sono quasi tutti topic aperti senza risposte.

In quelle stringhe devo inserire l'ID del prodotto e l'ID del fornitore...ok ma come le trovo? le trovo su windows con everest?



vai su " informazione su questo Mac" alla voce Usb troverai qui le caratteristiche del bluetooth dopodiché apri il kext IOBluetoothFamily vai in "mostra contenuto" poi vai Contents/Plugins/BroadocomUSBbluetoothCIController poi riapri con "mostra contenuto" Contents poi apri info.plist.


alla voce


</dict>
<key>Broadcom2045FamilyUSBBluetoothHCIController_Dongle</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.BroadcomUSBBluetoothHCIController</string>
<key>IOClass</key>
<string>Broadcom2045FamilyUSBBluetoothHCIController</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>IOProviderMergeProperties</key>
<dict>
<key>ClassicMustNotSeize</key>
<true/>
</dict>
<key>idProduct</key>
<integer>8448</integer> <------------ sostituire questo
<key>idVendor</key>
<integer>2652</integer> <------------ sostituire questo

fatto ciò salvare...riparare i permessi e provare (probabilmente non ti permetterà di modificare direttamente l'info.plist allora duplicalo e lo salvi.....ovviamente e sempre meglio fare una copia per sicurezza)

#5
Guest: the tourist_*

Guest: the tourist_*
  • Guests

vai su " informazione su questo Mac" alla voce Usb troverai qui le caratteristiche del bluetooth dopodiché apri il kext IOBluetoothFamily vai in "mostra contenuto" poi vai Contents/Plugins/BroadocomUSBbluetoothCIController poi riapri con "mostra contenuto" Contents poi apri info.plist.


alla voce


</dict>
<key>Broadcom2045FamilyUSBBluetoothHCIController_Dongle</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.BroadcomUSBBluetoothHCIController</string>
<key>IOClass</key>
<string>Broadcom2045FamilyUSBBluetoothHCIController</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>IOProviderMergeProperties</key>
<dict>
<key>ClassicMustNotSeize</key>
<true/>
</dict>
<key>idProduct</key>
<integer>8448</integer> <------------ sostituire questo
<key>idVendor</key>
<integer>2652</integer> <------------ sostituire questo

fatto ciò salvare...riparare i permessi e provare (probabilmente non ti permetterà di modificare direttamente l'info.plist allora duplicalo e lo salvi.....ovviamente e sempre meglio fare una copia per sicurezza)


Niente da fare, non me lo rileva

EDIT: ah no, ora si

#6
Guest: the tourist_*

Guest: the tourist_*
  • Guests
Mi restituisce questo errore

Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy