Jump to content

[GUIDE] OS X Lion on Intel D945GCLF2 Atom 330


  • Please log in to reply
59 replies to this topic

#41
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,541 posts
  • Gender:Male
  • Location:Italy
Try now please

Attached File  mach_kernel_atom_10.7.2.zip   5.74MB   109 downloads

#42
urig-herb

urig-herb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 296 posts
This time I it reboots shortly after the apple logo shows up after the chameleon screen.

#43
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,541 posts
  • Gender:Male
  • Location:Italy
Thanks :rolleyes:

#44
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,541 posts
  • Gender:Male
  • Location:Italy
Hei guys

we are using the kernel cache?

#45
starobrno1

starobrno1

    InsanelyMac Legend

  • Banned
  • PipPipPipPipPipPipPip
  • 930 posts
  • Gender:Male
Im having problems with my usb mobile broadband modem, if I leave it connected the computer freezes when the boot up next time. It also seems the over all function is not what it should be, Im thinking there is a power supply problem. The psu I have in this box is very small only 50 w. Am I right any ideas guys? Anyway Im gonna try with a powered usb hub and report back. Oh I have the latest driver for the modem so that should be ok.

#46
j_jack

j_jack

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male
nozyczek,

I am using your step by step procedure, and creating the USB stick, installing the initial OSX goes off without a hitch, however, since I just downloaded from the App store the Latest Lion (10.7.2), I am afraid that if affects the outcome. I am getting the dreadful "waiting on boot device" after running the automatic installer after OSX install. There was some talk of a 10.7.1 kernel, is this a feasible option? Any comments?

Thanks!

#47
scram69

scram69

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
Thanks to nozyczek's guide, I've got 10.7.2 running on my atom.
j_jack-
The problem with the "waiting on boot device" in 10.7.2 is the ethernet kext. I got the latest version here. Delete the old one, and run the installer for the new one.

To get the cloud working, I updated to the latest Chameleon. Then, I followed directions in this post.

#48
urig-herb

urig-herb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 296 posts
Anyone tried the 10.7.3 update?

Edit: Did the update, no problems at all :)

#49
ateam

ateam

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
herb when you update to the 10.7.3 what are your steps i am wanted to upgrade from snow to lion but i see people were having issues with the kernel. Thanks and great guide nozyczek

#50
UnaClocker

UnaClocker

    InsanelyMac Legend

  • Donators
  • 617 posts
I got 10.7.3 from the App Store, and after install, and running the install script, I'm getting stuck with the waiting for root drive, I suspect it's looking for the wrong UUID... Where do I edit that?

#51
UnaClocker

UnaClocker

    InsanelyMac Legend

  • Donators
  • 617 posts
Strike that. It really was the ethernet driver. Just download the latest one (linked previously in this thread) and install it after the installer script runs, before you reboot.
10.7.3 works great with this installer.

#52
acollins

acollins

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I put together a system for less than $150 with this board and a mini-itx case from fleabay and a 2GB stick of RAM and a 60GB SSD from Newegg. Replaced the motherboard fan with a heatsink and the case has an AC power supply. This thing runs OS/X Lion 10.7.3 with no moving parts. Pretty cool.

Anyway, the sequence of event I followed looked like this:




1. Install Lion 10.7 from installer USB
2. run ./installer script
3. re-boot to 10.7
4. run 10.7.3 combo update dmg (DON'T REBOOT)
5. run ./installer script again
6. run Realtek kext pkg installer
7. re-boot
8. repair disk permissions

I have another similar system with the exact same board running Snow Leopard 10.6.7 also from an SSD which I use as my primary desktop. I have to say the Lion O/S runs significantly slower than SL with this board. Really not worth the upgrade from Snow Leopard if you want to maintain performance, IMO. Most people will find this much too sluggish, even running on an SSD. Fun to play with however.

This board running Snow Leopard (especially from an SSD) is a thing of beauty and makes for a great little computer.

#53
max2055

max2055

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:italy
thank

nozyczek and all guys on this post , i followed your guide and updates and now i have on my D945GCLF2 server


"Lion Server 10.7.2" working good !!!


important things were:


- update bios version to 278


- install Eth Realink drivers after "installer" script and before reboot



#54
gusz

gusz

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

I have an Intel D945GCLF2D and successfully installed Snow Leopard using Nozyczek's Guide. Now I want to install Lion based on Install Disk downloaded from Apple store. I followed Nozyczek's Guide for Lion and made the USB install stick, but no joy, when I boot from install stick the boot stalls at "Still waiting for root device".


Initially the stall was directly preceded by "couldn't alloc class IOUSBMassStorageClass", and based on Googling that message I tried boot flags npci=0x2000 and USBFix=Yes, still no joy. Based on further ideas in this thread I then installed

Lnx2Mac's Realtek RTL81xx Driver on the boot stick, still shows

IOUSBMassStorageClass error, followed by messages about RTL81xx adapter, and then the "Still waiting ...." message. I've attached hereto the screen image at the stall.




I'd appreciate ideas on what's wrong and how to fix. Thx, Gus

Attached Files



#55
gusz

gusz

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I later got this to work, using

Nozyczek's Guide, with the following changes:



-Revert to Lion 10.7.3 (I had downloaded latest Lion 10.7.4 from Apple site, which causes USB problems on some hackintoshs)


-Use RealtekRTL81xx-0_0_90 kexts (download on

Nozyczek is 0_0_67)


-Use

Chimera-1.11.0 (download on

Nozyczek is 1.7)



#56
edmondwck

edmondwck

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
My 10.7.3 system (Celeron 420, GMA950) runs pretty well with nawcom's 10.7.1 kernel.
However, this kernel no longer work with 10.7.4

I tried the following kernel but it didn't work
http://www.osx86.net...l_atom.zip.html

It kept looping with "Cannot mount root, errno=19"

Does anyone got 10.7.4 running properly?


Edit:

32 bit kernel didn't work
64 bit kernel work but there is no driver for GMA950

#57
oli-j

oli-j

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:High Wycombe, UK
My results:

Updating to the latest firmware must be done before you attempt installing lion. Follow the guide and it will install fine if this is done.

10.7 --> 10.7.1 update, ran ./installer then reboot : working system.

-->10.7.3 combo update, ran ./installer, run network driver pkg (as mentioned earlier in this thread), reboot : working ok apart from iCloud.

Fix permissions after reboot.

I spent some time finding a fix for iCould, including messing around with network settings, deleting plist files etc but nothing worked (as per suggestions on some other threads/forums like this one (post by jtholb)) **.

Found this thread where someone had uploaded a custom compiled chameleon r1496 boot file. Download the file and then move (mv) to root ('/') using sudo -s. You may be wise to backup your old boot file (mv /boot /boot-old) first.

I can confirm it works a treat - system seems stable and it sleeps fine.

** I left the suggested fix in place, so it may have made a difference, it may have not. If you have used the new boot file and you still can't get iCloud to work then it may be an important step.

Haven't attempted 10.7.4.

#58
Rodion2010

Rodion2010

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts


thanks for Your Guides about OSX and mITX MB!
I have a question if You know how to update kernel for 10.7.5 for Intel Atom 330?


#59
Rodion2010

Rodion2010

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

The problem with the "waiting on boot device" in 10.7.2 is the ethernet kext.


the same problem is without this kext

#60
Methanoid

Methanoid

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Location:Brittania

Is nobody still playing with Lion on D945GCLF2? Anyone got 10.7.5 running reliably (how?) or not?  Just picked up this mobo again and wondering if to put Snow on it or Lion. ML out of question!







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy