Jump to content

Asus 1201N Installation and support


  • Please log in to reply
1037 replies to this topic

#781
SamReedy

SamReedy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts

------------------FULL INSTALLATION or UPDATE FROM 10.6.8 v1.1 x86_64 or i386 to Mac OS X Lion------------------------------

Pre installation steps:

Step 1 - Download Mac OS X Lion through the Mac App Store (~4GB)
Step 2 - Navigate to your application folder and right click on the OS X Lion installation file and choose ‘Show Package Contents’
Step 3 - Navigate to the ‘SharedSupport’ folder and find ‘InstallESD.dmg’
Step 4 - Mount InstallESD.dmg
Step 5 - (OPTIONAL) Open up Terminal and run the following command : (show hidden files)

Show hidden files:

defaults write com.apple.finder AppleShowAllFiles TRUE
killall Finder

Hide files:

defaults write com.apple.finder AppleShowAllFiles FALSE
killall Finder
Installation Guide

Step 1 - Restore BaseSystem.dmg to a usb guid formated usb key

Step 2 - Rename usb key to "Installer"

Step 3 - Mount the usb key

Step 4 - Delete packages link inside /System/Installation

Step 5 - Copy Packages folder from InstallESD.dmg to usb key inside /System/Installation/

Step 6 - Copy Extra folder to the root of the usb key and substitute the correct dsdt.aml file for your installed memory size in the /Extra folder

Step 6a - If you want to update your Snow Leopard, Copy Extra folder to the root of the usb key and substitute the correct dsdt.aml file for your installed memory size in the /Extra folder AND to the root of Hard Drive, if not skip this step

Step 7 - Copy mach_kernel_atom to the root of usb key



Step 8 - Install Chameleon-2.0-RC5-r1203 to the usb key using chamelon wizard app(if you have a problem with chameleon installation to usb key, unmount all images re-enter usb key and try again or if installer skip "destination select" just choose chameleon and bootcamp theme click next and now you have an option to Change Install Location...)

http://www.insanelym...howtopic=257464

Step 9 - Replace files inside installation and library directories using Lion_OSInstall_GM.tar.bz2

Step 10 - Reboot (If you want to update Snow Leopard you don't need to launch Disk Utility and you can skip step 12 and step 13)

Step 11 - Boot to new prepared usb key and choose Disk Utility



followed it exactly but seem to be getting a KP

appleintelcpupowermanagment


any help?

replaced nullcpumanagment kext and got a fakeSMC KP, so copied all the kexts over from the extensions filie to S/L/E on the USB and now im getting failed to load kexts.... this that and the other, then still waiting for root device


this is getting annoying now!

#782
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,834 posts
  • Gender:Male
You should rebuild caches when you replace/delete/add kexts.

Boot with -f, or boot with -s, then mount -uw /, then use the command sudo touch.

Best regards!

#783
SamReedy

SamReedy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
Yeahhh, but how can I do that on the usb, I'm sure kext utility only rebuilds it on the hd

#784
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,834 posts
  • Gender:Male
Boot with -f then.

#785
SamReedy

SamReedy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
Ok sorted kexts out, used kext wizard, itl install them and rebuild and repair etc to the USB which is rather handy.....

finally got into the installer but comes up with

Mac OS X cant be installed on this computer
we could not complete your purchase OSX ML is not compatible with this computer

tried using all the kexts for ML instead of lion but same result

could it be a smbios problem? or a dsdt problem?


as far as I can tell im doing nothing differently to what anyone else is doing :(

#786
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,834 posts
  • Gender:Male
Format your internal hard disk as GUID (probably is partitioned as MBR).

Is it possible to install it as MBR, but usually is more difficult, because it involves replace some components in the installer. In fact, the tutorial includes instructions for it and the files that must be replaced. Perhaps your problem is exactly the opposite: your HDD is partitioned as GUID, so as you follow strictly the instructions, it won't install because of the modified components. Test both hypothesis, but first things first: if it's already MBR, try partitioning as GUID.

Best regards!

#787
SamReedy

SamReedy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts

Format your internal hard disk as GUID (probably is partitioned as MBR).

Is it possible to install it as MBR, but usually is more difficult, because it involves replace some components in the installer. In fact, the tutorial includes instructions for it and the files that must be replaced. Perhaps your problem is exactly the opposite: your HDD is partitioned as GUID, so as you follow strictly the instructions, it won't install because of the modified components. Test both hypothesis, but first things first: if it's already MBR, try partitioning as GUID.

Best regards!


It was MBR before as it was running Lion and win 7, but its definatly now GUID as I tried installing it before, I cant get into the disk utility to change it, gives me the message before I can get into anyting

#788
SamReedy

SamReedy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
got it all sorted, anyone else having problems it was the OSinstall package which was the problem along with using the right kexts....


now running 10.8.2 and all is good apart from facetime/messages and my sound

installed HDAkext and IOfamily1 and 2 and still nothing any ideas?


also facetime? anyone got any solutions?

#789
SamReedy

SamReedy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
really struggling with getting the sound to work :(

I've used the appleHDA and IOFamilyaudio kexts from the Lion install, and also from a post on page 30 saying they are for ML, ive also tried IOFamily2audio and still nothing :(


could I use a voodoo sound kext instead?

#790
manmal

manmal

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 437 posts
hi, thanks for the guides.

a couple questions...

- can i use trackpad files for snow leopard too(64 bit)?
- does hdmi work (with audio too) in snow leopard or mountain lion?

thanks
mal

#791
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,834 posts
  • Gender:Male
HDMI worked with Mountain Lion until i updated it to 10.8.3 (beta).

Best regards!

#792
manmal

manmal

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 437 posts
so you mean that until 10.8.2 it worked perfectly ? Anyone using snow leopard ? I think system is much "faster" with snow leopard than mountain lion...in mountain lion it seems i don't even have accelerated graphics. Which bootloader are you using? Thanks!

#793
daniel_ivanov

daniel_ivanov

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Guys,hi
Need your help, I installed 10.8.2 and now my problem is in apple air port, device is listed in "about this Mac" as air port extreme device (AirPort Extreme (0x168C, 0x1A89)), but it cant be seen in my network devices in network settings.
Question is "How can I share Internet over wi-fi?", what should I do with my device to see it in settings and start wi-fi sharing?
I've read this article, used search and still got nothin'.
Native device is Atheros 9285, i updated it with files at osx86 site for atheros 9285, but still can't do anything.
Please help

#794
SamReedy

SamReedy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
Reinstall the kexts and repair permissions

#795
mtek

mtek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts
Anyone on official 10.8.3 yet? Any issues?

#796
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,834 posts
  • Gender:Male
I'm with 10.8.3: no issues other than HDMI audio not working regardless of the proposed workaround.

Best regards!

#797
daniel_ivanov

daniel_ivanov

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Guys, I'm stuck at installation of 10.8.3, i forgot not to update system in app store, so i cleaned everything and started from the beginning
Now I am using preinstalled image of system (.arc) which i extract onto my hard drive.
But here is the problem, when I choose to start with 1083, it is loading in very fast way, writing what was loaded. and simply stop at black screen, and after that..silence. hard drive also stops, so there is no activity at all.
What is the problem?need your help

I cant extract any kexts onto hard drive in transmac, it says "warning:there was an error accessing the end of this volume"
What should I do?

1201n,2ghz,2gb ram,256vram

#798
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,834 posts
  • Gender:Male
I've never used Transmac, so i don't know if i can help.

My advice is starting over with a proven method, then use the Migration Assistant to retrieve the data from the system image you have.

Best regards!

P.S.: I was wrong about having HDMI audio before. Don't know why i though i have. In fact, not even with VoodooHDA i get audio from HDMI to work, which is such a pity in a rather awesome netintosh.

#799
daniel_ivanov

daniel_ivanov

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I do not understand, what is a proven method? there are too much methods
I can say only that now I am using windows 7 from live-cd and do not have any mac- or hackintosh
Please, give me some help)
Thanks for your quick answer

#800
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,834 posts
  • Gender:Male
This is a proven method: http://www.insanelym...-for-beginners/

Good luck.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy