Jump to content

Asus 1201N Installation and support


  • Please log in to reply
1045 replies to this topic

#601
Cirroz

Cirroz

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
I have read an article blog, author said the kernel built on open source doesn't have iCloudness functionality.
Can't find this article now :(

Anyone tried this method?

#602
AvATar7SeVen

AvATar7SeVen

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Poland
  • Interests:various. :)
mtek, you said you updated to 10.8.1. Could you please upload somewhere your Extra folder with mkext and S/L/E? I need that because ML was booting only with -f flag, so I decided to remove some kexts that I thought are not necessary and now trackpad, keyboard and mouse are not working, even with -f. :P So I want to replace this folders with the ones that work properly. When I try to fix something, the things are getting only worse. :f

#603
mtek

mtek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts

I have read an article blog, author said the kernel built on open source doesn't have iCloudness functionality.
Can't find this article now :(

Anyone tried this method?


Sure I did - that's basic stuff - I've tried every trick on the book like I said earlier and still no-go!
I've always suspected it's an atom patched kernel issue, since the same installation method on other hacks and never ran into icloud login issues...

mtek, you said you updated to 10.8.1. Could you please upload somewhere your Extra folder with mkext and S/L/E? I need that because ML was booting only with -f flag, so I decided to remove some kexts that I thought are not necessary and now trackpad, keyboard and mouse are not working, even with -f. :P So I want to replace this folders with the ones that work properly. When I try to fix something, the things are getting only worse. :f


IMO no real advantage to you in posting my extra folder... Just do a fresh install and use the kexts I sent attached a few posts earlier - they're surely work out with 10.8 & 10.8.1.
Use chameleon wizard or champlist to get a good smbios model & serial.

My install runs perfect except for icloud/facetime.

#604
V-ADi

V-ADi

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Szeged, Hungary
  • Interests:Web programming, Video Games :)

Hi GC If you read carefully the last pages you'll see how myself & others have installed ML. There's no single method out there and no universal success formula unfortunately. Anyway I've attached a few essential kexts (& atom kernel) to run ML correctly on the 1201n - hope it helps you out. Good hack!



The forum says to your attachment:

[#10170] We could not find the attachment you were attempting to view.

Anyway, my question is, that what kexts and files should I copy to the ML Lion installer, and what files are post install only? I think my problem lies here, but I am open to any suggestions. (Sorry, I am a newby here.. :( )

#605
AvATar7SeVen

AvATar7SeVen

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Poland
  • Interests:various. :)
Use the kexts attached by mtek, I've added VoodooPS2Controller (because my touchpad and keyboard are not working) and AppleRTC. Not sure if you have to add any kexts for WLAN.
mach_kernel_atom from mtek, extra folder from nasseau (but rename mach_kernel to mach_kernel_atom in boot.plist) - replace Extensions and DSDT for the ones you need (for 2GB I used this one from b0ris). Generate Extensions.mkext with Kext Wizard. Install Chameleon r2033.
I use AHCI.
Before the installation, copy mach_kernel_atom and Extra to your disk just like it's written on the first page.
After installation use Kext Wizard, check every option (rebuilding cache and fixing permissions). And Chameleon Wizard of course.
I think that's all. Will install ML again and check if my E/E works. ;)

#606
mtek

mtek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts
AvATar7SeVen
Good tips/mini-guide! :) I'm in the process of writing my own mini-guide but it'll take a bit longer.
Forgot to say that I used MultiB. post-ML install in order to patch the AppleRTC & also to enable Keyboard & trackpad without having to use voodoops2 kext. This way the original kexts are patched and work great. Not saying though that the voodoops2 won't do the same job perfectly.

#607
AvATar7SeVen

AvATar7SeVen

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Poland
  • Interests:various. :)
Strange thing, with VoodooPS2 keyboard works, but trackpad not. With VoodooPS2 and ApplePS2 it stucks on PCI configuration begin.

#608
mtek

mtek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts

Strange thing, with VoodooPS2 keyboard works, but trackpad not. With VoodooPS2 and ApplePS2 it stucks on PCI configuration begin.


So just use the utility I mentioned before to make the trackpad work & don't forget to the voodoo kext. ;)

#609
mtek

mtek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts
*** UPDATE ***

I've FINALLY managed to get my iCloud working (currently on 10.8.1)!! It's been quite a struggle but the solution as I had first suspected was related to the patched atom kernel. I've tried a new patched kernel from buoo/meklort and BINGO - iCloud is on. :)
Check out my post here w/attached kernel: http://www.insanelym...7

#610
AvATar7SeVen

AvATar7SeVen

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Poland
  • Interests:various. :)
Dude - don't get me wrong - I love you. :P
Everything works now. Absolutely everything. Messages, iCloud, FaceTime...

#611
mondial

mondial

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 214 posts
  • Gender:Male
Hi guys,
Did an SW-update like mtek to 10.8.1 successfully but have the problem: I only can boot to ML via USB-stick and PCIRootUID=0

My config:
  • Bios 0326
  • Chameleon v2.1 18xx
  • first partition: Lion 10.7.4 (default part with Chameleon above)
  • second partition: MLion 10.8.1 (tried to install Cham v2.1 2033 to this partition but no funktion or better: can't access to that)
How and which Chameleon should be installed or updated to boot to both partitions and which parameters do I need ? (I think, I have all kexts in /S/L/E and have no chameleon plists yet) -- Any Ideas, any Insanely-links?

thanks Mondi


btw.: I opened the case b/c my 1201N got hot (The real reason was: I had to reset my bios' cmos :whistle: ) . The fan and the outlet were nearly full with dust of my girlfriend's blanket :thumbsdown_anim: .... after cleaning both with my dyson (!!unplug and remove the fan!!) the temperature is now moderate and the fan is slow and charming :ihw_wow:

#612
mtek

mtek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts
@Mondi, it must be something related to permissions on you ML partition. If I were you I'd fresh install ML once again to see if anything changes.

Good luck!

#613
dreamer_

dreamer_

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Hello:

I've a 10.7.4 installation in my Asus 1201n. Reading at eeuser, I've seen there's a modded 326 bios with AHCI and overclock support. http://forum.eeeuser...odded-326-bios/

Has anyone tried it with Lion?

Thanks

Edit: The links seems to be down. This is the right link for the bios with ahci and overclocking unlocked ;-):

http://www.bios-mods...01N-ahci-unlock


Edit again:
Flashed following this how-to: http://www.jamierf.c...asus-eee-1201n/ and activated AHCI. Lion 10.7.4 seems to work fine for me. I can see the overclocking options too :-)

#614
mtek

mtek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts
@dreamer_
Bios overclocking is unrelated to the OS so it'll work out on both win & os X
You should give Mountain Lion a try now, it works great and faster than Lion.

#615
dreamer_

dreamer_

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Need to definitely try this weekend ;-)


Thanks mtek

#616
mondial

mondial

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 214 posts
  • Gender:Male

@Mondi, it must be something related to permissions on you ML partition. If I were you I'd fresh install ML once again to see if anything changes.

Good luck!



No permission problem, yeah I had 2033 already on my 1201N but I didn't recognize b/c it's completely the same banner as 18xx. Now I've to recover both partitions, Lion & MLion ... :-(
That's really stupid like trial'n error... :-) Crazy !

Best Mondi

#617
V-ADi

V-ADi

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Szeged, Hungary
  • Interests:Web programming, Video Games :)

Use the kexts attached by mtek, I've added VoodooPS2Controller (because my touchpad and keyboard are not working) and AppleRTC. Not sure if you have to add any kexts for WLAN.
mach_kernel_atom from mtek, extra folder from nasseau (but rename mach_kernel to mach_kernel_atom in boot.plist) - replace Extensions and DSDT for the ones you need (for 2GB I used this one from b0ris). Generate Extensions.mkext with Kext Wizard. Install Chameleon r2033.
I use AHCI.
Before the installation, copy mach_kernel_atom and Extra to your disk just like it's written on the first page.
After installation use Kext Wizard, check every option (rebuilding cache and fixing permissions). And Chameleon Wizard of course.
I think that's all. Will install ML again and check if my E/E works. ;)

After my holiday and the beginning of the weekend I am trying again!
Thanks for the guide! It helped me to install ML perfectly! However after updating to 10.8.1 via the App Store I cannot boot to ML again (the same error before: blank screen in verbose boot, or stuck at apple logo). Will try again tomorrow! Does anybody give me a tip what did go wrong?

#618
AvATar7SeVen

AvATar7SeVen

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Poland
  • Interests:various. :)
U sure you have only necessary kexts in extra? In my extra i have:
AnyCardReader, AppleHDA, AppleRTC, AsusHotkeys, AtherosL1cEthernet, EvOreboot, FakeSMC, IOAudioFamily, IOStorageFamily, NullCPUPowerManagement, SleepEnabler, VoodooBattery, VoodooPS2Controller (while the installation my trackapad wasn't work but now it actually is). I had to install audio kexts via Kext Utility because there was no sound,
U didn't copy any kexts to your S/L/E, did you? Try to replace your extra folder again and check if it will help. Because I think that all the problem we had are kext-related. :)

#619
mondial

mondial

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 214 posts
  • Gender:Male
Hi Gurus,
Is there a possibility to install ML without Lion before?
Thx Mondi

#620
V-ADi

V-ADi

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Szeged, Hungary
  • Interests:Web programming, Video Games :)

U sure you have only necessary kexts in extra? In my extra i have:
AnyCardReader, AppleHDA, AppleRTC, AsusHotkeys, AtherosL1cEthernet, EvOreboot, FakeSMC, IOAudioFamily, IOStorageFamily, NullCPUPowerManagement, SleepEnabler, VoodooBattery, VoodooPS2Controller (while the installation my trackapad wasn't work but now it actually is). I had to install audio kexts via Kext Utility because there was no sound,
U didn't copy any kexts to your S/L/E, did you? Try to replace your extra folder again and check if it will help. Because I think that all the problem we had are kext-related. :)

I've tried with yours, mtek's and nasseau's kexts, 10.8.0 works fine, but after the update it's stuck at the Apple logo... My kexts are all in the E/E folder. Maybe I am missing something vital here. So I am writing down what I've tried, maybe you can help me what have I missed.
I updated to 10.8.1 with AppStore and the package installer too. After the update the computer restarts. After that I can't boot into ML with or without -f. So on my Lion partition I ran Kext Wizard, and repaired permissions and rebuilt mkext on Extra and rebuilt cache and repaired permissions on S/L/E, but it didn't work either.

Don't know what to do, today I've reinstalled poor ML three of four times, but no luck after the update... But I am optimistic, and I want to learn, so I am waitingg for some help again. :( Thank you in advance!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy