Jump to content

Asus 1201N Installation and support


  • Please log in to reply
1037 replies to this topic

#481
alphaplayer

alphaplayer

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Finally I've got Lion working 100% on my 1201N!

I made a fast tutorial:

1 - Follow the steps from biird at page 23 (it'll send you to first page to install crazy juice Lion with LionBootMaker and following the steps from 11).

2 - Once installed, you need to run chameleon from your USB Key to load the first drive but my chameleon didn't show nothing (grey screen) and booted again the Lion_Installer, so I've installed Chameleon with Chameleon Wizard (extract chameleon folder anywhere and choose the "update" option with the below box checked) on the Key using the Chameleon r1203 seen at page 1.

3 - After that, I've the option to choice from where load the OS, so this time I've decided to load from hard drive.

4 - Follow biird tutorial from page 23 from removing the Extra folder.

5 - Install 10.7.3 combo update (no kp nor something like that at this moment).

6 - Install audio kexts as said at the first page on the crazy juice tutorial (moving to Kext Utility), and I haven't the trackpad working, so install VoodooPS2Controller too moving it to Kext Utility.

7 - Always remember to fix permissions.

Logged successfully into iCloud (I have an MAS error so I've erased the NetworkPreferences.plist and all working OK). With 4GB dsdt (from the first post) and DW1510 wifi card. Battery lasts about 3:30-4:00 hrs (I think that's more than Windows), and now I'll try to do some geek bench tests and virtualize a Windows machine to do some tests (I know Atom 330 haven't Virtualization Technology, but I want to try).

At last, I will keep this post updated with problems I'll find (I'm sure I won't find nothing) and some info.

Thanks for Mondial, biird and crazyjuice (and more people I will forget).

#482
levvys

levvys

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Finally, I have working 10.7.3 and iCloud! Thanks to biird and Toletum91zgz!

BTW FaceTime and sleep doesn't work, it's ok, I can live with it ...BUT! I have a serious problem, notebook overheating and shuts down. I'm using biird's Extra folder, someone can advice what kext should I replace to resolve overheating problem?

#483
levvys

levvys

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Ok, I think I've fixed overheating by installing NullCPUPowerManagement.kext.
Any ideas how to fix sleep and FaceTime?

#484
alphaplayer

alphaplayer

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Have you changed your DSDT file? I'm not sure that would help, but, that's a point. I haven't installed NullCPUPowerManagement.kext and it worked like a charm (I think I'm booting x86_64). It's a bit hot, but taking advantage now it's winter, it's not a problem :star_sunglasses:

Also, I've found a bug. The sound works great, but I have not sound on Youtube (f.e.) with Safari or Google Chrome. Anyone knows how can I solve it?

#485
alphaplayer

alphaplayer

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Btw... Anyone knows how to virtualize a Windows 7 machine? I've tried Parallels (without working) and Vmware Fusion and this last one throws a KP. I will try now the Vmware Fusion 3.0.0.

#486
mtek

mtek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts
Hi guys,

My 1201n is running 99% perfect on 10.7.3 - the only issue still remains that I can't login into iCloud (communicating error) and also Facetime has a registration error when I try to login.

Other than that it runs just fine the Apple Store and has no login issues.

Since I have an updated chameleon, the ethernet built in string and the ethernet/wifi device id correctly sorted, I reckon the only possibility is that Apple somehow detects that the atom kernel loaded is not legit.

Is there yet a fix for this?

Thanks a lot for any insight.

#487
alphaplayer

alphaplayer

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Have you tried this?
http://www.insanelym...dpost&p=1730751

#488
mtek

mtek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts

Have you tried this?
http://www.insanelym...dpost&p=1730751


Thanks for replying. Yes I did already try that. I've pretty much tried everything possible other than trying a different kernel. The question is what kernel should I try, if any?

#489
alphaplayer

alphaplayer

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Thanks for replying. Yes I did already try that. I've pretty much tried everything possible other than trying a different kernel. The question is what kernel should I try, if any?


I didn't changed the kernel.

#490
Curtis.m.m

Curtis.m.m

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Leeds, W'Yrks
Is anyone's 1201n shutting down when the lid is closed?

I only ask as mine is doing this. Not sure why. It Sleeps by manually selecting it in the menu so i'm a bit confused :wacko:

Any help appreciated! Thanks.

#491
mosslack

mosslack

    InsanelyMac Legend

  • Donators
  • 881 posts
  • Gender:Male
  • Location:Mid-south Central Indiana
Mine doesn't shut down, but it won't wake up after I close the lid and must be rebooted. But then sleep doesn't work at all on mine, which is okay with me b/c I never use it. In addition, when I restart, it's just as though the system had been asleep as I am required to type my password to log back in. On a normal start, no password is required. HTH

#492
levvys

levvys

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Now I have issue only with audio in flash and sleep mode, all other things such as iCloud, FaceTime etc. works like a charm on 10.7.3.

Somebody know how to fix audio in flash? it works, but usually disappears after a couple of minutes, then can start working again, but disappears again.

#493
biird

biird

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
  • Location:Reno, NV

Now I have issue only with audio in flash and sleep mode, all other things such as iCloud, FaceTime etc. works like a charm on 10.7.3.

Somebody know how to fix audio in flash? it works, but usually disappears after a couple of minutes, then can start working again, but disappears again.


I have the same issue. Had it every 10.7 version and haven't found a fix yet.

I tried booting to 10.8 beta, but no luck- instant reboot with latest working 10.8 Chameleon. Probably an atom kernel thing.

#494
mosslack

mosslack

    InsanelyMac Legend

  • Donators
  • 881 posts
  • Gender:Male
  • Location:Mid-south Central Indiana

I tried booting to 10.8 beta, but no luck- instant reboot with latest working 10.8 Chameleon. Probably an atom kernel thing.


Same thing happened on my desktop system GA-P35-DS3L, but I found an image that worked to get it installed. Everything working except ethernet on that system.

#495
Karakino

Karakino

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts
  • Gender:Male
  • Location:Perugia, Italy

I finally got 10.7.2 working with iCloud/Facetime! Not entirely sure how exactly, but I've attached the files I'm currently using. I'll recap what I did in order and hopefully this helps clear things up.

Sleep works by closing the lid as well!

First thing to do is make the bootable Lion USB. This is all available on the first page of the thread. Use the files provided and follow the steps to boot, format drive, copy kernel/extensions, install, and boot into your newly installed 10.7.0 OS X partition. Remember to boot to the thumb drive and then select the hard drive install partition in Chameleon when the boot loader shows.

Once booted into 10.7, install Chameleon to the hard drive. Personally, I use Champlist to update and download Chameleon, but there are many of ways to do this.

Now remove the Extra folder and copy over the files in my attachment to the hard drive. You may need to rebuild the .mkext, but it should work as is. Reboot

10.7 should boot successfully now without use of the thumb drive. The next objective is to delete Ethernet and Wifi from the Network tab in System Preferences to reset the devices. After that, remove NetworkPreferences.plist from /Library/Preferences/SystemConfiguration and reboot.

After rebooting, go back into System Preferences and Network. Add Ethernet first, apply, add WiFi, apply, reboot. This is key because the Ethernet needs to be the first device. I connected to Wifi after this and tested FaceTime. ZING! WORKED! I hadn't had FaceTime work yet on Lion, but it finally worked with this group of kexts/boot.plist/smbios! Since success here, I downloaded the 10.7.2 combo update, rebooted, and logged into iCloud successfully!

Once I realized I had iCloud/Facetime working on 10.7.2, as well as sleep working, I moved /E/E to /S/L/E and removed the .mkext from Extra, repaired, and boom!


I tried exactly with what u say here... I have the 1201n silver with 3gb of ram. But i only get stuck at boot with the pci configuration begin error... If it worked for u... WTF!!! It should work even for me! :)

#496
mondial

mondial

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 211 posts
  • Gender:Male

Is anyone's 1201n shutting down when the lid is closed?

I only ask as mine is doing this. Not sure why. It Sleeps by manually selecting it in the menu so i'm a bit confused :wacko:

Any help appreciated! Thanks.


My config for working sleep at closing lid:

Attached Files



#497
levvys

levvys

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

My config for working sleep at closing lid:


I tried to do the same, but now my comp just restarts when booting, sad.... Another couple of hours to reinstall everything.

Do you have 10.7.3? iCloud/FaceTime working? Please upload your extra folder.


#498
Curtis.m.m

Curtis.m.m

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Leeds, W'Yrks

My config for working sleep at closing lid:


I noticed you're not in 32-bit mode. Could you tell us if you have the nullcpumanagment kext in your extra folder? I just tinder mine off and I'm now in a reboot loop do I'll have to sort that out tommorow.

P.s - for everyone with the iCloud issues, I kinda did what biirdy did with champlist and grabbed a new smbios config after deleting both the network setting files and fiddling with the network adapters. It took a few tries but I got there in the end.

#499
mondial

mondial

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 211 posts
  • Gender:Male

I tried to do the same, but now my comp just restarts when booting, sad.... Another couple of hours to reinstall everything.

Do you have 10.7.3? iCloud/FaceTime working? Please upload your extra folder.

I noticed you're not in 32-bit mode. Could you tell us if you have the nullcpumanagment kext in your extra folder? I just tinder mine off and I'm now in a reboot loop do I'll have to sort that out tommorow.

P.s - for everyone with the iCloud issues, I kinda did what biirdy did with champlist and grabbed a new smbios config after deleting both the network setting files and fiddling with the network adapters. It took a few tries but I got there in the end.


Sorry for being late ...
No iCloud & FaceTime --- don't work, but closing lid and sleep is working
==>>>> sorry something must have been cached, bc I changed my HDD to SSD and rebooted with exact the same configuration - now my sleep by LID doesn't work anymore !!! :-(
As you see in my signature, I'm using KernelCache ON, that means no kexts in /E, all moved to /S/L/E
and using nullCPUPowerMgmnt there as well (64bit).
... for iC & FT: I also deleted the network components (eth & wifi), the NetworkPreferences.plist, rebooted and added both elements, first eth then wifi - no sucess :-( (maybe b/c I'm already on 10.7.3 or x86_64?)


best Mondi

Attached Files



#500
biird

biird

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
  • Location:Reno, NV

Ok, I think I've fixed overheating by installing NullCPUPowerManagement.kext.
Any ideas how to fix sleep and FaceTime?

Hi guys,

My 1201n is running 99% perfect on 10.7.3 - the only issue still remains that I can't login into iCloud (communicating error) and also Facetime has a registration error when I try to login.

Other than that it runs just fine the Apple Store and has no login issues.

Since I have an updated chameleon, the ethernet built in string and the ethernet/wifi device id correctly sorted, I reckon the only possibility is that Apple somehow detects that the atom kernel loaded is not legit.

Is there yet a fix for this?

Thanks a lot for any insight.


I couldn't get iCloud/FT to work for the longest time. Then, some, whatever I did with those recent steps worked. It still works. And I completely reinstalled from scratch with those steps twice. Maybe it's a GPT/GUID thing? I don't know, and I don't know what step could be causing the issue, but those steps with those files worked after trying virtually everything. Wish I could be of better help...

I tried exactly with what u say here... I have the 1201n silver with 3gb of ram. But i only get stuck at boot with the pci configuration begin error... If it worked for u... WTF!!! It should work even for me! :)


I think that's because of the 4GB DSDT when you only have 3...I could be wrong, but try using the 3GB one from the 1st post and that may fix it.

Sorry for being late ...
No iCloud & FaceTime --- don't work, but closing lid and sleep is working
As you see in my signature, I'm using KernelCache ON, that means no kexts in /E, all moved to /S/L/E
and using nullCPUPowerMgmnt there as well (64bit).
... for iC & FT: I also deleted the network components (eth & wifi), the NetworkPreferences.plist, rebooted and added both elements, first eth then wifi - no sucess :-( (maybe b/c I'm already on 10.7.3 or x86_64?)


best Mondi


I wish I knew exactly how I fixed my iC/FT problem...it's working for me on 10.7.3 with those steps I posted (plus updating to 10.7.3 + replace audio kexts) as well as close-to-sleep. I'm PRETTY sure I'm still using the mach_kernel_atom kernel from the original post and have been updating Chamelon...hmmm, arghh





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy