Jump to content

[WIP/UNRESOLVED] 10v + Tiger (10.4) [Needs Member Support!]


  • Please log in to reply
40 replies to this topic

#21
gygabyte666

gygabyte666

    Insanely >_

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:New York
  • Interests:>An error has occurred and your computer will spontanously combust to prevent further damage...
Alright, good to know. I'll add it back in, lower the value for that and see if it's better to use.

Great! Thanks for the editor i'll try it right now. The one i've been using is HexEdit but I'm not a big fan of it's UI. What should I look for exactly to replace? Value I mean, like 8086 (I know that's not it but I hope you know what I mean).

#22
riws

riws

    InsanelyMac V.I.P.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 6,081 posts
Here is my VoodooHDA Info.plist tweak (MSI Wind, ALC888S: speaker, mic, line-in and line-out) for Mixer (there is a special PrefPane too) and Nodes.

<key>MixerValues</key>
			<dict>
				<key>Line</key>
				<string>0</string>
				<key>Mic</key>
				<string>0</string>
				<key>Monitor</key>
				<string>0</string>
				<key>PCM</key>
				<string>90</string>
				<key>Rec</key>
				<string>0</string>
				<key>iGain</key>
				<string>90</string>
				<key>iMix</key>
				<string>0</string>
			</dict>
			<key>NodesToPatch</key>
			<array>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x40f000f0</string>
					<key>Node</key>
					<integer>17</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x04214011</string>
					<key>Node</key>
					<integer>20</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x40f000f0</string>
					<key>Node</key>
					<integer>21</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x40f000f0</string>
					<key>Node</key>
					<integer>22</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x04819030</string>
					<key>Node</key>
					<integer>24</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0xb7a70120</string>
					<key>Node</key>
					<integer>25</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x40f000f0</string>
					<key>Node</key>
					<integer>26</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x90130110</string>
					<key>Node</key>
					<integer>27</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x40f000f0</string>
					<key>Node</key>
					<integer>28</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x40f000f0</string>
					<key>Node</key>
					<integer>29</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x40f000f0</string>
					<key>Node</key>
					<integer>30</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x40f000f0</string>
					<key>Node</key>
					<integer>31</integer>
				</dict>
			</array>
			<key>Noise</key>
			<integer>2</integer>
			<key>Vectorize</key>
			<true/>
			<key>VoodooHDAEnableHalfVolumeFix</key>
			<false/>
			<key>VoodooHDAEnableVolumeChangeFix</key>
			<false/>
			<key>VoodooHDAVerboseLevel</key>
			<integer>0</integer>
		</dict>
	</dict>


#23
gygabyte666

gygabyte666

    Insanely >_

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:New York
  • Interests:>An error has occurred and your computer will spontanously combust to prevent further damage...
Wow! Great. Now if I can figure this miserable GMA950 fix out i'll be doing ok. HAHA, I hate going in blind on new things. Oh well, i'll try to figure it out.

#24
riws

riws

    InsanelyMac V.I.P.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 6,081 posts

Alright, good to know. I'll add it back in, lower the value for that and see if it's better to use.

Great! Thanks for the editor i'll try it right now. The one i've been using is HexEdit but I'm not a big fan of it's UI. What should I look for exactly to replace? Value I mean, like 8086 (I know that's not it but I hope you know what I mean).



Look into AppleIntelGMA950.kext Info.plist, there you see the ID´s you could change.

Like 0x808627a2, you look after 8680a227 (bytes are flipped) and you replace it with your 0x808627ae, that´s 8680ae27. Don´t forget to change the ID in Info.plist too.

#25
gygabyte666

gygabyte666

    Insanely >_

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:New York
  • Interests:>An error has occurred and your computer will spontanously combust to prevent further damage...

Look into AppleIntelGMA950.kext Info.plist, there you see the ID´s you could change.

Like 0x808627a2, you look after 8680a227 (bytes are flipped) and you replace it with your 0x808627ae, that´s 8680ae27. Don´t forget to change the ID in Info.plist too.


Please correct me if i'm wrong. I am supposed to be editing the GMA950 MacOS directory file correct? I tried a search for those values with no results. Maybe i'm doing this wrong. Not something I do everyday though :)

EDIT: Ok, I found those values searching in hex, but i'm not sure if I should change them. They are just
...'
as ASCII. Not to mention there are tons of them.

#26
riws

riws

    InsanelyMac V.I.P.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 6,081 posts
Jep, the Binary File: AppleIntelGMA950.kext/Contents/MacOS/AppleIntelGMA950

In Info.plist, which ID´s do you have there?

#27
gygabyte666

gygabyte666

    Insanely >_

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:New York
  • Interests:>An error has occurred and your computer will spontanously combust to prevent further damage...

Jep, the Binary File: AppleIntelGMA950.kext/Contents/MacOS/AppleIntelGMA950

In Info.plist, which ID´s do you have there?


Ok good, thought so. Well, I replaced them anyway, testing now...

I didn't need to modify the one you provided me at all. 0x808627ae is one of my compatible ids, so it just worked. No editing needed.

UPDATE: Tested the newly edited GMA950 kext and it KPs on me now. I screwed it up. I have no idea what i'm doing. Looks like I changed the wrong thing afterall. :)

#28
riws

riws

    InsanelyMac V.I.P.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 6,081 posts
And that´s it, delete the Kext again. :)

#29
gygabyte666

gygabyte666

    Insanely >_

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:New York
  • Interests:>An error has occurred and your computer will spontanously combust to prevent further damage...
Um, what? Delete what kext? I hexed the 950 binary but I must have did it wrong. All I get are KPs when I try to boot using it. Sorry, I never hexedit anything. :)

Do I need a specific setup to use with 0xED? I currently have it setup using Little Endian and Insert. Should this be changed to Big Endian and Overwrite?

#30
riws

riws

    InsanelyMac V.I.P.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 6,081 posts
Nope, you did it correctly. Like I said, no QE

#31
gygabyte666

gygabyte666

    Insanely >_

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:New York
  • Interests:>An error has occurred and your computer will spontanously combust to prevent further damage...
So basically, there is no need to try to hexedit the 950 binary file? Because it just won't work? Hmmm...I'm confused.

Well, whatever screw it. I'm just gonna keep trying to patch my device id into all the 950 {censored} to see if I can get lucky. Maybe I just need to add it into everyone of them and then QE will work. A Mac is essentially useless w/o QE. We can't have that. Especially since SL and Leo both having it working. Thanks.

#32
riws

riws

    InsanelyMac V.I.P.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 6,081 posts
I tried all Intel GMA 900 and 950 ID´s out, but the same result, KP

#33
gygabyte666

gygabyte666

    Insanely >_

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:New York
  • Interests:>An error has occurred and your computer will spontanously combust to prevent further damage...
I don't think hexeditting them is the right way to go. I think that's the cause for KP. I think the only reason some had success doing that on Leopard is because Apple screwed up. I believe there are checks for modification to the GMA950 kexts on Tiger, that aren't there for early Leo.

We need to figure out some sort of DSDT patch for this through Tiger. I'm trying out some different Chameleon revs that support it, based on Slice's post. I have a working DSDT from SL, as long as the values/etc are still valid, it should work fine. That's the only reason this GMA has QE/CI on SL, because Chameleon DSDT patched it in. There must be a way in Tiger to get around this...

UPDATE: Interesting. I just copied my custom version of Chameleon for SL to my Tiger HDD and attempted a boot from it. Mind you, it was created using NBI and has custom attributes applied to it. This version of Chameleon has been specially modified to run on netbooks/my Mini so it tried loading DSDT patches and looked like it succeeded. Problem is, after booting to Tiger I noticed that everything seems the same. No QE/CI still. It really looked like it was applying patches though. Any thoughts?

#34
riws

riws

    InsanelyMac V.I.P.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 6,081 posts
Hex Edit is needed, the Kext wont load or not fully if it does not have the GMA ID. If you patch the GMA 900 ID´s (2592 or 2582), the Kext gets loaded, but wont load the 2D or 3D plugins/bundles.

What kind of Fixes do you have in your DSDT?

#35
gygabyte666

gygabyte666

    Insanely >_

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:New York
  • Interests:>An error has occurred and your computer will spontanously combust to prevent further damage...
I tried adding in fixes from my 10.4.4 restore DVD and tried out the GMA915 kexts with patched FrameBuffer but it didn't do anything. I was going to try the ones from my 10.4.6 disc next, so we'll see what happens. EDIT: Tried out 10.4.6 and hexed it. Nothing but KPs again. More failure *sigh* :)

Honestly, I don't know what kind of fixes are in the DSDT, I don't have anything to read them with. I just know they are there and because of my working SL, I know they work. I'll add them as attachments so you can take a look at them if you want. I don't know what else I could do with them anyway. The modules folder is what I think are the actual patches. Obviously the other two are the DSDT.aml files that were generated out of the patches.

I was thinking, maybe I could try patching in another device id for the GMA950 to trick it into working. I have three compatible ids, I wonder if one of the other two might work instead.
pci1028,2f4","pci8086,27ae","pciclass,030000
these are what I extracted earlier from ioreg.

CONFIRMED: Yeah, using my SL custom Chameleon is most definitely patching something up. I installed my testing GMA950/FrameBuffer kexts incorrectly (so they weren't being loaded) and still had native res at boot. Native res, with no kext loaded for gfx. This chameleon is patching things up for me it seems. It could just be a simple "Graphics Mode"="1024x576x32@60" fix that it applies though too. Still, as long as I use this Chameleon, I'll never have to worry about not having native res. :)

Attached Files



#36
gygabyte666

gygabyte666

    Insanely >_

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:New York
  • Interests:>An error has occurred and your computer will spontanously combust to prevent further damage...
Ugh, I'm at my limit. I'm gonna classify this as WIP and give up for the time being. Lots of progress was made and I thank you both very much for your support but sadly, as I said before if QE/CI can't be obtained, then this is for the most part, a useless Mac. I will keep the thread open and hopefully in the near future i'll hear back from meklort with a possible fix. Perhaps, someone will post an untested fix that'll work too. I don't know. All I know is I have done all I can do and have lost enough sleep over this damn thing so for the time being i'm putting it on hold and will image it for later tinkering.

If ANYONE has a fix for getting QE/CI working on a mobile GMA950 on Tiger, please DON'T be greedy and keep it to yourself. Share it with the rest of us Tiger lovers. I love Tiger and would be extremely excited it have it working a main OS for my Mini but if this problem doesn't have a solution, I don't know how that's possible. Once again, everyone thank you for your time, patience and understanding but this project has drained a lot out of me (this and the 5-6 other Mac-related projects I completed successfully over the last month). I'll try to stay on top of it from time to time testing here and there but I don't expect anything extraordinary to happen while doing so. Still, thanks again at the very least, I got it running, which is something I wasn't able to make happen until visiting this forum.

:)

UPDATE: If anyone has some test GMA950 kexts that they have hexed from
86 80 A2 27
to
86 80 AE 27
then please attach them for testing ONLY after you have tested them on your machine and can 'confirm' them working. I just find it very odd that so many people have had success with getting this device id loaded after hex-patching the GMA950 kext while people like myself and riws have had nothing but failure using the EXACT same dev-ids.


#37
gygabyte666

gygabyte666

    Insanely >_

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:New York
  • Interests:>An error has occurred and your computer will spontanously combust to prevent further damage...
Does anyone have any modified GMA950 kexts that I could tinker with to try to fix QE/CI on my Tiger machine? Any tips, tricks or hacks that could possibly work are welcome also. Any and all support is greatly appreciated. I hope someone has something to offer soon.

#38
abdeir

abdeir

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Did you try these: https://rapidshare.c...IntelGMA950.zip
https://rapidshare.c.../Natit.kext.zip
https://rapidshare.c...6649/0x27ae.zip



Try appleintelgma950 first then the rest.

#39
gygabyte666

gygabyte666

    Insanely >_

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:New York
  • Interests:>An error has occurred and your computer will spontanously combust to prevent further damage...
I appreciate the help but none of them worked. I expected them not to though simply because the last revision to my knowledge of GMA950 for Tiger is 1.4.58.2 and the two you sent me are 1.6.10.32 & 1.5.24.9 respectively. They are both designed for Leopard and didn't stand a chance of working on a Tiger system anyway.

Secondly, I'm pretty sure that Natit is useless for Intel gfx chipsets. It is designed to 'patch' Nvidia and ATI gfx kexts. As far as I know, it was never intended to fix Intel gfx problems like this. Still, I was hopeful and tried them just for kicks and no luck. I really appreciate you posting them though. I need more people like you on this thread. :)

#40
abdeir

abdeir

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
If you are on 10.4.8 you can try the Jas package here: https://rs108l34.rapidshare.com/#!downl...0%2834fa3175%29

then fix the resolution (if not working) with this post here : http://www.macgeekbl...lution-fix.html





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy