Jump to content

Fix: VoodooHDA KP (10.6.8 + 10.7.x)


  • Please log in to reply
57 replies to this topic

#41
Syfer82

Syfer82

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Hi, sorry for my english

I Have asus p5b deluxe and with lion i Have some sound problems

With applehda not see device

Stock vodoo only one out line and no kp

With modified vodoo see all out line but 50% Times kp

Your method can help me?


If yes:

Can indicate me the exact files i must delete to sle?

After how can use the modified vodoo?

#42
Syfer82

Syfer82

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
ok i tried it but a problem!


i can not see the green line
some kext in extentions folder let me see this line and con the loader not

why?

#43
s.sirio

s.sirio

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
I have upgraded to 10.7.4 but this version seems not to like the kext injected and gives a kernel panic. Not sure if I am the only one that faced such problem, i will appreciate if you could share your experience and possible solutions.

Thanks every one

#44
s.sirio

s.sirio

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
Just noted that I had to get rid off of the AppleHDA.kext, done that and the kernel panic no longer happens but the sound is very much distorted so I am back to square one. Has any one got a voodoohda.kext 10.7.4 compatible version? Any other solution or work around will be also very much appreciated.

Thanks everyone

#45
Mustang Sally

Mustang Sally

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 109 posts
AndersonTech

this worked perfect on my asus m50, c2d T9400, gf 9600gs with lion 10.74. ALC663 with my pin corrected voodoohda 2.73. zero crashes so far.

thanks


pin config guide
http://www.insanelymac.com/forum/index.php?showtopic=231179&st=0


#46
raziiq

raziiq

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts
Hey Guys,

Installed VoodooLoader, but no sound. I can see the speaker icon enabled now on my menubar and input output devices are appearing in the settings but still cant hear any sound. Any suggestions??

BTW i have Intel HD audio with Intel HD 3000 Graphics HDMI.

Also i cant find any Voodoo or AppleHDA kext in extensions folder, is it supposed to be like this?

#47
raziiq

raziiq

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts
No one?

This is my more info screenshot.

Attached Files



#48
Mustang Sally

Mustang Sally

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 109 posts
worling on my m50 with mountain lion gm 10.8 alc663

#49
ZikPhil

ZikPhil

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
Thank god, that actually gave my sound back on Mountain Lion.

#50
keessie

keessie

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
Thanks for the patches

AndersonTech,



I still have the same problems

though:(
Larsen effect is still there.
I am running Mountain Lion.

#51
Montspy

Montspy

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
Hello,
I'm running Mountain Lion 10.8 and Voodoo Loader makes my system freeze (no KP screen) when launched.
I have a VIA VT2021, and I tried "VoodooHDA 2.7.2/3/4.kext" and "VIA2021.kext".

Is ML supported ? Do you plan on supporting it ?

Val'

#52
AndersenTech

AndersenTech

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Wilmington, Delaware
Hi all,

Recently I've been super busy with school stuff and travel. I hope to resume work on this project as soon as I can get my rig fixed. It might be a while, but I'll try building on my other comp and updating more often.

Hope I can fix some problems,

AndersenTech

#53
Sanky18

Sanky18

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
Hi
When i install voodoo loader in ML it does not set it as a startup item. Everytime i have to launch the application after boot. Is there a way to set it as a startup item manually? Thanks

#54
Dyolp

Dyolp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts
Hi Mustang sally & Hi all !

I've also ALC663 and no KP after using this awesome loader (thanks to AndersenTech !)! But, the problem that i've under ML is that after every reboot I loose the voodoo HDA setting in preferences (see photo). Can you share your knowledge about this pb please ?

Thanks !
Wonderful Forum

Loyd

Attached Files



#55
rictec

rictec

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
hi
i m trying to install mountain lion on an HP 4320s Laptop with a i3-m350 cpu
beside the graphics problem i have wireless working ok
Voodooloader worked for one single section them i had a KP no sound and if i start it i get a KP

8086;Intel Corporation;3b56;5 Series/3400 Series Chipset High Definition Audio;Multimedia controller;Audio device
that is the audio device
Darwin Mac-Pro-de-Rictec.local 12.0.0 Darwin Kernel Version 12.0.0: Sun Jun 24 23:00:16 PDT 2012; root:xnu-2050.7.9~1/RELEASE_X86_64 x86_64
thats the kernel
can anyone help on where is the problem i tried every thing i found on the net and sound didn't came back
Thanks

ok i cant stay put so a quick replace of VoodooHDA 2.7.4 to VoodooHDA 2.7.3 and i have sound working again..
now lets try some better graphics

#56
AndersenTech

AndersenTech

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Wilmington, Delaware
Version 1.5b (beta) released on the Google Code page

Notes: Contains an updated VoodooHDA kext tested with ML (10.8). Removes auto-startup function: Users must manually add the app to their login rules through the Settings App (system) or through login hooks (for use with /usr/bin/vd_startup). Keep in mind that this is a beta and likely should not be used on a daily basis. I do not have a Hackintosh here to personally test the updated loader and therefore, comments would be greatly appreciated!

#57
davidkozat88

davidkozat88

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Hi guys so I have a CLEVO w370et with Mountain Lion and the only thing not working at all is the Audio ALC 269.... I have tried lots of kexts VoodooHDA 2.7.2/3/4 2.8/ 2.8.2, also tried using Voodooloader latest version with loads of different VoodooHDA kext ... and after editing the Dev Id to the according one in the info.plist inside the kext I get this cpu panic... even when I launch it after it boot using Voodooloader... do you guys have any idea what i could be doing wrong... fortunately my laptops bios allows me to disable the audio card, which is handy... just before I get the cpu panic I can hear the speakers "Pop"

Thanks in advance.

Also get this KP if I enable it from S/L/E

Attached File  2013-02-05 03.52.53.jpg   173.53KB   19 downloads

#58
platinumsteel

platinumsteel

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Hey AndersenTech I just wanted to thank you for sharing that voodoo helper and voodoo loader patch..It fixed my booting problem...I always had to use the -f flag to boot into mac osx..Now i don't...

All i did was use voodoo patcher to install the custom voodoohda.kext then fireup vodoo helper again to make sure..then reboot and that was it..now i have working sound without any boot up problems..thaks a million pal..







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy