Jump to content

Install stops at PCI Configuration


  • Please log in to reply
11 replies to this topic

#1
cossack56

cossack56

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
I am trying to install Lion on a Abit IP35 Pro. I have 4 drives-1 Win7, 2 Gentoo Linux, 3 Snow Leop, and trying to install on 4th drive. Followed all instructions to a "T", booted into Installer partition, everything starts to load but stops at "PCI Configuration". I had the same problem after install of 10.6.8 update and replaced 2 kexts to repair. Will I have to replace same kexts to continue install here also?

The 2 kexts were AppleACPIPlatform and IOPCIFamily.

I am trying to install Lion on a Abit IP35 Pro. I have 4 drives-1 Win7, 2 Gentoo Linux, 3 Snow Leop, and trying to install on 4th drive. Followed all instructions to a "T", booted into Installer partition, everything starts to load but stops at "PCI Configuration". I had the same problem after install of 10.6.8 update and replaced 2 kexts to repair. Will I have to replace same kexts to continue install here also?

The 2 kexts were AppleACPIPlatform and IOPCIFamily.



This was supposed to post to "Lion install on MBR" section, sorry

#2
ikingblack

ikingblack

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts

I am trying to install Lion on a Abit IP35 Pro. I have 4 drives-1 Win7, 2 Gentoo Linux, 3 Snow Leop, and trying to install on 4th drive. Followed all instructions to a "T", booted into Installer partition, everything starts to load but stops at "PCI Configuration". I had the same problem after install of 10.6.8 update and replaced 2 kexts to repair. Will I have to replace same kexts to continue install here also?

The 2 kexts were AppleACPIPlatform and IOPCIFamily.




This was supposed to post to "Lion install on MBR" section, sorry


Remove any DSDT, and move the kexts to somewhere else.

#3
cossack56

cossack56

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Remove any DSDT, and move the kexts to somewhere else.


Thanks, I don't have a DSDT because DSDT Patcher throws errors on my MB so I can't use it. I copied the 2 kexts to the Installer partion and now it gets past that but hangs at BootCache.playlist and then KP's. So I am getting farther.

#4
kup

kup

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 319 posts
Use the original kexts from Lion, add npci=0x2000 to the kernel flags and detach any and all USB hubs or devices other than the mouse/keyboard and the usb pen you're installing from (if you are).

#5
cossack56

cossack56

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Use the original kexts from Lion, add npci=0x2000 to the kernel flags and detach any and all USB hubs or devices other than the mouse/keyboard and the usb pen you're installing from (if you are).


Solved it with Netkas boot file from another poster. Thanks

You can mark this solved!!

#6
kup

kup

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 319 posts
Which bootloader, got a link?

#7
cossack56

cossack56

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Which bootloader, got a link?



Here ya go=I had used this link http://mirror.netkas.org/Lion/boot

#8
Tetsuya Tsurugi

Tetsuya Tsurugi

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Location:Italy
is a text file ?

#9
cossack56

cossack56

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

is a text file ?



No, it's a complete boot file w/ the PC EFI bootloader. Just copy and paste into the root portion.

#10
mopperx2

mopperx2

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
i have tried to get my abit ip35 running lion for the past 2 weeks and cannot get passed the pci configuration begin. can you post a how-to or guide on what method you used. thanks

#11
cossack56

cossack56

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

i have tried to get my abit ip35 running lion for the past 2 weeks and cannot get passed the pci configuration begin. can you post a how-to or guide on what method you used. thanks


I used a separate hard drive in tandem with my Snow Lep install. I used the usb guide with MBR and instead of using a USB key I used my second HD. One thing that is different on my rig is that I Quad Boot using LILO-(Linux Loader) so I must use a MBR install. After following the instructions for the USB-MBR install, I did everything except install Chameleon. I used the PC-EFI boot as I've talked about above. Then I booted using "-v npci=0x2000" as my parameters. That bootloader is the only one that will boot Lion on my rig. I tried for 3 days straight to get it to work, got pissed quit, came back and finally got it to install, then I had problems with video-(NVIDIA GTS-450) and was able to fix that with a EXTRA folder with the nvenabler kext, ElliotForceLegacyRTC kext, FakeSMC kext, and EvOreboot kext. I also use a Intel 1 gig NIC so I had to use the kext for that also. I am not using any DSDT file.

I hope that helps you some.

#12
tomythebest

tomythebest

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
If Installation stucks on "PCI Configuration Begin", in bootloader, write "npci=0x3000" and it works

(Sorry for bad english, i'm french)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy