Jump to content

Help Needed, stuck on Lion install boot.


  • Please log in to reply
25 replies to this topic

#1
Moze

Moze

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
So I'm trying to install LION on my hackintosh.

It's lifehacker build.

MB: GA-EP45-UD3P
CPU: Intel C2D Q9550
RAM: 4x2GB DDR2 800
VGA: nVidia GTS 250

No extra hardware connected.

I boot up and what ever I do, get stuck on this lines:

Kernel is LP64
				0				0 AppleUSBCDC: start - initDevice failed
com.apple.launchd 1 com.apple.launchd 1 ***launchd[1] has started ip. ***
...
Creating RAM Disk for /Library/Keychains
initialized /dev/rdisk13 as a 1024 KB HFS Plus volume
using 64-Bit bootcache playlist
BootCacheControl: Unable to open /var/db/BootCache.playlist: 2 No suck file or directory
Bug: launchctl.c:2408 (24957):30: (dbfd = open(g_job_overrides_db_path, 0_RDONLY | 0_EXL....

Currently have no extra kexts, tried with all different kexts from my SL drive. Alway get stuck on this lines above.

I'm using newest chameleon RC5 (1186 if I remember right).
Here is my org.chameleon.Boot.plist

<key>GeneratePStates</key>
	<string>Yes</string>
	<key>GenerateCStates</key>
	<string>Yes</string>
	<key>EthernetBuiltIn</key>
	<string>Yes</string>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Kernel Flags</key>
	<string>-v</string>

Generated DSDT from windows with DSDT Autopatcher.

Never had such problems before, and i'm hackintosh user since Leopard.
Please help, I'm banging my had up a desk here.


edit - attached screenshot of console output.

Attached Files



#2
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary
Try with FakeSMC.kext

#3
Moze

Moze

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

Try with FakeSMC.kext


Tried with and Without it - same results.

That BootCache.playlist file really does not exist. But why only for me? And if it's for everyone, then why i'm stuck on it? :\

#4
Moze

Moze

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
So I tried different kexts, disabler, tried with kakewalk 4, older version of chameleon. And I still get the same error every time. I'm so damn frustrated!

I tried putting BootCache.playlist file, that I found on SL drive, to place where Lion is looking for it. But then I get errors that there are problems with it.

Maybe some one could give me that file from their Lion install?

P.S. I had same problem with Lion GM, so decided to wait for final release, and now with this final that I downloaded for macbook problem is still there.

#5
copil

copil

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,716 posts
  • Gender:Male
  • Location:Italy
Changes the identification of the model, for your configuration the ideal is MacPro3,1 and follow the guide of MaLd0n.
http://www.insanelym...howtopic=256729

Change this key
<key>SMproductname</key>
<string>MacPro3,1</string>


#6
Moze

Moze

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

Changes the identification of the model, for your configuration the ideal is MacPro3,1 and follow the guide of MaLd0n.
http://www.insanelym...howtopic=256729

Change this key

<key>SMproductname</key>
<string>MacPro3,1</string>


The first time I tried with GM, I used this guide, ended the same.

I just tried to do it again. Cleaned the disk and followed everything step by step and same results.

I attach screenshots of output.

Posted Image
Posted Image

P.S. I does not seem to crash or etc., I can type in console. Feels like it's waiting for something.

#7
kdawg

kdawg

    InsanelyMac Legend

  • Donators
  • 508 posts
  • Gender:Male
  • Location:Boston, MA

The first time I tried with GM, I used this guide, ended the same.

I just tried to do it again. Cleaned the disk and followed everything step by step and same results.

I attach screenshots of output.

Posted Image
Posted Image

P.S. I does not seem to crash or etc., I can type in console. Feels like it's waiting for something.

I'm in the same situation. I'll let you know if I make any progress.

#8
copil

copil

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,716 posts
  • Gender:Male
  • Location:Italy
Try to install from internal HDD instead of USB stick.

#9
baller2319

baller2319

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Gender:Male
I have the same exact problem with my install. Its driving me nuts please let me know if you figure out something.

#10
thepretender

thepretender

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 116 posts
Just trying to get clear picture of what you are doing. Is this it in a nutshell?

1. Use guide to get files from install dmg onto usb drive.
2. Install chameleon onto the usb drive.
3. Copy working SL extra folder onto the usb drive.
4. Boot with usb drive and install stalls at bootCashe.playlist

By the way bootCashe.playlist is not on my usb drive either just bootCashe.data and my install has gone without a problem twice once for clean install and once for upgrade install. But I'm using Cartri bios and have no need for DSDT.

#11
aufa333

aufa333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 202 posts
  • Gender:Male
am pretty much close to that prob ,am stuck at the first boot gray metallic screen that u get after verbos ;) ,plz help.

btw i already tried 3 dif tutorials and all ends up with the same thing :((.

EDIT:
problem solved with some kexts and fakesmc +correct smbios ,now everything is just perfect :).
i will make a full tutorial soon about what i did incase someone didnt got any success with the other tutorials floating around.

#12
Moze

Moze

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

Try to install from internal HDD instead of USB stick.


I tried both, tried formatting hdd with multiple partition or only one. Same results all the time.

Just trying to get clear picture of what you are doing. Is this it in a nutshell?

1. Use guide to get files from install dmg onto usb drive.
2. Install chameleon onto the usb drive.
3. Copy working SL extra folder onto the usb drive.
4. Boot with usb drive and install stalls at bootCashe.playlist

By the way bootCashe.playlist is not on my usb drive either just bootCashe.data and my install has gone without a problem twice once for clean install and once for upgrade install. But I'm using Cartri bios and have no need for DSDT.


1. Used files from most popular guides in this forum. And my own files from perfectly working SL drive.
2. Installed chameleon on USB, and hdd when I was trying to install from hdd. Tried different versions on chameleon.
3. True, also tried copying them before chameleon.
4. Yes it stalls and feels like waiting for something, I waited for 20 min with no success.

Before every try I did a drive format.

Cache files should be generated by it's own. So I'm surprised why there are such problems. Maybe the problem is in something else. And it's just coincident that it stalls at those lines every time. On the other side install may occur from read only media. I guess installer should be creating ram drive and hold all cache in there.

Long time ago when Cartri was still active I tried it and had problems with USB. So reflashed back to normal. But I wish to try again, maybe you have one for ud3p ?

I will try playing with bios settings and sata cables In the meanwhile.

If anyone have any ideas what should I try please do not hesitate and write here.

This is such a horrible experience for me. I hate when I can't find the cause for problem.

#13
DeadlyBunny

DeadlyBunny

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Location:⌘ ⌥ + esc
I got the same problem on my notebook (Acer Aspire 2920z). I've tried to add arch=i386 or my processor bus ratio (14) but always stuck on that message. :(

#14
Moze

Moze

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
So I tried different BIOS settings, tried changing sata ports and sata cable. No luck.
Then I tried to follow tonymacx86 guide. Installed SL following iBott + ##### guide (everything went ok), then followed xMove guide for Lion and stuck on same {censored}!

Arrggghhh!

Is there any person who had a success on GA-EP45-UD3P motherboard?

And please everyone who have the same issue write your hardware info.

#15
kdawg

kdawg

    InsanelyMac Legend

  • Donators
  • 508 posts
  • Gender:Male
  • Location:Boston, MA

So I tried different BIOS settings, tried changing sata ports and sata cable. No luck.
Then I tried to follow tonymacx86 guide. Installed SL following iBott + ##### guide (everything went ok), then followed xMove guide for Lion and stuck on same {censored}!

Arrggghhh!

Is there any person who had a success on GA-EP45-UD3P motherboard?

And please everyone who have the same issue write your hardware info.

I was able to get past this hurdle. I had to use Netkas's PCEFI for Lion.
Use the 10.6 installer from here.
Then swap out the boot file from here.

Very kludge but it works. Not sure why people have been hanging at this particular spot. To avoid the long kext loading process add Usekernelcache=Yes to your apple.com.boot.plist then move all your kexts out of E/E and into S/L/E and rebuild with the latest Kext Wizard or Kext Utility.

Good Luck. My Lion install works as good as 10.6.8.

#16
baller2319

baller2319

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Gender:Male

I was able to get past this hurdle. I had to use Netkas's PCEFI for Lion.
Use the 10.6 installer from here.
Then swap out the boot file from here.

Very kludge but it works. Not sure why people have been hanging at this particular spot. To avoid the long kext loading process add Usekernelcache=Yes to your apple.com.boot.plist then move all your kexts out of E/E and into S/L/E and rebuild with the latest Kext Wizard or Kext Utility.

Good Luck. My Lion install works as good as 10.6.8.


thanks kdawg! But i cant seem to download the boot file. It downloads as text.


edit: never mind just deleted the .txt extension

#17
Moze

Moze

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

I was able to get past this hurdle. I had to use Netkas's PCEFI for Lion.
Use the 10.6 installer from here.
Then swap out the boot file from here.

Very kludge but it works. Not sure why people have been hanging at this particular spot. To avoid the long kext loading process add Usekernelcache=Yes to your apple.com.boot.plist then move all your kexts out of E/E and into S/L/E and rebuild with the latest Kext Wizard or Kext Utility.

Good Luck. My Lion install works as good as 10.6.8.


It Worked! I booted the install with it, installed the Lion and it's working. Thank you!

Because with PC-EFi I can't make the GraphicsEnabler to work properly, I tried to Boot it with newest Chameleon RC5 that I use for SL. But boot up, stalled, just in different place then installer :).

Also Sound not working at all, will try to find a solution. Just copied AppleHDA.kext from SL and it work.

#18
DeadlyBunny

DeadlyBunny

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Location:⌘ ⌥ + esc

I was able to get past this hurdle. I had to use Netkas's PCEFI for Lion.
Use the 10.6 installer from here.
Then swap out the boot file from here.

Very kludge but it works. Not sure why people have been hanging at this particular spot. To avoid the long kext loading process add Usekernelcache=Yes to your apple.com.boot.plist then move all your kexts out of E/E and into S/L/E and rebuild with the latest Kext Wizard or Kext Utility.

Good Luck. My Lion install works as good as 10.6.8.


If I used 10.6 installer, it wouldn't get in to the install screen, it always rebooting after the bootloader loading done. So I used another bootloader and replace the boot file but still stuck on that error message :D

#19
pagaille

pagaille

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

If I used 10.6 installer, it wouldn't get in to the install screen, it always rebooting after the bootloader loading done. So I used another bootloader and replace the boot file but still stuck on that error message ;)


Doesn't work for me either... Stuck at the grey screen just after the console messages with a spindle wheel mouse at upper left of the screen.

I'm using an Asus P5-KPL.

#20
AlSnow

AlSnow

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

It Worked! I booted the install with it, installed the Lion and it's working. Thank you!

Because with PC-EFi I can't make the GraphicsEnabler to work properly, I tried to Boot it with newest Chameleon RC5 that I use for SL. But boot up, stalled, just in different place then installer :(.

Also Sound not working at all, will try to find a solution. Just copied AppleHDA.kext from SL and it work.



How did it work? Could you please explain the procedure in depth... I'm trying to install Lion and get stuck on this screen ... It never goes anywhere from there:

Attached File  photo.jpg   147.27KB   180 downloads





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy