Jump to content

Mac OS X Lion 10.7 Golden Master on Fujitsu S6410


  • Please log in to reply
39 replies to this topic

#1
ucing

ucing

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Installation detail

Posted Image

#2
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
hi have you tried cam twist for your web cam???
I believe it was working with your laptop........

#3
ucing

ucing

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Brilliant.... robi62,

I just try installed camtwist and all of the sudden Facetime work flawlessly. Thank you for your marvelous advice.

Posted Image

hi have you tried cam twist for your web cam???
I believe it was working with your laptop........



#4
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
I am glad just bought a laptop like yours but having problems after reboot
You don't have anything in extra folder like dsdt.am what is your apple plist and smbios in extra???

#5
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
I have created a modified dsdt which will give you working brightness slider in display preferences pane
Let me know if you want it.
I also found a working kext for lan to work too

#6
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
After a week of testing managed a dsdt with sleep fix so laptop goes to sleep and wakes up no problem

To make F6 and F7 keys working for brightness I installed keyboard maestro and mapped those keys for it :P

#7
Sasch

Sasch

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Germany
Great Tutorial Thank you.
I think my Hardware are a little different but at the end it works . When i switch to 32bit Mode my Display not working correct.
Here are a solution for the Display in 32/64bit Mode without switchres.
Copy the file DisplayProductID-717 to /System/Libary/Displays/Overrides/DisplayVendorID-756e6b6e

A Solution for the Build in UMTS is the Sierra Watcher utility 2.06. The newer Version not worked for me.

And the last Solution is for the Battery :blink:

Now i having problems with Standby . Standby works but never wake up. The other problem is the Lan . Can´t get it to work
File

#8
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain

Great Tutorial Thank you.
I think my Hardware are a little different but at the end it works . When i switch to 32bit Mode my Display not working correct.
Here are a solution for the Display in 32/64bit Mode without switchres.
Copy the file DisplayProductID-717 to /System/Libary/Displays/Overrides/DisplayVendorID-756e6b6e

A Solution for the Build in UMTS is the Sierra Watcher utility 2.06. The newer Version not worked for me.

And the last Solution is for the Battery :D

Now i having problems with Standby . Standby works but never wake up. The other problem is the Lan . Can´t get it to work
File

Hi I need your dsdt as they might be different do you know how to extract it????
go here http://www.osx86.es/?p=610

and download dsdte editor open program and click on extract dsdt then save file and post file here

I also managed to get a patched apple hda to work 4 sound let me know if you want it


Attached File  AppleHDA.kext_.zip   1.57MB   37 downloads
Attached File  IONetworkingFamily.kext.zip   1.25MB   42 downloads
Attached File  Kext_Utility.zip   281.13KB   22 downloads


These are next for native sound and network
Install them with kextutility

Until i have your dsdt do not install sound it won't work

#9
Sasch

Sasch

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Germany
Great - Thank you for your help.
The patched apple Sound would be great :D ;)

Here is my dsdt file

Attached Files

  • Attached File  dsdt.zip   25.91KB   23 downloads


#10
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
Here it is

Attached File  dsdt.aml.zip   14.03KB   74 downloads

Which boot loader do you use???

This are my apple boot plist and smbiosplist

Attached File  com.apple.boot.plist.zip   894bytes   41 downloads

Attached File  smbios.plist.zip   473bytes   40 downloads

So let me know how it goes

To use key for brightness and sound download

keyboard maestro and then map only function keys without FN to get them working

#11
Sasch

Sasch

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Germany
Wow great Thank you very much.

As bootloader i used Chameleon 2.0 RC5 r877

Sleep is working perfect . Lid is working too.

Sound not working . It shows the Speaker Symbol in the Menu but no Sound .
Network is not really working. It shows that it have a connection - but can´t get a IP Adress.

Maping with keyboard maestro working great :rolleyes: ;)

I have a other problem . In the Bios I have switched Core Multi-Processing to disable. All works but i have only one CPU.
When i switches to enable the system hangs . I have try cpu=1 and cpu=2 . all the same . The system hung at the same error - ioapic: Version 0x20 Vectors

With SnowLeopard its works

Attached Files



#12
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
Did you install hda next in system library extensions????

Network works in my case but I always use wifi as i have swapped intel card for broadmcom and works oob

I use chimera or Chameleon 2 RC5 r1213

In system info when you click on audio does it show this???

Intel High Definition Audio:

Audio ID: 12

Headphone:

Connection: 1/8-Inch Jack

Speaker:

Connection: Internal

External Microphone / iPhone Headset:

Connection: 1/8-Inch Jack

Internal Microphone:

Connection: Internal

External Microphone / iPhone Headset:

Connection: 1/8-Inch Jack

#13
Sasch

Sasch

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Germany
Hi

Yes AppleHDA is installes in S/L/E

In Systeminfo it shows

Intel High Definition Audio

Audio-ID: 12

Speaker

Conection : Internal

Headphone:

Connection: 1/8-Inch Jack

Line in:

Connection: 1/8-Inch Jack

Internal Microphone:

Connection: Internal

I make a new clean installation - maybe i have installed a kext too much :rolleyes:

#14
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
ok I ll double check if I sent you right hda kext......

Sent you wrong one try this one

Attached File  AppleHDA.kext.zip   1.57MB   51 downloads


:rolleyes:

Attached File  boot.zip   129.07KB   38 downloads

Attached File  org.chameleon.Boot.plist.zip   474bytes   33 downloads

And try this bootloader with orgchamel..plist together with boot.zip

For the boot error have a look here
http://www.google.co...i...-8&oe=UTF-8

Let me know results

#15
Sasch

Sasch

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Germany
Hi

Sound is working -- Great :D - Thank you very much.

I have order today a SSD . Crucial m4 256GB ;o))

The problem with the second Core is the same. Sometimes when i wait a long time it boot the system . sometimes no. I don´t understand it. Have you problems with the second Core ??


Is it difficult to make a own dsdt File ?? I have a second notebook - Asus G74SX - I have a little problem to get the sound working.

#16
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
No I don't have a problem with second core could it be some setting in bios
do you have latest one ???or some different settings from mine

I boot up in round 40 seconds

How do you boot up with UseKernelCache=Yes ?????

For sound for you other laptop look here


http://tonymacx86.co...hp?f=34&t=24522

#17
Sasch

Sasch

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Germany
UseKernelCache=Yes ??

No i don´t have it in the com.apple.boot.plist

Where you have saw it ??


here are screen shots of my Bios. It is the same as yours ?? I have the newest Bios . It Version 1.30

Attached Files



#18
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
Ok only difference i have seen I have my firewire blutooth and smart card disabled
also I have power button off ,resume lan only ac mode
hardware power management enabled

I do not have low power mode in my settings maybe is something to do with ums card????
Also what kexts do have in your extra folder????
These are mine


Attached File  extra.jpg   93.63KB   59 downloads

#19
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
Maybe it could be my apple boot file????

try to boot without it and tell me if you get same problem

I booted with you dsdt.aml and its fine so its not that

#20
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
@Sasch any luck with it??????





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy