Jump to content

[Guide] Lion on GA-EP45-UD3R - very close to perfection


  • Please log in to reply
298 replies to this topic

#61
SunLizard

SunLizard

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts

You saved my life with the trifecta thing. Thank you. I have the same mobo as you and I'm still using eliade's dsdt and everything works, should I switch to yours? Do you have sleep working and everything. Also is there a way to compile these audio kexts so that everything works immediately upon install. Do you think it could be fixed by patching dsdt? You think you could do it?



1) If you're happy where you are with functionality, mosec, I wouldn't worry about tweaking dsdt.aml Hardware wise, you should be fine but you never know (this works with F7 BIOS rev for this board. I don't expect much if anything would have changed for the most recent Rev (10) but my philosophy is, its not broken, don't fix it...

2) I'm not 100% certain, but I think while my system sleeps just fine, the HDD's may not sleep independently, I'll have verify that later.

3) I think you'd still have to replace the AppleHDA.kext from the original base install (you could try looking into replacing that when you add OSXInstall.mpkg to the /Packages/ on the base system, but I think that would require a bit of heavy-handed Pacifist manipulation. Alternately, as soon as Lion goes to retail, I'm sure MrJanek and his band of merry OSX fans will be updating Kakewalk to automate the process.

4) I can patch a dsdt.aml with the tools that the community has available as can anyone with a couple hours of boredom. There are several good threads on that subject alone (I learned it all on this site!) The DSDT.aml provided for the 45T board was all done with guides from here and tools!

#62
lob3s

lob3s

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

I'm confused, let's clear things out again:
1/ you can't go beyond post screen, right ? not even past HDD detection during boot, right ?
2/ SL/7/fat32 are all on one single HD, but that drive is internal right ? if so there won't be a problme.
3/ this internal drive is MBR not GUID, right? if so don't forget to use OSXinstall_MBR, but that os not the problem yet anyway
4/ the drive you formatted that had Lion installer, is a USB flash drive or USB HDD ? it is not an internal drive, right?
5/ that USB drive with lion instaler, is GUID or MBR ?
6/ is there multiple partition on that drive, or am i totally confused and the drive you have Lion installer is on the same drive as SL, 7, Fat32...


Great news! I got it working!

I used a different version of chameleon on a seperate thumb drive and it booted flawlessly! I'm currently copying my data to an external so I can start fresh. I'm going to use OSX 24/7 seeing as that I only used my Windows 7 partition for games and the only games I play are TF2 and CS:S, which are available through Mac now. Thanks for your help!

#63
sultangetin

sultangetin

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
  • Gender:Male
  • Location:india
i've got everything working except the internet and file sharing with windows, which was previously working with snow leopard.

can anybody confirm that others having the same problem or not???

#64
SunLizard

SunLizard

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts

i've got everything working except the internet and file sharing with windows, which was previously working with snow leopard.

can anybody confirm that others having the same problem or not???


If you mean 'internet' as in "any wired or wireless networking" - I can confirm that Wired Marvel 10/1000 ethernet hardware works just fine with Eliades's included e/e kexts.

With windows file sharing - I have no data. I have connected a NTFS formatted drive via USB and it works reads normally. as far as SMB shares, I (thankfully) have no Windows machines to test with anymore!

#65
ledjohnny

ledjohnny

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
If we use the retail install that was just released to the public by apple will we be able to update to the newest version. The reason for my question is that the final release seems to be a lower build number than the GM. However if the setup detects an internet connection it will update, so hmm I wonder if we can update through the software updater...

#66
thay

thay

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Got a problem with to Boot USB Stick on GA-P45-UD3LR after setup on (8.1 GB SMI USB DISC Media) like you did describe here .

When I plug this USB to the PC and restart, my PC halt and I must press Reset button and it halt again until I unplug the USB.

So I did reformat the Stick to Mac OS Extendet Journaled then I did restart my PC until it comes to Memory Count, then I hit F12 and I can choose the USB stick to boot.

So again I setup the like the stick you describe here and the same {censored} happend. The PC just halt after grafik post messages. Usually the Memory starts counting. but again nothing pc just hold. alt + ctrl + entf (del) does not work. I got to push the reset button.

I did try until now several USB Media without success for example like a 300 GB extern USB HD and a 16 GB USB Stick same problem here.

Cant believe it. I have no answer solution at all. I could throw my pc out of the window :-(

The only solution I see right now is to create 2 partitions on my HD. One with at least 8gb. On this partion I bring everything on it like described here in the awsome tutorial

But how can I boot from USB?

#67
thepretender

thepretender

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 116 posts

But how can I boot from USB?


Try a newer build of Chameleon had to use 1035 on my ep45-ud3p.

#68
thay

thay

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts

Try a newer build of Chameleon had to use 1035 on my ep45-ud3p.

I did use Chameleon_2.0_RC5_r1083.pkg

Anyway I did try Kakewalk 4.0 now and it is working. No problem at all.

Now I can boot from USB.

I can't tell whats diffrent in Kakewalk 4 because you just hit some buttons thats all.

#69
thepretender

thepretender

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 116 posts

I did use Chameleon_2.0_RC5_r1083.pkg

Anyway I did try Kakewalk 4.0 now and it is working. No problem at all.

Now I can boot from USB.

I can't tell whats diffrent in Kakewalk 4 because you just hit some buttons thats all.

Glad you got it working I should have said 1135 not 1083 :)

#70
edwardgtxy

edwardgtxy

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
After finished installing, the OS got stuck during boot, last line is DSMOS has arrived.

#71
iHand

iHand

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Hay man, great Guide, thanks, but I have little problem here!:-)

So I can't get sound out of the system, in System Profiler, or System Report (they call it now) under Audio I can see my things, but at System Preferences "No Outpot Device".

First I tried with #####+xMove+#####, everything worked fine besides of sound, after I repleaced everything with your things still everything seems to bee god, besides the sound thing....

So what can I do?

THX

#72
magare

magare

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:ANZ
Thanks heaps !!!

Great guide and it works 100%
Amazing effort mate. Works perfect for my EP45 DS4P with HD 6870.
Have not tested sleep/shutdown/reboot but all the rest works OK.

Enjoy Lion guys !!!

#73
Matty___

Matty___

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
  • Gender:Male
  • Location:The Netherlands

Thanks heaps !!!

Great guide and it works 100%
Amazing effort mate. Works perfect for my EP45 DS4P with HD 6870.
Have not tested sleep/shutdown/reboot but all the rest works OK.

Enjoy Lion guys !!!


does dual display work with the 6870?

#74
magare

magare

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:ANZ

does dual display work with the 6870?


Yes. It does.

Everything works perfect, including shutdown/restart/sleep.


ALS 889a only front speaker or only back speakers, but probably will need to play with the outputs.

#75
pollopollo

pollopollo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts
  • Gender:Male
Can anybody help me?
I'm trying to instal the final release of lion on my Gigabyte EP45-UD3R that has the cartri's Mac BIOS v0.8; I'm using my Macbook and a Verbatim 8GB USB pen drive.
I've followed the guide but I can't install the OS because when i plug in the Usb pen and I turn on my PC it stop on the bios splash screen!! (if I take off the USB pen the pc turns on perfectly) I think There is probably a bootllader problem..
Thanks in advance!!

#76
thay

thay

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts

<br />Can anybody help me?<br />I'm trying to instal the final release of lion on my Gigabyte EP45-UD3R that has the cartri's Mac BIOS v0.8; I'm using my Macbook and a Verbatim 8GB USB pen drive.<br />I've followed the guide but I can't install the OS because when i plug in the Usb pen and I turn on my PC it stop on the bios splash screen!! (if I take off the USB pen the pc turns on perfectly) I think There is probably a bootllader problem..<br />Thanks in advance!!<br />

<br /><br /><br />


I had the same problem. Just look some posts above this one.

I must be a problem with the bootloader
Try a different one.

I had success with Kakewalk 4.0

This tutorial here ist awsome anyway. You learn a lot more when doing stuff step by step.

#77
cizko

cizko

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Was there anything special about installing Snow Leopard with that bios (i.e. a special Kext because of that modded bios)... I actually never tried it...
If snow leopard was a rather normal install, it should work with Lion too...

Let me know how it goes...



I Have have an EP45T-UD3LR with Catri 0.8 and can't get the USB Medium to do a proper boot. After some time it just stalls with a symbol of a dashed circle. Anyone else experiencing something similar? ;)

#78
pollopollo

pollopollo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts
  • Gender:Male

I Have have an EP45T-UD3LR with Catri 0.8 and can't get the USB Medium to do a proper boot. After some time it just stalls with a symbol of a dashed circle. Anyone else experiencing something similar? ;)

OK, I'm in the same position! as THAY said the problem was the version of chameleon posted in this topic, I've used Chameleon 2.0 RC5 r1200 and now the USB works, the installation begin but it stops with a white screen and the rainbow circle keeps spinning.
Kext problem?

#79
jugdus

jugdus

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Can anybody help me?
I'm trying to instal the final release of lion on my Gigabyte EP45-UD3R that has the cartri's Mac BIOS v0.8; I'm using my Macbook and a Verbatim 8GB USB pen drive.
I've followed the guide but I can't install the OS because when i plug in the Usb pen and I turn on my PC it stop on the bios splash screen!! (if I take off the USB pen the pc turns on perfectly) I think There is probably a bootllader problem..
Thanks in advance!!


Hi pollopollo

I had the same problem with a 16GB USB pen drive, until I read somewhere the pen drive needs to be formatted as MBR instead of GUID. After formatting as MBR mine functioned normally, without any further problem

#80
ledjohnny

ledjohnny

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

OK, I'm in the same position! as THAY said the problem was the version of chameleon posted in this topic, I've used Chameleon 2.0 RC5 r1200 and now the USB works, the installation begin but it stops with a white screen and the rainbow circle keeps spinning.
Kext problem?


Yea I have this problem too, I was able to boot into the installation before but I'm not sure what triggered this error. Just the spinning beach ball now...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy