Jump to content

p7p55d sleep


  • Please log in to reply
3 replies to this topic

#1
mcdougal33

mcdougal33

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
Ok so I got Lion installed and working almost perfectly. I am having an issue with sleep. I can put my computer to sleep and it goes to sleep properly. I press a mouse button or a key on my keyboard and it begins to wake. The screen stays black and nothing more happens. I have to hold the power button to turn it off. When I restart, the BIOS says there is a new cpu installed and my cpu settings are reset.

I've got a fairly vanilla install. The only kexts I am using are FakeSMC, lnx2mac rtl driver, voodoohda. I'm using a DSDT created from the dsdt auto-patcher which is available on this site. Sleep used to work fine in Leopard (well, automatic sleep never worked properly but manual sleep did).

My boot.plist contains the following:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Kernel Flags</key>
	<string></string>
	<key>Hide Partition</key>
	<string>hd(1,2) hd(1,3)</string>
	<key>GraphicsEnabler</key>
	<string>Yes</string>
	<key>Timeout</key>
	<string>5</string>
	<key>Legacy Logo</key>
	<string>Yes</string>
	<key>EthernetBuiltIn</key>
	<string>Yes</string>
	<key>GeneratePStates</key>
	<string>Yes</string>
	<key>GenerateCStates</key>
	<string>Yes</string>
</dict>
</plist>


#2
mcdougal33

mcdougal33

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
Well, I thought I would give this another go. I found the solution in another thread. Run the following from a terminal window:

sudo perl -pi -e 's|\x8b\x45\xc8\x39\x45\xcc\x74\x0b|\x8b\x45\xc8\x39\x45\xcc\xeb\x0b|; s|\x8b\x45\xb4\x39\x45\xb8\x74\x08|\x8b\x45\xb4\x39\x45\xb8\xeb\x08|' /System/Library/Extensions/AppleRTC.kext/Contents/MacOS/AppleRTC

Make sure "startup automatically after power failure" is CHECKED in system preferences\energy

I am using a DSDT created by the dsdt auto-patcher. I've heard success stories with the dsdts from tonymacx86 as well.

#3
koira

koira

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Hamburg, Germany
  • Interests:digital media tools, edge-of-technology gadgets and.... cooking!
Patching the AppleRTC in the way mentioned finally helped me getting sleep to work again with Lion as it was working with Snow Leopard all the time. Running Asis P7P55D with vanilla kernel, autopatched DSDT, OS X 10.7 and FakeSMC+plugins in /Extra. Because of me using the ATI Radeon 5770 setting GraphicsEnabler=No was tricky to find out.

Just like running SL my system refrains to go to sleep automatically in Lion. No change here. So I was really happy to see that PleaseSleep has been updated to support Lion.

#4
mcdougal33

mcdougal33

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
Automatic sleep is working for me on 10.7. I could not get auto sleep to work on 10.6. I'm not too sure why this is but I'm not complaining.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy