Jump to content

[Guida] Installare OS X Lion e Mountain Lion !

Guida Installare OSX Lion Mountain

  • Please log in to reply
2282 replies to this topic

#1921
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male
i miei probelmi non finiscono mai ..
Aiuto !

Ho un problema al quanto strano con chamaleon .
Ho preso un poratile Samsung RC 530 J06 con processore I5.

Se installo Mountain Lion su un disco da 320 Gb e poi installo successivamente Chamaleon , il boot funziona ,
mentre se installo Mountain Lion su un disco da 500 Gb o 1000 Gb Chamaleon non Butta. , mi esce fuori il messaggio di inseire il dispositvo bootabile ( qualcosa del genere ).

Ho provato anche a installare sul disco da 1000 Gb Mountain Lion , successivamente Win 7 e infine Chamaleon con Mountain ( facendo bouttare da USB ) ma continua partire Win 7 , e non il menu di Chamaleon .

Visto il che boot di Chamaleon non avviene con il dischi maggiori di 320Gb , anche partizionandoli con una sola partizione dove e installato mountain e basta , mi sto chiedendo quale soluzione posso adottare, devo settare qualche opzione al momento dell'installazione ?

#1922
vicmin

vicmin

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Questo vuol dire che probabilmente ti mancano i driver del controller dischi (ipotizzo). Riesci ad entrare nel sistema tramite il bootcd? di che bootcd si tratta?


Uso "i B o o t" cd. Con questo sono riuscito ad installare Snow Leo, tutte le atre installazioni di OS X non partono neanche :(. Ho provato di tutto, non riesco neanche ad arrivare alla schermata della scelta della lingua, si riavvia molto prima!!
Non so come fare ad entrare nel sistema tramite bootcd

#1923
peppect1984

peppect1984

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
Ragazzi ho seguito la guida alla lettera ma c'è ancora qualcosa che non quadra, ho fatto tutto il procedimento su hard disk mbr, ho aggiunto i fle che sono postati nella guida, ho messo il mach kernel nella root ma appena provo a fare il boot si blocca, ho fatto partire da un preboot su cd di chameleon e carica per un minuto il mach kernel, dopo di ferma non facendomi proseguire, Il mio pc è cambiato, non è più quello che avevo in firma, monto adesso una mainboard Gigabyte X48-DS5 e gira senza alcun intoppo grafico o altro ideneb 10.5.7.. Ho una scheda video nvidia geforce 256mb 6200le...
Intel® X48 Northbridge
Intel® ICH9R southbridge
Realtek 8111C ethernet
Realtek ALC889A audio (installo i voodooHD per farlo andare su ideneb)

#1924
peppect1984

peppect1984

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
Vi aggiorno sulla mia situazione, come tutti gli utenti sono andato avanti tramite il software ******** ... ho fatto partire l'installazione tramite -v ma purtroppo come tutti gli atri utenti arrivato ad un certo punto si riavvia, E' molto veloce e non go modo di vedere quale kext crea questo comportamento anomalo, qualcuno ha consigli in merito?

#1925
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D

....ho aggiunto i fle che sono postati nella guida

Quali file?

ho messo il mach kernel nella root ma appena provo a fare il boot si blocca

Cosa vuol dire "si blocca" ? senza una spiegazione dell'errore non si può fare nulla. Il bios è settato correttamente? ahci abilitato?

Vi aggiorno sulla mia situazione, come tutti gli utenti sono andato avanti tramite il software ******* ... ho fatto partire l'installazione tramite -v ma purtroppo come tutti gli atri utenti arrivato ad un certo punto si riavvia, E' molto veloce e non go modo di vedere quale kext crea questo comportamento anomalo, qualcuno ha consigli in merito?

Tutti gli utenti? di cosa parli? tutti gli utenti che seguono questa guida utilizzano SOLO chameleon, senza nessun software esterno come quello citato da te. E tra le tante cose non diamo supporto a nessun software preso da terze parti

#1926
peppect1984

peppect1984

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
Ok, non sapevo la situazione del software di terze parti e mi scuso per questo, io volevo seguire per filo e per segno la tua guida ma quando provo a bootare da hard disk esterno restava bloccato li, non spuntavano ne mele ne niente, restava proprio sul bios della scheda madre e per farlo andare ho fatto come hanno consigliato in questo thread, quindi tramite quel programmino che non cito, così solo il boot è partito, ha caricato tutti i kext e successivamente si è riavviato, è molto veloce a caricare tutti i kext quindi non riesco a capire quale sia a creare problemi, ho provato a far partire l'installazione su tre computer differenti e tutti e tre hanno avuto lo stesso problema, due tra i quali hanno una scheda video nvidia ed uno ha un intel

#1927
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D
E allora arrivo a l'unica conclusione logica. Non hai seguito bene il procedimento. Non è possibile che su 3 computer diversi abbia il medesimo comportamento. Magari rifai la procedura con calma, ed assicurati di installare chameleon sulla usb. Inoltre metti FakeSMC nella cartella Extra/Extensions e magari dai un'occhiata al bios

Ti assicuro che altri software fanno più danni che utile

#1928
peppect1984

peppect1984

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
Il procedimento l'ho rifatto decine di volte e mi dà sempre lo stesso problema a bootare, chameleon lo installo sulla usb, non sono molto ferrato di mac motivo per cui vi chiedo di pazientare un pò, non mi spiego perchè quando installo chameleon mi dà problemi nell'installazione, poi per risolvere clicco con il destro sull'hard disk usb, ottieni informazioni, clicco sul lucchetto condivisione e permessi, metto su tutti lettura e scrittura, everyone ed applica, eseguo il procedimento da un hackintosh con la 10.5.7 installata, appena dò i permessi sembra che esegua correttamente l'installazione di chameleon, adesso ho appena riaggiunto FakeSMC, riavvio e vediamo che succede, vi tengo informati!

#1929
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D
Molti hanno problemi quando seguono la guida da un sistema con leopard, è consigliabile usare almeno snow leopard. In caso avessi ancora problemi prova così, di sicuro non viene installato correttamente chameleon

#1930
vicmin

vicmin

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Anche a me si riavvia costantemente. Il procedimento l'ho fatto tramite Snow Leopard. :(

#1931
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D
Dipende dall'hardware e dalla versione di chameleon probabilmente. Stai installando sul notebook in firma? fakesmc è presente?

Aggiunto il nuovo FakeSMC intanto, quello presente nella guida era vecchiotto

Per chi ha problemi di reboot, fate una prova con questo https://dl.dropbox.c...rev609.kext.zip

#1932
peppect1984

peppect1984

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
Ragazzi per tutti coloro che hanno un riavvio improvviso seguendo questa guida, è il kernel!!! Sostituito il kernel la guida sembra andare, ora è sorto un altro problema, l'ApplePIIXATA.kext che ovviamente mi da kernel panic...

#1933
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D
E' normale che sia il kernel se non ci sono kext segnalati. Dipende dalla cpu di ognuno. Per quanto riguarda ApplePIIXATA, eliminalo, ed avvia con -f

#1934
cavallo

cavallo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 357 posts
  • Gender:Male
La guida di Fiox e' perfetta tanto che Mountain lion si installa. Quello che succede dopo non dipende dalla chiavetta, ma dal bootloader e dall'hardware.
Capisco che non siamo tutti uguali, pero' potreste andare a vedere le compatibilita' della scheda grafica, se vi siano kext problematici e cercaste un chameleon piu recente forse non tormentereste così. Ho usato per la incompatibilita' del mio hardware un software che funziona ma che non c'entra con la chiavetta infatti l'ho usato in fase di post installazione, si tratta di my hack. E' un software libero tra l'altro compilato con i consigli di vari compilatori di questo forum. Li ho letto dei kext problematici e come far partire con grafica problematica (GraphicsEnabler=No) dopo aver eliminato tutti i kekt intelHDgraphics, ati, Nvda e Geforce. Il kernel modificato e' stata la prima cosa che ho cercato avendo un atom.

#1935
vicmin

vicmin

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
@Fiox89: si, sto installando su notebook in firma. Oggi provo ancora con il nuovo fakeSMC. Ho usato diverse versioni di Chameleon ma il risultato non cambia :(

@peppect1984: Quale Kernel hai usato? Hai qualche suggerimento per me?


Grazie

#1936
peppect1984

peppect1984

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts

E' normale che sia il kernel se non ci sono kext segnalati. Dipende dalla cpu di ognuno. Per quanto riguarda ApplePIIXATA, eliminalo, ed avvia con -f


Ho già provato ad eliminare il file all'interno della cartella extension ma il risultato non cambia

peppect1984: Quale Kernel hai usato? Hai qualche suggerimento per me?


Grazie


Il kernel che devi inserire dipende dal tipo di processore che utilizzi ogni processore ha un kernel suo, magari fai una ricerca su google tipo "mach kernel + nome tuo processore" esempio... mach kernel core 2 duo e8600

#1937
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D

Ho già provato ad eliminare il file all'interno della cartella extension ma il risultato non cambia

Se lo hai eliminato non può apparire a video quando avvii, non credi? le cose sono 2, o hai un altro sistema osx installato (ma non credo dipenda da questo) o non avvii con -f, oppure semplicemente non hai eliminato il kext corretto...

Non ci può essere altra spiegazione

Il kernel che devi inserire dipende dal tipo di processore che utilizzi ogni processore ha un kernel suo, magari fai una ricerca su google tipo "mach kernel + nome tuo processore" esempio... mach kernel core 2 duo e8600

Quello che dici non è esattamente vero, anzi. I processori intel sono pienamente supportati dal kernel originale apple, non è necessario sostituirlo. I problemi derivati dalla cpu non dipendono dalla stessa, ma dal chipset o dalla scheda madre spesso e volentieri (mancanze nel bios)

In ogni caso quando proprio non si trova una soluzione migliore, allora si usa un kernel anche per processori intel, ma non è comunque consigliabile (tranne rari casi magari)

#1938
peppect1984

peppect1984

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts

Se lo hai eliminato non può apparire a video quando avvii, non credi? le cose sono 2, o hai un altro sistema osx installato (ma non credo dipenda da questo) o non avvii con -f, oppure semplicemente non hai eliminato il kext corretto...

Non ci può essere altra spiegazione


Quello che dici non è esattamente vero, anzi. I processori intel sono pienamente supportati dal kernel originale apple, non è necessario sostituirlo. I problemi derivati dalla cpu non dipendono dalla stessa, ma dal chipset o dalla scheda madre spesso e volentieri (mancanze nel bios)

In ogni caso quando proprio non si trova una soluzione migliore, allora si usa un kernel anche per processori intel, ma non è comunque consigliabile (tranne rari casi magari)


Io go riportato semplicemente la mia esperienza, avevo provato a fare di tutto, modifiche al bios comprese ma senza successo, appena ho messo il mach kernel invece è andato tranquillamente, l'unica problematica che rimane è quella di questo kext, sono sicuro di averlo eliminato e sono ancora più sicuro di aver avviato con -f ma il problema persiste, per assurdo ho anche provato a cancellare tutta la cartella extension senza alcun risultato, Ora mi viene da pensare solo una cosa, questo kext stà anche da qualche altra parte... non mi trovo altra spiegazione...

#1939
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D

Io go riportato semplicemente la mia esperienza, avevo provato a fare di tutto, modifiche al bios comprese ma senza successo, appena ho messo il mach kernel invece è andato tranquillamente, l'unica problematica che rimane è quella di questo kext, sono sicuro di averlo eliminato e sono ancora più sicuro di aver avviato con -f ma il problema persiste, per assurdo ho anche provato a cancellare tutta la cartella extension senza alcun risultato, Ora mi viene da pensare solo una cosa, questo kext stà anche da qualche altra parte... non mi trovo altra spiegazione...

Ora che ci penso non abbiamo ancora visto una foto del kernel panic, o mi sbaglio? magari il problema è altrove

#1940
vicmin

vicmin

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Ciao,
ho provato a reinstallare cambiando il Kernel e rifacendo la procedura da zero. Non sono ancora riuscito a far partire l'installazione ma almeno ora non si riavvia continuamente. Questa volta ho un Panic con un avviso che dice di premere il pulsante di alimentazione per spegnere il pc.
Suggerimenti?





Also tagged with one or more of these keywords: Guida, Installare, OSX, Lion, Mountain


2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy