Jump to content

[Guide] Dell XPS 15 L502X (Early 2011) Snow Leopard Install (possibly L702x too)

* * * * * 5 votes

  • Please log in to reply
2972 replies to this topic

#1961
Ahmed_shiko

Ahmed_shiko

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:EGYPT
@Doix

install success ML 10.8

in boot -v problems


Aug 9 16:16:45 Ahmeds-MacBook-Pro kernel[0]: DSMOS has arrived
Aug 9 16:16:45 Ahmeds-MacBook-Pro kernel[0]: ACPI_SMC_PlatformPlugin::pushCPU_CSTData - _CST evaluation failed
Aug 9 16:16:45 Ahmeds-MacBook-Pro kernel[0]: ACPI_SMC_PlatformPlugin::registerLPCDriver - WARNING - LPC device initialization failed: C-state power management not initialized

#1962
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
You get them because 1. you didn't install a patched AppleIntelCPUPowerManagement.kext or 2. You did, and it's just ML's fault, in this case there is nothing to worry about.

#1963
burrows1980

burrows1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Irby

@burrows, no need to remove numbers, they are generic in the smbios file... even the serial number since the bios is from tonymac. I think it's like bcc9 described here http://www.insanelym...5 you get waiting for root device because of the timing, probably when you use smbios this gets fixed... i don't know.

Cheers for that, will give it a try.. Took the numbers out because of posting it here, force of habit i guess...If I can't get the installer to work past the Mac OSX installation error, will install it the way you told me to install Lion, open the OSinstall.mpkg in a working OSX install, would be nice to install something from USB for once though!

Edit: finally installed from USB, downloaded ML from app store to working lion install this time, followed the long method, had to install trackpad and keyboard kext from another cant be named package to the USB install, including my smbios.plist and all worked out.. Woohoo!!

#1964
pcwiz13

pcwiz13

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

No problem, by the way "normal" dsdt does no longer "exist" i changed the DSDTs to be universal across screens and made the boot.plist screen specific. AppleHDA and some other fixes are also DSDT dependent. Also i forgot to mention this, i included a USB3 DSDT fix in the L502x dsdt, this gives us native USB3 support but it's painfully slow.

I still need some volunteers to test a boot cd/stick...


I'll help out with testing the boot cd/stick if your still looking for people.

#1965
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
I'll post a link tomorrow, i need to recompile it.

In the mean time, i decided to disassemble the laptop today to clean it and change the thermal paste. The original one was smeared all over the CPU and GPU, after i applied the new one the Fan is working less and temp is about 3ºC cooler, which is great considering the oven i'm living in this summer.

I noticed a sim card tray, did anyone try to see if it's somehow compatible with os x? On windows does it work only for broadband internet or you can even call using it?

Edited by DoiX, 09 August 2012 - 09:06 PM.


#1966
burrows1980

burrows1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Irby
Has anybody else had this problem with ML first boot:

http://i132.photobuc...80/dbbdd641.jpg

done a few searches and can't seem to find anything, it just hangs when it gets to this. FakeSMC is installed tried it a few times now by kextwizard.

Fresh install of ML, ran chameleon r1820, installed FakeSMC and NullCpuPowerManagement kexts through a working Lion install and thats it.....

Any help appreciated..

#1967
Ahmed_shiko

Ahmed_shiko

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:EGYPT

Has anybody else had this problem with ML first boot:

http://i132.photobuc...80/dbbdd641.jpg

done a few searches and can't seem to find anything, it just hangs when it gets to this. FakeSMC is installed tried it a few times now by kextwizard.

Fresh install of ML, ran chameleon r1820, installed FakeSMC and NullCpuPowerManagement kexts through a working Lion install and thats it.....

Any help appreciated..


install fakeSMC and NullCpuPowerManagement in package ML V1.4 Doix

working :D

#1968
burrows1980

burrows1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Irby

install fakeSMC and NullCpuPowerManagement in package ML V1.4 Doix

working :D


Beat me to it :wink2: I used them from another installer and alls well now, apart from it hangs at [IOBluetooth.................] bit now, more researching tomorrow!!

Edit: can boot into ML if i use these flags -v -x -f, getting somewhere now!

#1969
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
@burrows, amh10 had the same problem. Either delete the nvidia kexts or install my DSDT/ The Extra folder from lion (assuming it's has the DSDT i made)

-x safe boot so graphic kexts don't get loaded.

#1970
burrows1980

burrows1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Irby

@burrows, amh10 had the same problem. Either delete the nvidia kexts or install my DSDT/ The Extra folder from lion (assuming it's has the DSDT i made)

-x safe boot so graphic kexts don't get loaded.


Thanks again DoiX, boots into ML fine now!! Appreciated..

#1971
amh10

amh10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
@DoiX, @burrows - Yes it boots fine now. Sorry for being so dippy.

@DoiX, which are the best audio kexts for your DSDT? The volume control is on the status bar - but there is no sound - some of the AppleHDA.kexts for your 1.4 pack halt the kext loading screens

@burrows - are you having the same problems?

#1972
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
@amh10, old AppleHDA kext are buggy if you don't use kernel cache (the kext loading part).

I included in the V1.4 package a [ML] AppleHDA with patched IOAudioFamily. They are the exact version that come in 10.8, for them to work you need the new DSDT (also included).

After installing and rebooting be sure to check that the proper channel is selected in the system preferences sound pane.

Notice: [ML]AppleHDA breaks after waking from sleep. I said i'll release a script to fix that.. and i'll do it as soon as i have some spare time, kinda busy this weekend.

#1973
Ahmed_shiko

Ahmed_shiko

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:EGYPT
how fix fix graphics artifact freezes ML 10.8

any idea

Posted Image

#1974
amh10

amh10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts

@amh10, old AppleHDA kext are buggy if you don't use kernel cache (the kext loading part).

I included in the V1.4 package a [ML] AppleHDA with patched IOAudioFamily. They are the exact version that come in 10.8, for them to work you need the new DSDT (also included).

After installing and rebooting be sure to check that the proper channel is selected in the system preferences sound pane.

Notice: [ML]AppleHDA breaks after waking from sleep. I said i'll release a script to fix that.. and i'll do it as soon as i have some spare time, kinda busy this weekend.


Thanks for this. Any thoughts as to why I don't have an external speaker option?

Posted Image

#1975
deadsmile

deadsmile

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
@Doix
Comming from MackyReddy's L702X thread, I remember you once said you would be looking into a dsdt modification to stop loading the Nvidia GPU, arre there any news on that side ?
It's the only thing stopping me from reinstalling OSX :(

#1976
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
Hi deadsmile, i'm really clustered this month, work, apartment hunting and several other things. The DSDT modding is a painful process, i promised i would mod it and i will, i just can't tell when. I also have the tonymac replacement project on roll.

@Amh10, on my system, that appears when i have headphones plugged in, if you don't have any plugged in then plug'em in! See if that does anything.

@Ahmed, nothing that i know of... not for ML at least.

#1977
amh10

amh10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
Thanks. I tried that but it didn't matter whether the headphones were plugged in. When they were plugged in the sound did work though.

So I decided to go with the Voodoo kext:

Posted Image

All the sliders aren't greyed out, but still no sound (either speakers or headphones). How bizzare!

#1978
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
It could be because of IOAudioFamily.kext http://dl.getdropbox.com/u/16173714/IOAudioFamily.kext.zip try the stock one.

#1979
amh10

amh10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
Thanks. It was the VoodooHDA 2.7.3 that seems to be working now.

Still can help out with your beta testing of the boot install if you like.

#1980
mackyreddy

mackyreddy

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
  • Gender:Not Telling
  • Interests:Building Operating Systems from scratch

@Doix
Comming from MackyReddy's L702X thread, I remember you once said you would be looking into a dsdt modification to stop loading the Nvidia GPU, arre there any news on that side ?
It's the only thing stopping me from reinstalling OSX :(


Hey Deadsmile, i actually tried the new package and installed xps 15 DSDT and bam its working. No more blank screen. I will look into the DSDT, if possible i will try to port it to our XPS 17.

@ Doix

what changes did u make in this version 1.4, now it seems to be fully compatible with L702x and i have checked system profile nvidia not spotted. Now we can have a smaller Universal package without any redundant files for L702x. :thumbsup_anim:

Update:

1. Cpu temps are lower and at idle touching 42c

2. Fn brightness keys are working as well but at reducing the brightness completely screen goes blank but again on increasing the brightness screen comes back.

3. All USB ports are working no compatibility issues.

4. Audio, Webcam, Sleep & Wake are also working, i feel everything else is also working, no compatibility issues what so ever with this DSDT.





3 user(s) are reading this topic

1 members, 2 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy