Jump to content

[Guide] Dell XPS 15 L502X (Early 2011) Snow Leopard Install (possibly L702x too)

* * * * * 5 votes

  • Please log in to reply
2976 replies to this topic

#1941
Ahmed_shiko

Ahmed_shiko

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 116 posts
  • Gender:Male
  • Location:EGYPT

@viki, i know.. it's included in the package. The problem was with PackageMaker, after compiling it switched kexts and scripts.


Please Install the battery kext in a different session (separately) to be sure it got installed.

Lx02X - Mountain Lion V1.4
- DOWNLOAD HERE -

Changelog-V1.4:

- rebuilt using Packages by Stephane Sudre because Apple's PackageMaker is bad, and they should feel bad about it!



link no Working

#1942
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
Fixed... it had a % in it... safari is bugged on my side.

#1943
amh10

amh10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
I still can't load the first boot of ML. It freezes at this point and won't progress despite various boot flags:

https://www.dropbox....20808-00070.jpg

Any thoughts?

#1944
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
Delete NVDAGF100 kexts or install my DSDT so the Nvidia Card doesn't get loaded anymore.

#1945
burrows1980

burrows1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Irby
Im still getting the waiting for root......... message:

https://www.dropbox....%2021.32.24.jpg

Used flags: -v UseKernelCache=No Installed the keyboard and trackpad kexts from DoiX's v1.4

Funnily enough I could never get SL or Lion to install from USB stick, iirc the same message used to come up, so wether I'm missing something in the setup process when making the bootable stick?

Checked in disk utility and the USB is still MBR, followed PCWIZ13 guide to the letter, tried the original 750gb HD.... Read through the previous few pages and pretty much tried all the suggestions to no avail.

Forgot how much fun this can be :wink2:

Used the kexts from the resource pack DoiX posted a few pages back, Used Enoch and chameleon on different sticks...

#1946
amh10

amh10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
@Doix - deleting the nvda*.kext did not work. Which DSDT can I install to the Extra folder and where could I get it?

#1947
burrows1980

burrows1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Irby
Ok, so added my extra folder from working lion install to USB stick, and it's worked, got to install screen!!

Happy days, so onto the next challenge..

#1948
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
@burrows, The extra folder fixed the waiting for root device error? Weird. Glad it worked tho'

@amh10, the DSDT that comes with all the installer packages i made. Anyway, if you deleted the nvidia kexts then i assume you need the dual link patch + proper smbios, or the Boot.plist you used in Lion the one with the efi string included.

So far it seems that ML is reaaaally picky with graphics.

#1949
amh10

amh10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts

@burrows, The extra folder fixed the waiting for root device error? Weird. Glad it worked tho'

@amh10, the DSDT that comes with all the installer packages i made. Anyway, if you deleted the nvidia kexts then i assume you need the dual link patch + proper smbios, or the Boot.plist you used in Lion the one with the efi string included.

So far it seems that ML is reaaaally picky with graphics.


@DoiX: Thanks for this. I'm not sure how to extract the DSDT from the v1.4 package. I no longer have any working copies of lion except in a VMWare machine which won't work for this.

I can still boot into windows, but I have to use the USB stick each time.

AMH.

#1950
burrows1980

burrows1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Irby

@burrows, The extra folder fixed the waiting for root device error? Weird. Glad it worked tho'


Yeah, added the extra folder and it boots really quickly into the install screen, I'm thinking it had something to do with the org.Chameleon.Boot.plist? , although trackpad not working, keyboard does.. Read somewhere about plugging keyboard or mouse in, think I had to do that with lion...

Silly question but how do you repair permissions on the bootable USB stick when in Lion? is it just a case of dragging the usb icon over the kext utility icon?

#1951
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
@AMH10 here you go https://dl.dropbox.c...4/Laur/DSDT.aml

@burrows, i don't use kext utility so i don't know for sure. You can use Disk Utility Applications/Utilities/ to repair permissions. Just select the USB stick and click repair.

#1952
one9092002

one9092002

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 237 posts
  • Gender:Male
  • Location:san bernardino,ca
  • Interests:hackintosh,networking,programming graphic design,video editing
@ Doix I installed mountain lion successful and got everything working! but i am experiencing freezing and scrambled screen i don't know how to fix the lock up and freezing and messed up picture. how can i fix this issue i also experienced this lion 10.7.2

#1953
amh10

amh10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
@DoiX. The DSDT that you gave me I dropped this into the root. The loading froze again:
https://www.dropbox....5/DoiX_DSDT.jpg

Interestingly, the Caps Lock light still turns on and off which implies this is purely a graphics loading problem.

Should I try a differrent IntelHD3000 kext? Does anyome have a boot plist I can use?

AMH.

#1954
burrows1980

burrows1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Irby
@DoiX, Ive worked out that I don't need to put any flags in when trying to install ML from USB all I need is smbios.plist in the extra folder. delete this and I get the still waiting for root device....

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMfamily</key>
<string>MacBook Pro</string>
<key>SMproductname</key>
<string>MacBookPro8,2</string>
<key>SMboardproduct</key>
<string>Mac-(removed numbers)</string>
<key>SMserial</key>
<string>(removed serial)</string>
<key>SMbiosversion</key>
<string>######.tonymacx86.com</string>
</dict>
</plist>

I don't know if this makes any sense of why this would make it boot to the installer?

Im getting stuck when the installer screen appears:

https://www.dropbox....%2009.38.24.jpg

Am I right in thinking its just the files on the USB stick causing this error? possible corrupt file?

#1955
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
@burrows, no need to remove numbers, they are generic in the smbios file... even the serial number since the bios is from tonymac. I think it's like bcc9 described here http://www.insanelym...5 you get waiting for root device because of the timing, probably when you use smbios this gets fixed... i don't know.

@amh10, do you have the full HD screen?

#1956
amh10

amh10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
@DoiX - this is what I find most puzzling. The screen is the standard 1366x768 - so the "normal" DSDT should work. For some reason the system isn't displaying the screen. It is the first boot after install so no user account etc has been set up.

#1957
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
Well, the next question would be... did you remember to copy a smbios in the extra folder? http://dl.getdropbox.com/u/16173714/smbios.plist

#1958
amh10

amh10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
That would be a no then! Thanks for this. I'll try it when I get home.

#1959
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
No problem, by the way "normal" dsdt does no longer "exist" i changed the DSDTs to be universal across screens and made the boot.plist screen specific. AppleHDA and some other fixes are also DSDT dependent. Also i forgot to mention this, i included a USB3 DSDT fix in the L502x dsdt, this gives us native USB3 support but it's painfully slow.

I still need some volunteers to test a boot cd/stick...

Edited by DoiX, 09 August 2012 - 02:18 PM.


#1960
Ahmed_shiko

Ahmed_shiko

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 116 posts
  • Gender:Male
  • Location:EGYPT
@Doix

install success ML 10.8

in boot -v problems


Aug 9 16:16:45 Ahmeds-MacBook-Pro kernel[0]: DSMOS has arrived
Aug 9 16:16:45 Ahmeds-MacBook-Pro kernel[0]: ACPI_SMC_PlatformPlugin::pushCPU_CSTData - _CST evaluation failed
Aug 9 16:16:45 Ahmeds-MacBook-Pro kernel[0]: ACPI_SMC_PlatformPlugin::registerLPCDriver - WARNING - LPC device initialization failed: C-state power management not initialized





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy