Jump to content

[Guide] Dell XPS 15 L502X (Early 2011) Snow Leopard Install (possibly L702x too)

* * * * * 5 votes

  • Please log in to reply
2978 replies to this topic

#1521
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.

I might have messed up my install...

I upgraded to 10.7.4 from 10.7.2 then ran v7 installer. Selected the i7 processor and full HD options, replaced the DSDT and patched the 10.7.4 AIPM kext.

It boots really slowly, then eventually gets to the blue screen and stalls there. If i wait till the display sleeps and then wake it, the desktop will appear, the trackpad works, but clicking doesn't and either does the keyboard. The resolution is correct.

If I boot with -v it seems like there are a few lines about an error with thermal and a few stalls with a line something like "super iodevice manager unsupported ship"

Help Please!


You rebooted the system before it was done building the kextcache.... boot with -s and write /sbin/mount -uw / <press enter> kextcache -system-prelinked-kernel <press enter>

It should generate only one or two errors :) it's normal. If you manage to access the desktop use kextwizard's maintenance mode and check /System/Library/Extensions...

#1522
markmac81

markmac81

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

You rebooted the system before it was done building the kextcache.... boot with -s and write /sbin/mount -uw / <press enter> kextcache -system-prelinked-kernel <press enter>

It should generate only one or two errors :) it's normal. If you manage to access the desktop use kextwizard's maintenance mode and check /System/Library/Extensions...


I tried it.... It didn't fix the problem. I used an old 10.6 installation on another disk to boot into it (10.6) via usb and then ran the v7 package again.

Now i get a KP. See photos.. One booted with -v one without..

Thanks again!

Mark.

Attached Files



#1523
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
@Mark, install NULLCPUPowerManagement.kext for some reason AppleIntelCPUPowerManagement.kext is failing... usually this happens because the permissions of the kext are wrong. Or you could boot again in the 10.6 installation and repair the permissions of Lion (kext wizard / disk utility - whatever works on 10.6)

#1524
darren cox

darren cox

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 107 posts

Can anyone upload the graphics kexts that are changed in the v7 pack for the 'graphics fix' as I've tried a couple and they are worse than when i had the stock 10.7.4 ones (or whatever was installed by default)

with the 768mb one i still only get 512mb reported (with 8gb ram) and with the 512mb version i get corruption that wasn't there before.

Thanks


Anyone??? Really need those Kexts please!

#1525
adeebm

adeebm

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

@Mark, install NULLCPUPowerManagement.kext for some reason AppleIntelCPUPowerManagement.kext is failing... usually this happens because the permissions of the kext are wrong. Or you could boot again in the 10.6 installation and repair the permissions of Lion (kext wizard / disk utility - whatever works on 10.6)


I had the same problem after upgrading. It wasn't the kext failing. I have a 2720M, and SSDT seemed to be the issue. Using the 2720M SSDT that was posted earlier solved the problem for me.

On another note, I've lost sound and battery detection after the upgrade...

--Adeeb

#1526
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.

I had the same problem after upgrading. It wasn't the kext failing. I have a 2720M, and SSDT seemed to be the issue. Using the 2720M SSDT that was posted earlier solved the problem for me.

On another note, I've lost sound and battery detection after the upgrade...

--Adeeb


After each update you must reinstall IOAudioFamily.kext AppleHDA.kext AppleACPIPlatform.kext. About the SSDT, 2720M = dual core? I didn't even know the l502x comes in that "flavour".

@darren, why don't you just install them directly from the installer package.. ? http://dl.dropbox.co...HD3000Patch.zip

#1527
adeebm

adeebm

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
i7 2720QM, not m sorry. I thought your v7 installer took care of the audio kexts? I ran the installer with audio selected after the upgrade, with no luck.

Also, the smartbatterymanager kext from here: http://www.osx86.net..._need_dsdt.html works perfectly on my system. You need to install the included acpiplatform as well. It detects more battery properties than the voodoo battery kext I was using before. You may want to include that in your installer.

Oh, and upgrading from chimera 1.9.1 to 1.9.2 should solve some p-state issues. It did allow me to boot with GeneratePStates=Yes and no kp. Still have to sue DropSSDT=Yes.

--Adeeb

#1528
adeebm

adeebm

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Ok, manually reinstalling the audio kexts worked. I think you install script isn't replacing the stock kexts for some reason.

One more issue: My trackpad and keyboard work fine, but they don't show up as devices. So the bluetooth keyboard assistant pops up every time I reboot. Not a major issue, but does this happen to you as well?

--Adeeb

#1529
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
God damn script :D, it's a generic script... it *should* work no matter what... i guess in V8 i'll make one specially for Audio, maybe that requires something different. I assume same thing applies if you manually install battery kexts,

#!/bin/sh

# update caches

rm -R ${targetVolume}/System/Library/Caches/
kextcache -update-volume ${targetVolume} -f

exit 0


Smart battery looks interesting, i have another battery kext that works on our laptop provided by CupidHWM but for some reason it stucks the fan when the battery is charging (by stuck i mean it keeps it active - loud). Anyway i'll check SBattery out now.

About the keyboard thing, i vaguely remember getting spammed when i first installed Lion.... i think i disabled that panel from System Preferences.

Chimera 1.9.1 or 1.9.2 makes no difference for me, if i recall well 1.9.2 addressed the bdmesg output more than the actual functionality.

The battery kext is lagging, takes 2 minutes to detect any change... but i like the output info in System Profiler :D

Edited by DoiX, 24 May 2012 - 05:04 PM.


#1530
adeebm

adeebm

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Thanks, I found the bluetooth option in prefs.

I checked the audio kext versions in /S/L/E after running the installer and selecting the l502 audio check. They were still stock kexts after install. I remember after selecting, the installer showed "upgrade" instead of "install". I wonder if the installer decided not to replace the kexts for some reason because the stock kexts have a higher version number?

--Adeeb

#1531
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.

Thanks, I found the bluetooth option in prefs.

I checked the audio kext versions in /S/L/E after running the installer and selecting the l502 audio check. They were still stock kexts after install. I remember after selecting, the installer showed "upgrade" instead of "install". I wonder if the installer decided not to replace the kexts for some reason because the stock kexts have a higher version number?

--Adeeb


It's plausible, i'll see what i can do about it in the next rev.

#1532
amh10

amh10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
Just upgraded from 4Gb to 8Gb - not sure what to expect in terms of performance.

#1533
birdibird

birdibird

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
@DoiX, if you are updating your installer, please include usb3 pxhcd kext.
I'm creating an easy install from scratch 10.7.4 method (still testing) and the pxhcd kext is needed.
I also discovered the same problem as adeebm with the ps2 kexts from your package.
If I just use the kexts from #####, our touchpad is found. If I install your v7 package I get the message to connect a mouse or bluetooth mouse


edit:
also you need to address this problem:
when starting your v7 installer, and ticking the chosen options to install, then when you change the target drive in the next screen: ALL chosen options are RESET TO DEFAULT!!!!
multi_beast solves this problem by automatically going back to chosing the options after you changed the target disk
I think many problems people have with your package are based on this bug (feature?)

#1534
birdibird

birdibird

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
please use small letters :)

You'll need to buy an wifi card or usb stick with a chipset which is supported by osx out of the box or for which a kext / driver is available.
Mine for example is a Medion RTL8188CU/8192CU nano usb stick which works fine in OSX 10.7.4 with the official driver/kext from the Realtek site.
I bought it for just € 4,-

#1535
darren cox

darren cox

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 107 posts

After each update you must reinstall IOAudioFamily.kext AppleHDA.kext AppleACPIPlatform.kext. About the SSDT, 2720M = dual core? I didn't even know the l502x comes in that "flavour".

@darren, why don't you just install them directly from the installer package.. ? http://dl.dropbox.co...HD3000Patch.zip


I don't want the patched Files just the originals - patched ones give glitches I never had before unless something else in your installer could cause them?

#1536
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
@darren

About the Graphics Artifacts Patch:
- it may or may not fix your gfx glitches. According to some devs, increasing or decreasing the memory used by the Intel GPU remove graphic artifacts. This means you must test each kext, low RAM and high RAM, to see what does it for you.


Manually install the 64mb version from the archive.

@birdibird

also you need to address this problem:


when starting your v7 installer, and ticking the chosen options to install, then when you change the target drive in the next screen: ALL chosen options are RESET TO DEFAULT!!!!


multi_beast solves this problem by automatically going back to chosing the options after you changed the target disk


I think many problems people have with your package are based on this bug (feature?


That happens because it's a feature and ##### didn't fix it because its part of the OS X package installer functions. Also, why choose another disk? The installer selects the disk the current installation boots from...

The only problem people have with the installer is the fact that kexts are not replaced, and i don't know why because i couldn't manage to replicate it. I restored the stock 10.7.4 audio kexts (IOAudio & AppleHDA) then used V7 installer to install audio... it worked. I don't know why its working for some people and why it isn't working for others.

One fix coming right up!

#1537
birdibird

birdibird

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts

That happens because it's a feature and ##### didn't fix it because its part of the OS X package installer functions. Also, why choose another disk? The installer selects the disk the current installation boots from...

The reason to choose another disk is for example if you install on another partition and you boot back into your old osx to run the installer package to the new partition

#1538
Alessandro17

Alessandro17

    Chief of Security

  • Administrators
  • 8,333 posts
  • Gender:Male
  • Location:Sector 001, Italy

@DoiX, if you are updating your installer, please include usb3 pxhcd kext. I'm creating an easy install from scratch 10.7.4 method (still testing) and the pxhcd kext is needed. I also discovered the same problem as adeebm with the ps2 kexts from your package. If I just use the kexts from uni_beast, our touchpad is found. If I install your v7 package I get the message to connect a mouse or bluetooth mouse edit: also you need to address this problem: when starting your v7 installer, and ticking the chosen options to install, then when you change the target drive in the next screen: ALL chosen options are RESET TO DEFAULT!!!! multi_beast solves this problem by automatically going back to chosing the options after you changed the target disk I think many problems people have with your package are based on this bug (feature?)


This is a final warning, assuming you haven't read my post yet: http://www.insanelym...0
Discussion of tonymac beasts is not allowed in this forum. There are forum filters for a reason. The next who tries to overcome them gets at least one month suspension.

#1539
birdibird

birdibird

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
Ow, I'm sorry. I didn't know it was considered commercial and haven't seen your post yet indeed.
I won't refer to it anymore.
sorry again :)

#1540
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
Ah, sorry... i had no idea :) i rarely visit other threads.. and when i do i use search so i've missed global warnings.

I didn't even know tonymac is commercial... sorry once again.

I have one question though, if someone would make a similar package and make it freely available with no "donation" demands or similar would it be acceptable by IM Forums?





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy