Jump to content

Supported Graphics cards with Full QE/QI


  • Please log in to reply
255 replies to this topic

#1
kludgedean

kludgedean

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:Wales, UK
Thought I'd start a thread for people trialling Lion, with already working hardware, in an effort to find out what series/models of cards are compatible, have full resolution, full QE/QI acceleration, and what's needed to get them to work as such.

resources list
NVEnabler64; http://www.kexts.com/view/984-nvenabler.kext.html

RoaringApps; http://roaringapps.com/apps:table Compatibility List of OSX 10.7 Lion Apps


ATI/AMD Cards
HD 4000 Series
ATI HD 4870 512 ram; With Graphics Enabler works grate on Lion 11A459e. The strange thing is that it thinks that I have an additional VGA display connected on my second port. This did not happen in previews builds.

HD5000 Series
HD5670 ASUS works without any injector
HD5770 1GB sapphire works without any injector
HD5770 fully working without injector (in DP1... not tested since)
HD5850 1GB Sapphire Vapor-X works without any injector

HD6000 Series
XFX 6870 100% working including the mini Display Port use GraphicsEnabler=Yes


nVidia Cards
7000 Series
Albatron 7600 GT fully working in 32 bit , with any above method

8000 series
8400GS 512MB works 100% with NVEnabler64
8600GT 512MB works 100% with NVEnabler
8600GS 256MB works 100% with NVEnabler64
8800GT 512MB works 100% GraphicsEnabler=Yes
8800GT 1024MB (Gainward bliss GS) works OK with GraphicsEnabler=Yes, better with NVEnabler64
8800GTX Club3D (thanks to npwski (http://www.applelife.ru/topic/29175 post 244) ___ deleting GeForce7xxx & NVDAResmanG7xxx from S/L/E fully working, with GE=Y)

9000 Series
9400GT 512MB XFX works without any injector
9400GT 512MB EVGA works fine with NVEnabler64
9600GT 100% with enabler :)
9800GT 1 Gig works 100% with NVEnabler64 OR DSDT INjection.
9800GT 512 MB (Club3D Geforce ) working 100% with Efi string ... currently using with Chameleon Graphics enabler and loaded .rom.

GTS/GTX Series
GT240 512MB nVidia works 100% with NVEnabler64 or without Enabler with DSDT
GTS 250 1GB XFX Nvidia DualDVI fully working with NVEnabler.
GTX 260 Core 216 896MB (EVGA 896-P3-1255-AR GeForce) works 100% with either Graphics Enabler (pciroot set) or DSDT

GT275 896MB nVidia works 100% with NVEnabler64

335M GT works 100% (no HDMI sound though) with GraphicsEnabler=yes

Nvidia Fermi architecture cards
GTX 460 device ID 0E22 works with GraphicsEnabler=y (HDMI not tested)


NOT WORKING

GeForce GTX 560 Ti not working, no QE/CI :/

Please feel free to add your hardware here, and I shall add them to the list :)

#2
dgtlchlk

dgtlchlk

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
EVGA 896-P3-1255-AR GeForce GTX 260 Core 216 896MB works 100% with either Graphics Enabler (pciroot set) or DSDT.

#3
Dellmantt

Dellmantt

    STILL LEARNING

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,122 posts
  • Gender:Male
  • Location:AUSTRALIA
8400GS 512MB works 100% with NVEnabler64

#4
STLVNUB

STLVNUB

    InsanelyMac Legend

  • Coders
  • 1,143 posts
  • Gender:Male
9800GT 1 Gig works 100% with NVEnabler64 OR DSDT INjection.

#5
iLeopod

iLeopod

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts
  • Gender:Male
  • Location:Germany
  • Interests:ileopod.wordpress.com

9800GT 1 Gig works 100%


100% ?
also hdmi?
my works to but still got that HDCP/HDMI blackscreen issue

#6
STLVNUB

STLVNUB

    InsanelyMac Legend

  • Coders
  • 1,143 posts
  • Gender:Male

100% ?
also hdmi?
my works to but still got that HDCP/HDMI blackscreen issue

My card doesn't have hdmi only 2xdvi, so can't answer that question

#7
iLeopod

iLeopod

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts
  • Gender:Male
  • Location:Germany
  • Interests:ileopod.wordpress.com
Yes but when u connect via dvi <-> hdmi cable.

#8
STLVNUB

STLVNUB

    InsanelyMac Legend

  • Coders
  • 1,143 posts
  • Gender:Male

Yes but when u connect via dvi <-> hdmi cable.

Monitor is DVI/VGA

#9
A

A

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
I am thinking of picking up this one: XFX Radeon HD 5770.

Is anybody running one of theses ? If its basically the same as the Sapphire 5770 - does this mean I wont have to do anything and Lion will detect it automatically with full QE/CI ?

#10
fredouille

fredouille

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,193 posts
  • Location:GROVILLE du Nord
club 3D 8800GTX not fully working ( CI: OK, QE: no !)
tried : NATIT, NVEnabler, NVInject, DSDT + GFX FIX, Strings as suggested by BlackOSX, Graphic Enabler, add ID in info.plist of NVDANV50HAL.kext (=019110de)

ATI Radeon 5770 fully working without injector (in DP1... not tested since)

Albatron 7600 GT fully working in 32 bit , with any above method

EDIT : thanks to npwski (http://www.applelife.ru/topic/29175 post 244) ___ deleting GeForce7xxx & NVDAResmanG7xxx from S/L/E

8800 GTX fully working, with GE=Y


Credits to npwski !
:(

#11
fattire357

fattire357

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

I am thinking of picking up this one: XFX Radeon HD 5770.

Is anybody running one of theses ? If its basically the same as the Sapphire 5770 - does this mean I wont have to do anything and Lion will detect it automatically with full QE/CI ?


To my understanding, there are a few types of HD 5770 cards:

1. Purchased from Apple for $$$. Works out of the box in 10.6 and 10.7 without any OS modifications.

2. XFX model purchased from Best Buy / Newegg for less. If the card is stock and the OS is stock, it will crash upon loading the GUI. However, you can flash the Apple XFX HD 5770 onto the graphics card to make it permanently work on all vanilla installations :(. There are other ways to make it work that I couldn't replicate but I like the permanent solution (flash the bios of the graphics card within Windows 7): http://forums.macrum...d.php?t=1136504. graphics acceleration works.

3. I don't have a sapphire so I dont' know why these work stock but my xfx didn't. i think it has something to do with efi

disclaimer: don't flash an xfx 5770 rom onto a sapphire 5770 card

#12
kludgedean

kludgedean

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:Wales, UK
Thanks for the contribution, fattire357.
I'm looking at a new graphics card, and obviously Mac OS X really isn't going to utilize these cards to their extent. Although a 5770 sounds a great buy, it's probably not going to cut it for windows gaming (which is probably what most people will still be doing with their cards (dual booting etc))/

I'm looking at a 6870, but no idea if it'd work AT ALL, so i'm hesitant to buy one in case it renders OSX practically useless! - Another good reason to hold onto my 8800GT

#13
Javimdq

Javimdq

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
XFX Nvidia GTS 250 1GB DualDVI fully working with NVEnabler.

#14
A

A

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts

I am thinking of picking up this one: XFX Radeon HD 5770.


works just fine here on dp2 update 2

(system profiler reports HD5000 but everything seems right performance wise)

#15
Goron

Goron

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 339 posts
  • Gender:Male
  • Location:somewhere out there ...
Club3D Geforce 9800GT 512 MB working 100% with Efi string ... currently using with Chameleon Graphics enabler and loaded .rom.

#16
mathq

mathq

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 210 posts
  • Gender:Male
  • Location:Quebec
nVidia GeForce 335M GT works 100% (no HDMI sound though) with GraphicsEnabler=yes

#17
stirkac

stirkac

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
9600gt 100% with enabler :unsure:

#18
douggle

douggle

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
any luck with Geforce 9500 GT 1gb?

#19
np_wski

np_wski

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Location:Moscow, Russia
douggle
I think 9500 will work with GraphicsEnabler. Anyway you can make efi-string with this method "Howto createEFI string the simple way"
I have 9500 GT 512Mb, it work fine in OS X Lion.

#20
Wayang-NT

Wayang-NT

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 143 posts
  • Gender:Male
9600GT 512MB work fine with GraphicsEnabler.... D-Sub, DVI and HDMI works ....





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy