Jump to content

"Installer" hangs when installing apps


  • Please log in to reply
22 replies to this topic

#1
exscape

exscape

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
I'm getting somewhere with my OSX86 setup now, QE/CI and this problem are the remaining ones that I know of.

Anyhow, I can't install applications that use OSX' "Installer" application.
The screen loads, and tells me for instance "Welcome to the ....... Installer". That's it, though, the window freezes right there, with the OSX loading cursor spinning and spinning. The only thing to do is to Force Quit.
It has happened with at least two completely different applications, so I doubt that it's their fault.

I'm running JaS 10.4.7, on this system:
MB: DFI nF4 Ultra-D (nForce4)
CPU: Athlon 64 "Venice" 3000+ (2700MHz)
RAM: 4x 512MB
GFX: Sapphire Radeon X800XL (running Callisto, but no luck with QE/CI yet)
2 SATA HDDs (NTFS only, thus read only), 2 PATA HDDs (one of them has the OSX partition).

The system is completely stable and has proven so for more than half a year, by the way.

Any clues?
Thanks in advance.

#2
Pitr-

Pitr-

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Location:Sweden
Also try starting System Profiler... it should crash. Or atleast it does so for me with this latest JaS compilation. And from what I can tell som far, it only happens on AMD-based machines (tried it on my X2 at home which has these symptoms, and on my SSE2 P4 at work which does not show these symptoms).

Automatic updates also hangs for me, so it seems everything is related to the Installer in one way or another. I've looked in the console-log and it's showing up alot of invalid connections and some other warnings.... I'm going back to Myzar 10.4.6 upgraded to 10.4.7 until this is fixed and someone has compiled an 10.4.7 kernel.

#3
exscape

exscape

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
System profiler works just fine for me, however "About this mac" doesn't. I don't feel like trying right now, since it seems to log out/freeze the system when clicked.

Anyhow, I've had some success (complete, actually) when using Pacifist to install packages. That way, I don't need to use the OS X installer, but can still install all the software I want to.
Needless to say, I still appreciate responses/solutions to my problem!

#4
Pitr-

Pitr-

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Location:Sweden

System profiler works just fine for me, however "About this mac" doesn't. I don't feel like trying right now, since it seems to log out/freeze the system when clicked.

Well, that's exactly what happens to me too when I click "About this mac". So, there's gotta be some systemfiles that doesn't get patched for amd or something else that failes to install correctly on our systems.

#5
riffic

riffic

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Well, that's exactly what happens to me too when I click "About this mac". So, there's gotta be some systemfiles that doesn't get patched for amd or something else that failes to install correctly on our systems.

yeah, happens here too with JaS 10.4.7

=/ still pretty fun though

#6
JaS

JaS

    InsanelyMac Legend

  • Gurus
  • 1,487 posts
  • Gender:Male
Try getting semjaza's 10.4.7 amd patcher and run it,I might have missed a cpuid patch for amd.Anyway running the semjaza patcher should fix all the issues.

#7
riffic

riffic

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Try getting semjaza's 10.4.7 amd patcher and run it,I might have missed a cpuid patch for amd.Anyway running the semjaza patcher should fix all the issues.

ok that fixed problems with About this Mac, thanks.

I'm still unable to use "installer" though, it hangs up whenever I try to use it. does anyone have a solution?

#8
wcarson

wcarson

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Had similar issues with JaS 10.4.6 and 10.4.7....solved with Maxxuss' AMD_Enabler patch.....

Attached File  AMD_Enabler.zip   7.55KB   1904 downloads

#9
suryoyo

suryoyo

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Can somebody out there please help me with this installer problem as well. I can't install any .pkg files because the OsX installer just hangs when it's called to use. I'm running Jas 10.4.7 Install, not the upgrade but the straight 10.4.7 install from demonoid. I did actually install the semjaza decrypts but that hasn't done anything for me. I still can't see "about this mac" and the installer still doesn't work.

#10
Hellmonkeys

Hellmonkeys

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

Had similar issues with JaS 10.4.6 and 10.4.7....solved with Maxxuss' AMD_Enabler patch.....

Where can I get the AMD_Enabler patch? Could you PM me a location? I can't seem to find it on googe :pirate2:. Also , AFAIK, this patch is for 10.4.5, but will it really solve the problem of the installer hang in 10.4.7?

#11
wcarson

wcarson

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Where can I get the AMD_Enabler patch? Could you PM me a location? I can't seem to find it on googe :happymac:. Also , AFAIK, this patch is for 10.4.5, but will it really solve the problem of the installer hang in 10.4.7?


Added patch to my above post (I got it off of a post on this forum somewhere...but couldn't find it). Yeah..I know about the version difference....but it worked for me in 10.4.7. Beleive me...I don't really know what the heck I'm doing....I guess I just got lucky.

#12
cmf

cmf

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 145 posts
thanks wcarson, this fixed all issues =)

#13
Kalagaraz

Kalagaraz

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
This didn't work for me. I'm new to mac though and may I've done something wrong. I downloaded that patch, saved it on desktop and just double clicked the patcher file. It said process completed and I restarted.

However, the installer still hangs.

#14
Zaffobaldo

Zaffobaldo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Can somebody out there please help me with this installer problem as well. I can't install any .pkg files because the OsX installer just hangs when it's called to use. I'm running Jas 10.4.7 Install, not the upgrade but the straight 10.4.7 install from demonoid. I did actually install the semjaza decrypts but that hasn't done anything for me. I still can't see "about this mac" and the installer still doesn't work.


Hi there, maybe it is not an elegant "fix" but I got the installer work by using it with Rosetta. :blink:

#15
cmf

cmf

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 145 posts

This didn't work for me. I'm new to mac though and may I've done something wrong. I downloaded that patch, saved it on desktop and just double clicked the patcher file. It said process completed and I restarted.

However, the installer still hangs.

open up the terminal (finder->applications->utilities)
> cd Desktop
> sudo ./patcher cpuid_patches.txt

#16
Biku

Biku

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
http://img63.imagesh...2/screendc7.png

shouldn't there be sse3 feature??

#17
diegowsky

diegowsky

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Costa Rica
what i did for getting SSE3 on Jas 10.4.7, was getting the AMD_SSE3.pkg from the 10.4.6 DVD... on /System/Installation/Packages (in the 10.4.6 DVD)

#18
Zman101

Zman101

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

what i did for getting SSE3 on Jas 10.4.7, was getting the AMD_SSE3.pkg from the 10.4.6 DVD... on /System/Installation/Packages (in the 10.4.6 DVD)


That worked for me to. Good Idea.

#19
7210211

7210211

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
for you guys having problems try here: http://forum.insanel...showtopic=29379

;)

#20
Big Kahuna

Big Kahuna

    InsanelyMac Sage

  • Donators
  • 303 posts
  • Gender:Male
hit up the bay for the 10.4.7AMD.pkg, or something similar

i updated using it from 10.4.6 with no hangups





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy