Jump to content

Lenovo S12 ion (NVIDIA) 10.6.6 GUDE


  • Please log in to reply
54 replies to this topic

#41
HNO3

HNO3

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
Hello,
I think you should do a new thread for the 10.6.8 system
because your 10.6.6 guide works quite good ... maybe it is safe to keep it as it is now and open a new thread for system 10.6.8
in my humble opinion :-)

you did (and you continue to do) a really great work !
i love my lenovo s12 with triple boot (Win7 , OSX 10.6.6 and ubuntu 11.04)

#42
carlitosx

carlitosx

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Hello,
I think you should do a new thread for the 10.6.8 system
because your 10.6.6 guide works quite good ... maybe it is safe to keep it as it is now and open a new thread for system 10.6.8
in my humble opinion :-)

you did (and you continue to do) a really great work !
i love my lenovo s12 with triple boot (Win7 , OSX 10.6.6 and ubuntu 11.04)


Hi dear friend!
I am starting to flirt with a package builder... so maybe for 10.6.8 i can make a definitive LENOVO S12 ENABLER!!
Of course lots of testings are necessary... and i am starting to get a little tired of reinstalling the system on every fail i made.
One more thing (Steve we will miss you)
Sleep is not working anymore with 10.6.8 at the moment... need to rewrite the sleep and lidsleep parts on the dsdt.

For everyone... ill explain how to update to 10.6.8 on this same post very soon.
And once ill finish to write the Enabler ill post a new thread with the definitive 10.6.8 guide from scratch.
And that will be the end of my contrib fof this netbook.

Regards
Carlitosx

#43
revomac

revomac

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
I have a question. Is anyone else getting constant kernel panics about 45 minutes into use. No matter what I do, safari, music, etc. the machine always seems to {censored} out about 45 minutes in. Any fix for this?

#44
HNO3

HNO3

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
hello revomac,
no such bug for me.
you should have a look in your log files (open console app) maybe you will find some clues :-)
see you

#45
revomac

revomac

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male

hello revomac,
no such bug for me.
you should have a look in your log files (open console app) maybe you will find some clues :-)
see you


Alright, I booted with debug=0x100 so that I would get a verbose message instead of the 4 language text kernel panic. Said something about the ACPIBatterManager.kext. @carlitosx's doens't work for me. I had to snag one from kexts.com. This one is now working, and I think it drastically improved my battery. Went from 3:25 to like 4:10. If I can go through my history and find it, I will upload it for others to test. :)

Alright here is the updated or new ACPIBatteryManager.kext. This fixed my issue, and might also for others. I have also included VoodooBattery.kext. Now this isn't necessary, it just is useful if you are using a 9-cell battery from Amazon.com for this netbook instead of the 3 or 6 cells. :)
Have fun :P

Attached Files



#46
revomac

revomac

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male

ONLY FOLLOW THIS GUIDE IF YOU REALLY KNOW WHAT YOU ARE DOING ANY MISTAKE COULD BREAK YOUR OS.

Ok, lets go for it.

First step.
DOWNLOAD THIS
http://www.megaupload.com/?d=RZZD5HLV


This file says that it is always "unavailable." Can you upload this zip to mediafire.com or just attach it here?

Thank you very much carlitosx

#47
carlitosx

carlitosx

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

This file says that it is always "unavailable." Can you upload this zip to mediafire.com or just attach it here?

Thank you very much carlitosx


Here´s the link
http://www.mediafire...a5r4ki4rw4nsfxf
You are welcome

#48
revomac

revomac

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
Thank you very much again. I will test this out and give my results shortly ;)

#49
simselain

simselain

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Thanks Carlitosx for this how to.

I successfully followed your guide to install osx 10.6.0 then upgraded to 10.6.6.
All drivers seems ok but i'm experiencing kernel panic especially when big io's are running like carbon copy or time machine save. I had it also during 10.6.8 upgrade.

I tried to load the AppleIntelIntegratedFramebuffer.kext with kextwizard and kextutility but when i reboot, the kext is never loaded as i can see with kextstat command.

This sounds surely like a newbie question but how make it loaded automatically when S12 reboot ?


Thanks in advance.

#50
carlitosx

carlitosx

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Thanks Carlitosx for this how to.

I successfully followed your guide to install osx 10.6.0 then upgraded to 10.6.6.
All drivers seems ok but i'm experiencing kernel panic especially when big io's are running like carbon copy or time machine save. I had it also during 10.6.8 upgrade.

I tried to load the AppleIntelIntegratedFramebuffer.kext with kextwizard and kextutility but when i reboot, the kext is never loaded as i can see with kextstat command.

This sounds surely like a newbie question but how make it loaded automatically when S12 reboot ?


Thanks in advance.


The solution for fixing this problem is the AppleIntelIntegratedFramebuffer.kext
This kext is a must have if you want to have some stability in your hackintosh netbook.
Try to install it again, with Kext Helper, repairing permissions etc.
Keep trying, you are in the right way!

PS: 10.6.6 is the most stable release for our lenovo´s s12 netbook. 10.6.8 works but with the new nvidia drivers, some glitches and less performance seems to be a not very convenient update.

#51
julietecho

julietecho

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Carlitosx,

First, thanks for your hard work testing and documenting.

I gave my S12 OSX new life after many months using Ubuntu. What I noticed already in the past try outs is that occasional kernel panics are caused by battery not recognized properly. It get logs flooding with those "FIX ME...." errors, and eventually it gives KP. I used the other ACPIBatteryManager.kext linked above to make it work properly. If not using correctr kext you may find mambojambo in System Profilers power section's battery information. I updated easily to 10.6.7 (didn't bother to break things with 10.6.8). And system is really stable. Only thing I'm missing is sleep, didn't manage to get it work with any of your DSDTs even in 10.6.6.

#52
revomac

revomac

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
Hey guys easy fix for you guys with sleep problems... It lies in the Bluetooth. Easy solution though... open up the back of the netbook, take out the wifi card and place tape over pin 20. Then place the card back in boot up with the wifi switch OFF, and voila, wifi and sleep! AND, if you want bluetooth, just boot up with the switch on, and before you go to sleep, remember to flick the switch off... For me, I never use bluetooth, so 99% of the time, I have the switch off.... Works perfectly, with the provided kexts above in the guide : )

Happy hackint0shing : )

#53
tonto2k

tonto2k

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hi Everyone,

I have a Samsung NC10 running Leopard 10.5.8 and I really like it but the screens not big enough. I was looking for a 12 inch netbook for osx86 and found that the Lenovo S12 is fully compatible with Snow Leopard 10.6.0

So I bought a S12 Ion from eBay... :)

Anyway following the guide I restored a snow leopard 10.6.0 image to a 8gb usb stick and installed Chameleon RC5 to a 2gb usb stick inc extras folder from guide.

When I booted I selected boot from 2gb in boot menu, then got an error "mach_kernel not found". I placed the mach_kernel from the guide onto the 2gb usb stick and tried again. This time the chameleon boot loader goes upto:

**************************************************************************************************************************************************************************

Table /DSDT.aml read and stored at: a78000
New DSDT Loaded in memory
No ACPI version 1 found. Ignoring
RSDP version 2 found @f74f0. Length=36
RSDT @37ecdc47, Length 64
TABLE FACP, FADT found @37ed7c14, Length 116
DSDT: Old @37ecf0cc, 49fe7422, New @a78000, 49fe7422
TABLE SLIC, TABLE MCFG, TABLE HPET, TABLE APIC, TABLE BOOT, TABLE SSDT,
RSDT:Original checksum 104, New checksum 52 at a83000
XSDT "0;37ed7c88, Length 244
DSDT: Old @37ecf0cc, 37ecf0cc, New @a78000,a78000
TABLE FACP@a86000, Table SLIC@37ed7d7c, TABLE MCFG@37ed7ef2, TABLE HPET@37ed7f2e, TABLE APIC@37ed7f66,TABLE BOOT@37ed7fd8, TABLE SSDT@37ecdce3, RSDP: Original Checksum 198, checksum 52





RSDP: Original extended checksum 86New extended checksum 228
Press a key to continue... (DEBUG_DSDT)

**************************************************************************************************************************************************************************



When I press a key I get kernel panic I think? the code says:

**************************************************************************************************************************************************************************

panic(cpu 0 caller 0x55c075): "Unable to find driver for this platform: \"ACPI\".\n"@\SourceCache/xnu/xnu-1504.9.2/iokit/Kernel/IOPlatformExpert.cpp:1389
Debugger called: <panic>
Backtrace (CPU 0), Frame : Return addree (4 potential args on stack)
0x185f3da8 : 0x21b50c (0x5d4438 0x5d4438 0x185f3ddc 0x223974 0x0)
0x185f3df8 : 0x55c075 0x5ddd5c 0x20e8510 0x185f3e28 0x2161540)
0x185f3e18 : 0x53cb6e (0x2162c80 0x214dd80 0x1 0x4ffaa6)
0x185f3e78 : 0x53ada3 (0x214dd80 0x2162c80 0x2161580 0x50396e)
0x185f3f28 : 0x53b334 (0x214dd80 0x2154bc0 0x8 0xffffffff)
0x185f3f78 : 0x53cfe3 (ox214dd80 0x0 0x185f3fac 0x1)
0x185f3fc8 : 0x2a06cc (ox2156770 0x0 0x0 0x0)

BSD process name corresponding to current thread: Unknown

Mas OS version:
Not yet set

Kernel version:
Darwin Kernel Version 10.6.0 Wed (****cannot read rest of line as is obscured by restart computer error)

system uptime in nanoseconds: 28303 (****cannot read rest of line as is obscured by restart computer error)

************************************************************************************************************************************************************

Then the background goes white and "you need to restart your computer, Hold down the power button until it turn off, then press the Power button again"




And thats as far as I can get :(

Can anyone please help me out?

#54
1aquila1

1aquila1

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
@tonto2k, I think you and I have the same problem. This lenovo has always worked pretty wel on 10.6.6 but it just stopped working from one on another day giving probably the same error message as yours. I didn't update it or whatever. And now when I try to reinstall exactly the same as I always did, what always worked it gives me this error message. Very weird

edit: when I install chameleon bootloader with myhack installer it goes further, no succes so far but you might try some things out

#55
Cookeydile

Cookeydile

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Here´s the link
http://www.mediafire...a5r4ki4rw4nsfxf
You are welcome


This one is no longer available :(

Could anyone re-up it? Pretty please?





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy