Jump to content

who got Intel Pro 1000 PL LAN card working?


  • Please log in to reply
58 replies to this topic

#41
bcas9472

bcas9472

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
I have the same exact card(dual port version) and the AppleIntel8254XEthernet.kext driver works perfectly, right out of the box (ToH DVD)

#42
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
can you guys please add your Laptop model to your signatures .. ;) ?

#43
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
working now with Chun-Nan's IOPCIFamily.kext !! (many thanks to atanasko for PMing me about this!)

Also working: swapped Atheros miniPCIe card, now 100% working as Airport !! (just browsing via WLAN!)

#44
JeroenJ

JeroenJ

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
  • Gender:Male
  • Location:Belgium

working now with Chun-Nan's IOPCIFamily.kext !! (many thanks to atanasko for PMing me about this!)

Also working: swapped Atheros miniPCIe card, now 100% working as Airport !! (just browsing via WLAN!)


Hi bugs,

I've got the same lan card as yours (and same bridge) (dev/ven id's are the same :P)

annyways, until now I was able to go online with this card, didn't got any kernel panics, but I always had to "fix" the connection when I booted up

So it said it didn't get an IP from the DHCP, than I had to set it to disabled, apply that, set it to something else and it just jumped back to disabled and than again I needed to set it to DHCP, and than it was working, though it said there wasn't a cable connected, but I got an IP and was able to go online!

With this kext, will your calbe show up as connected or not ? I don't have too much time right now to test it out, nor the time to fix any problems, so I was just wondering if it worked alright for you :angel:

Thanks :)

PS: don't mind my sig, I have a docking station, and the 1000 pro pl is on the dock, not on my lapto itself

#45
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
yes, 100% working in 10.5.2. Since there are different revisions of Chun-Nan's kexts I attached the working IOPCIFamily.kext + the working IONetworkingFamily.kext.

Attached Files



#46
kk249

kk249

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Hong Kong
Hi all, I have the Leo4all successfully installed on my P5K-E/wifi system, sound, video, wireless lan (realtek8187), onboard lan (marvell yukon 8056) all working fine but I could not get my PCI Intel Pro1000MT work, the network shows "cable unplugged" but it shows the ip address and the router address, any help? Thanks in advance!

#47
costarico

costarico

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Location:Thessaloniki Greece

yes, 100% working in 10.5.2. Since there are different revisions of Chun-Nan's kexts I attached the working IOPCIFamily.kext + the working IONetworkingFamily.kext.



Dear bugsbanny
i am a newbie in mac OS X86 world

Forgive me my english are not so good....

I wonder if you could help me!
I have installed iATKOS 10.5.1 r3---> update with kallyway combo update 10.5.2
I have installed your working_Extensions:IONetworkingFamily.kext and IOPCIFamily.kext . I don't have panic any more, i am surfing internet all ok but my network diagnostics say that this computer does not seem to be connected to a dsl(ethernet failed).
Also my fire wire put it self in full security! I don't know why?

what about Texas Instruments PCIxx12 Cardbus Controller can you help me please!
What about your system, which kernel are you using , kext etc.

my hardware

I have a TOSHIBA Satellite P100-138

Disk , 93 GB
Physical Memory 2047 MB Total
--------------------------------------------------------------------------
Chipset Vendor Intel Corporation
Chipset Model 955XM/945GM/PM/GMS/940GML Express Processor to DRAM Controller
South Bridge 82801GBM (ICH7-M) LPC Interface Controller
SMBus Intel Corporation 82801G (ICH7 Family) SMBus Controller @1100h

CPU Intel Core Duo
Cpu Socket Socket 479 [U2E1]
Processor Upgrade ZIF Socket
BIOS Version TOSQCI - 6040000
PhoenixBIOS 4.20 Release 6.1
Ver 1.00PARTTBL
BIOS Date 11/02/07
-----------------------------------------------------------------------
Intel® 82801GBM/GHM (ICH7-M Family) Serial ATA Storage Controller - 27C4
-----
Device ID PCI\VEN_8086DEV_27C4SUBSYS_FF311179REV_02\3B1BFB680FA
Class hdc
Manufacturer Intel
Hardware IDs PCI\VEN_8086DEV_27C4SUBSYS_FF311179REV_02
PCI\VEN_8086DEV_27C4SUBSYS_FF311179
PCI\VEN_8086DEV_27C4CC_010180
PCI\VEN_8086DEV_27C4CC_0101
Compatible IDs PCI\VEN_8086DEV_27C4REV_02
PCI\VEN_8086DEV_27C4
PCI\VEN_8086CC_010180
PCI\VEN_8086CC_0101
PCI\VEN_8086
PCI\CC_010180
PCI\CC_0101
Description Intel® 82801GBM/GHM (ICH7-M Family) Serial ATA Storage Controller - 27C4
Physical Object Name \Device\NTPNP_PCI0013
Bustype GUID {44203042-2046-4245-2043-382031302042}
Legacy bus type 0x00000005
Install State 0x00000000
Device Address 0x001f0002
MatchingDeviceId pci\ven_8086dev_27c4
DriverDesc Intel® 82801GBM/GHM (ICH7-M Family) Serial ATA Storage Controller - 27C4
------------------------------------------------------------------------
Conexant High Definition Audio
-----
Device ID HDAUDIO\FUNC_01VEN_14F1DEV_5047SUBSYS_1179FF31REV_1000\4484DAEA00001
Status 0x0180200a Started
Problem 0x00000000 (0)
Service HdAudAddService
Capabilities 0x00000000
Config Flags 0x00000000
Class MEDIA
Manufacturer Conexant
Hardware IDs HDAUDIO\FUNC_01VEN_14F1DEV_5047SUBSYS_1179FF31REV_1000
HDAUDIO\FUNC_01VEN_14F1DEV_5047SUBSYS_1179FF31
Compatible IDs HDAUDIO\FUNC_01VEN_14F1DEV_5047REV_1000
HDAUDIO\FUNC_01VEN_14F1DEV_5047
HDAUDIO\FUNC_01VEN_14F1
HDAUDIO\FUNC_01
Class GUID {4D36E96C-E325-11CE-BFC1-08002BE10318}
Location Internal High Definition Audio Bus
Bus number 0x00000000
Enumerator name HDAUDIO
Description Conexant High Definition Audio
Driver {4D36E96C-E325-11CE-BFC1-08002BE10318}005
Physical Object Name \Device0000078
UI number 0x0000ffff
Bustype GUID {41203534-2037-3144-2042-422044362041}
Legacy bus type 0x00000005
Device Type 0x0000001d
Install State 0x00000000
Security 01 00 04 90 00 00 00 00 00 00 00 00 00 00 00 00 14 00 00 00 02 00 5C 00 04 00 00 00 00 00 14 00 00 00 00 10 01 01 00 00 00 00 00 05 12 00 00 00 00 00 18 00 00 00 00 E0 01 02 00 00 00 00 00 05 20 00 00 00 20 02 00 00 00 00 14 00 00 00 00 E0 01 01 00 00 00 00 00 01 00 00 00 00 00 00 14 00 00 00 00 E0 01 01 00 00 00 00 00 05 0C 00 00 00
Security (SDS form) D:P(A;;GA;;;SY)(A;;GXGWGR;;;BA)(A;;GXGWGR;;;WD)(A;;GXGWGR;;;RC)
Device Address 0x00000001

ProviderName Conexant
DriverDateData 00 00 AC CF 0A 0C C6 01
DriverDate 12-29-2005
DriverVersion 3.11.0.0
MatchingDeviceId hdaudio\func_01ven_14f1dev_5047subsys_1179ff31
DriverDesc Conexant High Definition Audio
-------------------------------------------------------------------------
Description Device ID:Intel® 82801G (ICH7 Family) USB Universal Host Controller - 27C8
----------
Property Value
Device ID PCI\VEN_8086DEV_27C8SUBSYS_FF311179REV_02\3B1BFB680E8
Status 0x0180200a Started
Problem 0x00000000 (0)
Service usbuhci
Capabilities 0x00000000
Config Flags 0x00000000
Class USB
Manufacturer Intel
Hardware IDs PCI\VEN_8086DEV_27C8SUBSYS_FF311179REV_02
PCI\VEN_8086DEV_27C8SUBSYS_FF311179
PCI\VEN_8086DEV_27C8CC_0C0300
PCI\VEN_8086DEV_27C8CC_0C03
Compatible IDs PCI\VEN_8086DEV_27C8REV_02
PCI\VEN_8086DEV_27C8
PCI\VEN_8086CC_0C0300
PCI\VEN_8086CC_0C03
PCI\VEN_8086
PCI\CC_0C0300
PCI\CC_0C03
Class GUID {36FC9E60-C465-11CF-8056-444553540000}
Enumerator name PCI
Description Intel® 82801G (ICH7 Family) USB Universal Host Controller - 27C8
Driver {36FC9E60-C465-11CF-8056-444553540000}003
Physical Object Name \Device\NTPNP_PCI0006
Bustype GUID {44203042-2046-4245-2043-382031302042}
Legacy bus type 0x00000005
Install State 0x00000000
Device Address 0x001d0000
Controller 01
InfPath ich7usb.inf
InfSection INTEL_USB
InfSectionExt .NT
ProviderName Intel
DriverDateData 00 80 ED 42 51 AF C5 01
DriverDate 9-2-2005
DriverVersion 7.2.2.1001
MatchingDeviceId pci\ven_8086dev_27c8
DriverDesc Intel® 82801G (ICH7 Family) USB Universal Host Controller - 27C8


USB 1: Supported
USB 2: Supported


Intel® 82801G (ICH7 Family) USB Universal Host Controller - 27C8 PCI\VEN_8086DEV_27C8SUBSYS_FF311179REV_02\3B1BFB680E8
Intel® 82801G (ICH7 Family) USB Universal Host Controller - 27C9 PCI\VEN_8086DEV_27C9SUBSYS_FF311179REV_02\3B1BFB680E9
Intel® 82801G (ICH7 Family) USB Universal Host Controller - 27CA PCI\VEN_8086DEV_27CASUBSYS_FF311179REV_02\3B1BFB680EA
Intel® 82801G (ICH7 Family) USB Universal Host Controller - 27CB PCI\VEN_8086DEV_27CBSUBSYS_FF311179REV_02\3B1BFB680EB
Intel® 82801G (ICH7 Family) USB2 Enhanced Host Controller - 27CC PCI\VEN_8086DEV_27CCSUBSYS_FF311179REV_02\3B1BFB680EF

----------------------------------------------------------------------------------
SD SDA Standard Compliant
-------
Property Value
Device ID PCI\VEN_104CDEV_803CSUBSYS_FF311179REV_00\46B16D5B023F0
Status 0x0180200a Started
Problem 0x00000000 (0)
Service sdbus
Capabilities 0x00000000
Config Flags 0x00000000
Class SDHost
Manufacturer SD SDA Standard Compliant
Hardware IDs PCI\VEN_104CDEV_803CSUBSYS_FF311179REV_00
PCI\VEN_104CDEV_803CSUBSYS_FF311179
PCI\VEN_104CDEV_803CCC_080501
PCI\VEN_104CDEV_803CCC_0805
Compatible IDs PCI\VEN_104CDEV_803CREV_00
PCI\VEN_104CDEV_803C
PCI\VEN_104CCC_080501
PCI\VEN_104CCC_0805
PCI\VEN_104C
PCI\CC_080501
PCI\CC_0805
------------------------------------------------------------------------------------
Texas Instruments OHCI Compliant IEEE 1394 Host Controller
-----------
Property Value
Device ID PCI\VEN_104CDEV_803ASUBSYS_FF311179REV_00\46B16D5B021F0
Status 0x0180200a Started
Problem 0x00000000 (0)
Service ohci1394
Capabilities 0x00000000
Config Flags 0x00000000
Class 1394
Manufacturer Texas Instruments
Hardware IDs PCI\VEN_104CDEV_803ASUBSYS_FF311179REV_00
PCI\VEN_104CDEV_803ASUBSYS_FF311179
PCI\VEN_104CDEV_803ACC_0C0010
PCI\VEN_104CDEV_803ACC_0C00
Compatible IDs PCI\VEN_104CDEV_803AREV_00
PCI\VEN_104CDEV_803A
PCI\VEN_104CCC_0C0010
PCI\VEN_104CCC_0C00
PCI\VEN_104C
PCI\CC_0C0010
PCI\CC_0C00
Class GUID {6BDD1FC1-810F-11D0-BEC7-08002BE2092F}
Bus number 0x0000000a
Enumerator name PCI
Description Texas Instruments OHCI Compliant IEEE 1394 Host Controller
-------------------------------------------------------------------------------------
Texas Instruments PCIxx12 Cardbus Controller
------
Property Value
Device ID PCI\VEN_104CDEV_8039SUBSYS_FF311179REV_00\46B16D5B020F0
Status 0x0180200a Started
Problem 0x00000000 (0)
Service pcmcia
Capabilities 0x00000000
Config Flags 0x00000000
Class PCMCIA
Manufacturer Microsoft
Hardware IDs PCI\VEN_104CDEV_8039SUBSYS_FF311179REV_00
PCI\VEN_104CDEV_8039SUBSYS_FF311179
PCI\VEN_104CDEV_8039CC_060700
PCI\VEN_104CDEV_8039CC_0607
Compatible IDs PCI\VEN_104CDEV_8039REV_00
PCI\VEN_104CDEV_8039
PCI\VEN_104CCC_060700
PCI\VEN_104CCC_0607
PCI\VEN_104C
PCI\CC_060700
PCI\CC_0607
Class GUID {4D36E977-E325-11CE-BFC1-08002BE10318}
Bus number 0x0000000a
Enumerator name PCI
Friendly name Texas Instruments PCIxx12 Cardbus Controller
--------------------------------------------------------------------------------------
NETWORK
Number of Network Cards 4
Card 1 (Connected) Intel® PRO/Wireless 3945ABG Network Connection
Description Intel® PRO/Wireless 3945ABG Network Connection - Miniport
Type WIRELESS LAN
Speed 54 Mbps
MAC Address 00-13-02-3B-AC-EB
IP Address 192.168.2.2

Card 2 (Connected) 1394
Description [12] 1394
Type WIRED 1395
MAC Address 72-57-02-3D-FD-36

Card 3 (Not Connected) Intel® PRO/1000 PL Network Connection
Description Intel® PRO/1000 PL Network Connection - Miniport
Type WIRED
Speed 1000 Mbps
MAC Address 00-16-36-40-8D-60
IP Address 0.0.0.0
--------------------------------------------------------------------------------------
Intel® PRO/1000 PL Network Connection
-------
Device ID PCI\VEN_8086DEV_109ASUBSYS_FF311179REV_00\4192AC53F000E0
Status 0x0180200a Started
Problem 0x00000000 (0)
Service e1express
Class Net
Manufacturer Intel
Hardware IDs PCI\VEN_8086DEV_109ASUBSYS_FF311179REV_00
PCI\VEN_8086DEV_109ASUBSYS_FF311179
PCI\VEN_8086DEV_109ACC_020000
PCI\VEN_8086DEV_109ACC_0200
Compatible IDs PCI\VEN_8086DEV_109AREV_00
PCI\VEN_8086DEV_109A
PCI\VEN_8086CC_020000
PCI\VEN_8086CC_0200
PCI\VEN_8086
PCI\CC_020000
PCI\CC_0200
Class GUID {4D36E972-E325-11CE-BFC1-08002BE10318}
Location PCI "2", "0", "0"
Bus number 0x00000002
Enumerator name PCI
Description Intel® PRO/1000 PL Network Connection
Driver {4D36E972-E325-11CE-BFC1-08002BE10318}012
Physical Object Name \Device\NTPNP_PCI0020
---------------------------------------------------------------------------------------
Intel® PRO/Wireless 3945ABG Network Connection
-------------
Device ID PCI\VEN_8086DEV_4222SUBSYS_10418086REV_02\420975680000E1
Status 0x0180200a Started
Problem 0x00000000 (0)
Service w39n51
Class Net
Manufacturer Intel Corporation
Hardware IDs PCI\VEN_8086DEV_4222SUBSYS_10418086REV_02
PCI\VEN_8086DEV_4222SUBSYS_10418086
PCI\VEN_8086DEV_4222CC_028000
PCI\VEN_8086DEV_4222CC_0280
Compatible IDs PCI\VEN_8086DEV_4222REV_02
PCI\VEN_8086DEV_4222
PCI\VEN_8086CC_028000
PCI\VEN_8086CC_0280
PCI\VEN_8086
PCI\CC_028000
PCI\CC_0280
Class GUID {4D36E972-E325-11CE-BFC1-08002BE10318}
Location PCI "3", "0", "0"
Bus number 0x00000003
Enumerator name PCI
Description Intel® PRO/Wireless 3945ABG Network Connection
---------------------------------------------------------------------------------------
Property Value
Device ID V1394\NIC1394\956DDCC09F00
Status 0x0180600a Started
Problem 0x00000000 (0)
Service NIC1394
Capabilities 0x000000b4
Config Flags 0x00000000
Class Net
Manufacturer Microsoft
Hardware IDs V1394\NIC1394
Compatible IDs V1394\NIC1394
Class GUID {4D36E972-E325-11CE-BFC1-08002BE10318}
Enumerator name V1394
Description 1394
Friendly name 1394 #2
---------------------------------------------------------------------------------------
Description NVIDIA GeForce Go 7600
------------
Device ID PCI\VEN_10DEDEV_0398SUBSYS_FF311179REV_A1\431B7BFB900008
Status 0x0180200a Started
Problem 0x00000000 (0)
Service nv
Capabilities 0x00000000
Config Flags 0x00000000
Class Display
Manufacturer NVIDIA
Hardware IDs PCI\VEN_10DEDEV_0398SUBSYS_FF311179REV_A1
PCI\VEN_10DEDEV_0398SUBSYS_FF311179
PCI\VEN_10DEDEV_0398CC_030000
PCI\VEN_10DEDEV_0398CC_0300
Compatible IDs PCI\VEN_10DEDEV_0398REV_A1
PCI\VEN_10DEDEV_0398
PCI\VEN_10DECC_030000
PCI\VEN_10DECC_0300
PCI\VEN_10DE
PCI\CC_030000
PCI\CC_0300
Class GUID {4D36E968-E325-11CE-BFC1-08002BE10318}
Bus number 0x00000001
Enumerator name PCI
-----------------------------------------------------------------------------------------
Description SMSC HID CIR - Consumer IR
-----------
Device ID ACPI\SMCB000\51907E21B0
Status 0x0180000a Started
Problem 0x00000000 (0)
Service SMCB000
Capabilities 0x00000020
Config Flags 0x00000000
Class HIDClass
Manufacturer SMSC
Hardware IDs ACPI\SMCB000
*SMCB000
Class GUID {745A17A0-74D3-11D0-B6FE-00A0C90F57DA}
Enumerator name ACPI
------------------------------------------------------------------------------------------
Description Bluetooth ACPI from TOSHIBA
-----------
Device ID ACPI\TOS6205\2DABA3FF0
Status 0x0180000a Started
Problem 0x00000000 (0)
Service tosrfec
Capabilities 0x00000020
Config Flags 0x00000000
Class System
Manufacturer Toshiba
Hardware IDs ACPI\TOS6205
*TOS6205
Class GUID {4D36E97D-E325-11CE-BFC1-08002BE10318}
Enumerator name ACPI
Description Bluetooth ACPI from TOSHIBA
-----------------------------------------------------------------------------------------
Description Texas Instruments PCIxx12 Integrated FlashMedia Controller
Device ID PCI\VEN_104CDEV_803BSUBSYS_FF311179REV_00\46B16D5B022F0
Status 0x0180200a Started
Problem 0x00000000 (0)
Service tifm21
Capabilities 0x00000000
Config Flags 0x00000000
Class MTD
Manufacturer Texas Instruments Inc
Hardware IDs PCI\VEN_104CDEV_803BSUBSYS_FF311179REV_00
PCI\VEN_104CDEV_803BSUBSYS_FF311179
PCI\VEN_104CDEV_803BCC_018000
PCI\VEN_104CDEV_803BCC_0180
Compatible IDs PCI\VEN_104CDEV_803BREV_00
PCI\VEN_104CDEV_803B
PCI\VEN_104CCC_018000
PCI\VEN_104CCC_0180
PCI\VEN_104C
PCI\CC_018000
PCI\CC_0180
Class GUID {4D36E970-E325-11CE-BFC1-08002BE10318}
Location PCI "10", "4", "2"
Bus number 0x0000000a
Enumerator name PCI
Property Value
MatchingDeviceId pci\ven_104cdev_803bsubsys_ff311179
DriverDesc Texas Instruments PCIxx12 Integrated FlashMedia Controller
------------------------------------------------------------------------------------------

Thanks for your time!
costarico

#48
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
hi costarico,

would you please empty or enable your PM box .. ;) ?

Anyway, I just got home from late shift and am tired - I will upload all my kexts + best kernel + boot plist as working perfectly now in 10.5.2 (fast, no crashes, extremely quiet, no restart/shutdown hangs or delays) tomorrow and send you and some other people the link.

Greetz,
Bugs

#49
costarico

costarico

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Location:Thessaloniki Greece

hi costarico,

would you please empty or enable your PM box .. :police: ?

Anyway, I just got home from late shift and am tired - I will upload all my kexts + best kernel + boot plist as working perfectly now in 10.5.2 (fast, no crashes, extremely quiet, no restart/shutdown hangs or delays) tomorrow and send you and some other people the link.

Greetz,
Bugs


Thanks Bugs,
for your time, i will wait for your upload!!!

#50
JaS

JaS

    InsanelyMac Legend

  • Gurus
  • 1,487 posts
  • Gender:Male
Just got a rig today, everything working but the nic

00:19.0 Ethernet controller [0200]: Intel Corporation 82562V 10/100 Network Connection [8086:104c] (rev 02)

00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev f2)

Anyone get past the checksum 0 error ?

#51
ron_artest

ron_artest

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
hi BugsB, i have a nearly similar notebook from toshiba too.
can you please give me the link for the files you wanted to upload?
greets
ron

#52
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
hi JaS, hi ron_artest,

in my sig click onto the link "Chun-Nan's kexts".

If also you click onto "surprise" you will get ALL the kexts I use in my Leo 10.5.4 install (incl. the specific IOPCIFamily from Chun Nan which made my Intel 1000 work) ;)

Cheers & good luck,
Bugs

#53
HackBook Pro

HackBook Pro

    Web Developer & MLP:FiM Fan

  • Members
  • PipPipPipPip
  • 219 posts
  • Gender:Male
  • Location:Earth
  • Interests:Ponies
Suddenly, it just stopped working. My ethernet used to "just work," but now it stopped. Anyone got any ideas why?

dmesg outputs:
AppleIntel8254XEthernet: Ethernet address [hidden]
AirPort_Brcm43xx: Ethernet address [hidden]
AirPort: Link Down on en1
Intel8254x -- Link Down -- [hidden] -- called by interruptOccurred() -- 
--		Auto-Negotiation Advertisement Register (04d)				= 0xde1
--		Auto-Negotiation Link Partner Ability Register (05d)		 = 0x41e1
--		Auto-Negotiation Gigabit Advertisement Register (09d)		= 0xe00
--		Auto-Negotiation Gigabit Link Partner Ability Register (10d) = 0x4000
--		PHY Specific Status Register (17d)						   = 0x6d00
MAC AUTH succeeded
AirPort: Link Up on en1


#54
risnandar

risnandar

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hi BugsB,
I installed the ACPIFamily and IONetworking from chun-nan and my PCMCIA is working !
but my intel pro 1000 PL still not detected :(
is there some kext missing here ?

==========
Lenovo Thinkpad T60 2008 EB1 (Kalyway 10.5.2)
-1.67 GHz Intel Core Duo
-2 GB RAM
-ATI Mobility Radeon x1300 - Working w/ QE/CI ENABLED
-Audio > works
-Intel PRO/Wireless 3945ABG > not working
-Ethernet Intel Pro 1000 PL > not working

#55
IcemanLBZ

IcemanLBZ

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

hi costarico,

would you please empty or enable your PM box .. ;) ?

Anyway, I just got home from late shift and am tired - I will upload all my kexts + best kernel + boot plist as working perfectly now in 10.5.2 (fast, no crashes, extremely quiet, no restart/shutdown hangs or delays) tomorrow and send you and some other people the link.

Greetz,
Bugs


Hey BugsBunny,

I have this card too, with same PCI Bridge that you. and use Kalaway Leopard 10.5.2.
I replace my IOPCI and IONetworking with the Chun-Nan's Kext files that you post here (IOPCIFamily.kext + the working IONetworkingFamily.kext), rebuild Extensions.kext, reboot, and nothing.
Am i doing something wrong ?
I have a HP 6275 Notebook with Intel PRO/1000 PL, PCI Bridge 2448.

Thanks

#56
DisableR

DisableR

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

hi

My built network is an intel pro/1000 pl network and it works just fine
no modifications to kext or anything it just works


Hi, curlyboy. Tell me please what release of hackintosh do you use on Asus P5LD2 motherboard. I have the same mboard and I have problems with LAN adapter Intel Pro 1000 PL. I've tried iDeneb 10.5.4 and iPC 10.5.6, but that all not helped. They contained only Intel Pro 100 drivers

#57
oaltairao

oaltairao

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I'd also like to know how to get the wired intel pro 1000 pl working.. i've searched everywhere with NO luck!! i'm using kalyway 10.5.6 -- audio won't work either but i don't care about that, i need ethernet!!!

#58
cbreaker

cbreaker

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
Hi,

I've encountered the same problems with the Pro 1000 PL in my Thinkpad T60. It works sometimes. Most of the time, it does not.

After install, the network worked great. After a couple rebooted it stopped, and then last night it worked again. This morning it's not working. It always works in Windows and Linux so I don't believe it's the NIC itself.

I'll try the PCI Bridge stuff, but that just doesn't seem likely because it DOES work sometimes. Maybe sometimes the machine boots up with a specific IRQ setup and it either works or not? I'll try to manually assign some IRQ's to the slots and see what happens.

#59
ptolomy_was_right

ptolomy_was_right

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
Hey for anyone still on Intel PRO/Wireless 3945ABG (like me), I just got it working by going to the CamphorProject (Voodoo Wifi) site and downloading their kexts and framework:

http://projectcampho...rcurysquad.com/

There were kexts in that package for the 1000 too I think. Note though that i have Voodoo kernel installed (iATKOS 10.5.7). Still no luck with Chun-Nan's fix for my cardbusses/PCMCIA. Not on system Profiler anyway. But I got a difficult rig here, Sony VAIO NR-series... Expresscard slot, not PCMCIA, and two mem card readers, one just for SD/MMC, the other just for MStick. Expresscard is rumoured to work if you insert before boot (no hot-swapping though), someone said that of SD/MMC as well. See almost everyone else has the TI 5-in-1 cardreader, tried that fix over and over, "specific family matching fails".
Any wise words on my card slots? Cheers

EDIT: Woah! Don't mess with the Camphor project just yet... or do so at yr own risk. Yeah it got my wifi working, but then messed my whole OS so badly I had to reinstall! It's still in experimental development stages... BugsB there's no kext for the Intel PRO/Wireless 3945ABG in yr package, does anybody have this working and can they post the kext?

THANKS





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy