Jump to content

i7 Sandy Bridge Install


  • Please log in to reply
4 replies to this topic

#1
darkstargtk

darkstargtk

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hey All,

I'm attempting to install Lion alongside a working SL 10.6.7 install. (Separate HD)

I've created the correct partitions on the target drive and modified the Lion install files correctly.

I'm trying to boot with a USB XPC drive - once the Lion install partition is booted I get a KP.

Something along the lines of "Looking for 8 args only found 9" weird..

Is Lion DP2 known to work with Sandy Bridge chips?


Hardware:

ASUS P8P67 Deluxe
i7 2600K
eVGA GTX460
16GB G.Skill

#2
Kyle_C

Kyle_C

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
Check out the Sandy Bridge forum at tonymacx86.com. Lots of info there, although discussion of Lion is verboten in that forum.

But it's interesting to look at what people have been able to do with Sandy Bridge and the vanilla kernels released for 10.6.6/7 and the new Macbook Pro. Whether this works seems to be sensitive to whether you can adjust your CPU multiplier.

I expect it is probably the same situation with the Lion DP2 kernel. I've seen one report in comments on Netkas' site that just said, yeah, I was able to install DP2 on a SB system (no further details). But you may have to adjust multiplier settings if you try it. Good thing you bought the K chip! I am stuck with a laptop that does not seem to be capable of booting Lion :(

Although I should point out that I'm not entirely convinced that the instant reboot problem I'm seeing with trying to boot the Lion DP2 kernel is the same as the multiplier issue I had when trying to boot the 10.6.7 MBP kernel. They look a little different: with Lion I never see any console messages from the kernel at all. I've yet to try XPC instead of Chameleon so maybe that makes a difference.

edit: sorry, when posting I overlooked what you mentioned re getting a kernel panic. I guess you're past the point I'm stuck at already. Can you post more details on the KP?

#3
darkstargtk

darkstargtk

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hey Kyle - I've attached a picture of the KP. Any Ideas?

Attached File  IMAG0136.jpg   1.98MB   139 downloads

#4
Kyle_C

Kyle_C

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts

Hey Kyle - I've attached a picture of the KP. Any Ideas?


Hmm, I thought AppleIntelCPUPowerManagement.kext was supposed to be blacklisted by the bootloader anyway. Maybe try adding NullCPUPowerManagement the same way as with FakeSMC. If I recall correctly, you can't remove AppleIntelCPUPower Management, but I believe the Null... one is supposed to prevent this.

#5
digital_dreamer

digital_dreamer

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,100 posts
  • Gender:Male
  • Location:Missouri USA
I've run into these issues before (personally and troubleshooting others) with the AppleIntelCPUPowerManagement.kext KP, but not on SB systems.

What I found was that even when you rename that kext in S/L/E or force the NullCPUPowerManagement.kext to load in Single-User Mode, it would still KP. It wasn't until we installed the DSDT.aml file, that this issue went away. Weird, I know.

best of wishes,
MAJ





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy