Jump to content

ESI Juli@ / Envy 24 with OSX86 - Any progress?


  • Please log in to reply
971 replies to this topic

#921
duhoc

duhoc

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

i think ... it's just need some time.... leopard is coming soon so i guess ESI is will realese new driver))


Hope somebody can come up with a solution for my Revolution 7.1 (Envy24). So far my card had been collecting dust.

#922
audiodriverwriter

audiodriverwriter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts

Hope somebody can come up with a solution for my Revolution 7.1 (Envy24). So far my card had been collecting dust.


Should work fine with the Envy24HT (note the HT) driver.

#923
Breathless

Breathless

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 118 posts
Awesome job on these drivers! I hope you have received many donations for all your work. I just donated.

Any possibility of input controls for Audiophile 192? Output works great. My assumption is that if the input controls become adjustable, the hardware should be selectable in Pro Tools 9 to use as a recording device. Currently it is recognized as a "playback" device in pro tools, but I can't select it in "hardware" to record TO it.

#924
audiodriverwriter

audiodriverwriter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
I've uploaded a special Envy24 0.22 version for SL which turns on monitoring: it also sends the audio from analogue inputs 1-2 to outputs 1-2. By lack of control panel we can't change the volume though, but perhaps it's useful for some people.

The M-Audio 192 (and 2496) don't have input controls. It would be strange though if that were the reason that Pro Tools wouldn't show the card as input capable.

#925
starobrno1

starobrno1

    InsanelyMac Legend

  • Banned
  • PipPipPipPipPipPipPip
  • 930 posts
  • Gender:Male

Hi, I would be happy to help you in any beta testing! I dig into it yesterday and here is what I found:
There is a History.txt file in the DMX6Fire folder, which starts like this:

/*=============================================================================
   FILE:		 History.txt
-------------------------------------------------------------------------------
   DESCRIPTION:  PHASE 88, EWS88 MT/D, EWX 24/96 and DMX6fire Driver History (WDM)
   DATE:		 31-Aug-2007
-------------------------------------------------------------------------------
   COPYRIGHT:	(c) 2000-2007, TerraTec Electronic GmbH. All Rights Reserved.
=============================================================================*/
Even if the drivers are different they couldn't be so much if the they were compiled from the same code tree.

Something more important, a part from an early DMX6Fire driver:
[TerraTec]
%DeviceName_TTP7%=TTP7.Device,PCI\VEN_1412&DEV_1712&SUBSYS_1138153B

;%DeviceName_TTP7%=TTP7.Device,PCI\VEN_1412&DEV_1712&SUBSYS_1138153B&REV_02
;FMB TEST: allow 88MT to load this driver
;%DeviceName_TTP7%=TTP7.Device,PCI\VEN_1412&DEV_1712&SUBSYS_1115153B

3. point is that all the differences in ews.c from ALSA package doesn't seem too complex (from what I understand just some different registers for initializing different parts, but that code didn't look like some complex chip controlling thing).

BTW I could install the Phase88 driver in Windows using inf modding, and the driver starts, but the volume control (in control panel) is greyed out in the same way as it is in OS X. I will see what does ASIO say about that, maybe the channels are just remapped somewhere.

UPDATE:
Using a simple dev id modding, the EWX 24/96 driver works fine with a DMX6Fire under XP! The volume control is greyed out, but everything works as it should!


Did the new Envy24 driver work with this card for osx too now? Thinking to get one of these cards.

#926
starobrno1

starobrno1

    InsanelyMac Legend

  • Banned
  • PipPipPipPipPipPipPip
  • 930 posts
  • Gender:Male
Bumping this

#927
starobrno1

starobrno1

    InsanelyMac Legend

  • Banned
  • PipPipPipPipPipPipPip
  • 930 posts
  • Gender:Male
I got a really good deal on this card so I decided to give it a try but Im sad to say even though it looks like its working I get no sound physically out of it. Its still a good card for a PC though. Im running 10.5.1 on the computer I installed it on so I tried it only with the Envy24.0.20.0 driver.

I have the Harrison Mixbus (Ardour collab) recording software on this computer and normally Mixbus wont open if theres no soundcard present and probably cause the Envy driver wont load then. But the case is it does open up with this card installed and I can see sound is playing in System sound so it cant be so much "off" from the Terratec cards that do work with this driver.

I guess a small donation might help :unsure: just let me know and I´ll get it done.

#928
starobrno1

starobrno1

    InsanelyMac Legend

  • Banned
  • PipPipPipPipPipPipPip
  • 930 posts
  • Gender:Male
Tried this card in Snow Leo too, same result I see activity in system sound input so the driver is loaded but no sound play back. Tried to replace the IDs for the generic Envy24 with the IDs for this card in the plist but no luck, the driver still load though. When I replace the generic IDs with the IDs for another of the working Terratec cards the driver wont load at all. I think this shows it should be possible to make this card work.

#929
audiodriverwriter

audiodriverwriter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
I am going to open-source the driver due to lack of time.
Any suggestions on how to handle this, meaning: who to give the sources to or where to upload them? Perhaps someone can make a sourceforge website?

I hereby would like to thank everyone that donated and/or tested the drivers! I hope some people can continue development and fix those nasty bugs! :P

#930
audiodriverwriter

audiodriverwriter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
BUMP!

#931
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,047 posts
  • Gender:Male
  • Location:Brazil
Somebody please do something, this is way too cool to pass up.

And I don't even have a sound card that works with these drivers.

#932
audiodriverwriter

audiodriverwriter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
Source code is now available from my website!

I've also uploaded an Envy24 version 0.22 for OSX 10.5. It is untested but might give people digital out under 10.5.

#933
seltsam23

seltsam23

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
  • Gender:Male
Hi there,

since I changed my pc-case and switched the pci-slot of my soundcard the sound isn't working anymore. In the audio-setup the envy24-driver doesn't show up.

Two things I may did wrong: Booted Macos without Soundcard in pci-slot. After that I placed the soundcard in a different pci-slot than it was before.

I already reinstalled the drivers, but it didn't help.

Do you have any ideas?

EDIT: Just changed the PCI-Slot to the old one, now it's working fine again. But, what do I have to do if I want to use a different PCI-Slot?


Thank you!

#934
starobrno1

starobrno1

    InsanelyMac Legend

  • Banned
  • PipPipPipPipPipPipPip
  • 930 posts
  • Gender:Male
To me its sounds like a bios issue, that the os for some reason cant see that pci port. I mean even in win you could end up having to move a soundcard to get it to work good.

#935
dddirtman

dddirtman

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
  • Gender:Male

Curious to see if there has been any progress made on this little corner of the soundcard world - specifically the VIA Envy24HT-S (24-bit, 192 kHz; interfaces: three output I2S/AC-links, two input I2S/AC-links)? As few might know, a number of professional sound cards (as well as a couple of consumer cards) use the Envy 24 chip and I amongst others am aching to put it to good use with OSX86 and its glorious variety of musical software.

If there's been any progress or insight into a working kext, I'd love to know. ESI-Pro actually have a driver for OSX which fails to work in OSX86 of course. They have done their research as any good company and have stated their reason for not creating an OSX86 driver - being that Intel Mac's don't and never will have standard PCI slots they don't see reason to create a driver.

Keeping in mind that an OSX driver exists, it shouldn't really be all that difficult to simply modify it into x86. Then again my knowledge of programming is close to zero, so I may be wrong, but sure as heck makes me regret giving up learning programming years ago.

Anyway, if anyone has heard anything, please do respond in here :(

serch d net there is a decent envy24 driver out there (audio-evolution.com) ill admit though they seem buggy at highest bitrate settings but they do work and sound verry good
using osx 10.6.7 64b on a m-aidio 1010lt

#936
Tal Winter

Tal Winter

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
The news users quiz is very funny and it's a GREAT way to determine knowledge.
anywayz, audiodriverwriter, you rock.
The audio works fine for me (well, I only need it for sound so .. )
I will fix the other osx problems and donate :P

#937
axel99092

axel99092

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Location:Erfurt
  • Interests:Music, Computer, Sex
I just wanna say Envy24_SL64bit_0.20 is also working with Lion DP3.

#938
THX

THX

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Russia
Sleep doesn't working correctly with ESI Juli@ for me. Got kernel panic after waking up and when try to play some audio.
Any suggestions?

Attached File  Pastebot_2011_07_14_17.51.46_PM.jpg   214.1KB   17 downloads

#939
demik475

demik475

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
  • Location:Paris, France

I just wanna say Envy24_SL64bit_0.20 is also working with Lion DP3.


Confirmed with M-Audio 2496 and Envy24_SL64bit_0.22 on Lion final

#940
tuxianer

tuxianer

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 155 posts
Sound is working for me in Lion. I use Envy24HT.
But if i wake up from sleep the sound is disabled. kextload does not fix the problem.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy