Jump to content

[Guide] Mammoth Method v2.00 - HP DVx 10.6.x: Fast, Easy, Comprehensive Installation. /// NEW MAMMOTH BOOT CD for i5 & i3 \\\

* * * * * 1 votes

  • Please log in to reply
1536 replies to this topic

#1521
Peter_sm

Peter_sm

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 289 posts

found this, might be a update of what you suggest ?

 

http://www.insanelym...ite-1010-dppkg/



#1522
macq

macq

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts

@Peter

 

ok here is the link to the last installer he made: Clover_v2k_r2928_Special Edition.pkg

 

http://www.datafilehost.com/d/336d8813

 

This was the most uptodate in the series of installers he made from dp till beta.

 

just renameInstall OS X Yosemite.app  to Install OS X Yosemite Beta.app  otherwise the installer wont work, and place it in applications folder. The rest is automatic Run the special pkg and choose the first option to make the installer, choose clover install options as mentioned in my posts above(1509).

 

Once installer finishes.mount the efi partition of the install usb and add config.plist ,dsdt , kexts needed etc and boot from it to complete install

 

 

let me know how it goes!!!



#1523
Peter_sm

Peter_sm

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 289 posts

Thanks ,i will try it later! but is config.plist something to create ? and where should the dsdt and kext go in to what folder ?

Thanks , but never haver used Clover....

 

//Peter



#1524
macq

macq

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts

@Peter

make the installer fom your currently installed osx system.

 

Once the installer has finished the usb is ready to install yosemite.While making the installer choose the option for clover install on the usb as i had showed earlier.This will install the clover in ESP that is the efi patioin of the usb.

 

Now you need some modification to boot this usb on your system to install yosemite.

Download and install efi mounter 2.1,you,ll get it at usual places.Run it to mount the efi partion of your recently made usb, in that partition there would be a "clover" folder in the EFI directory with sub folders in that.

 

Place your patched dsdt in Clover/ACPI/Patched

Place voodoops2controller.kext from rehabman in Clover/Kext/Others or you can make a folder named 10.10 there( as the same loaction as Others) and put that in it rather than in others

Place the config.plist in .the EFI/Clover folder.   You can try the config.plist by yehia amer to get it going and then modify  it later to your system.You can do so by installing clover configurator once you reach desktop. See this post by yehia

http://www.insanelym...74#entry1975123

 

Make sure you have boot in uefi mode selected in bios.

Boot from the usb ,you will get at clover gui, choose the installer usb (will be like boot usb external efi ) to boot from it and complete install.At the  clover gui you can press the space bar and opt boot with kext injection to load all kexts that you have placed in kexts folder.

 

Install ,reboot from the usb to enter into yosemite on the hdd , complete account setting etc, reach to desktop, now install the clover to the hard drove with the same options to boot without the usb.

 

 

Config.plist in clover is roughly = orgchameleonboot.plist+ smbios.plist in chameleon bootloader



#1525
Peter_sm

Peter_sm

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 289 posts

 

 

 

let me know how it goes!!!

I manage to boot a USB, but is rebooting after a wile , it might be a GPU issue?

 

//Peter



#1526
macq

macq

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts

@peter

 

Install the latest clover 2953 on to the usb after the install usb has been made.Sometimes that helps.

try to use the default config.plist that clover generate and then at clover gui press 'O" to open options and in the config options enter

 

-v kext-dev-mode=1 slide=0 darkwake=10

 

in binaries patching select lapic fix

 

and try again.

 

Is your dsdt patched and correctly placed,what is  shown at verbose screen?

 

 

Edit :look for files in yehia's post and choose the ones that work for dv8 or corresponding  ones that have worked for you.

 

Look @ this thread

http://www.insanelym...dated-10162014/.

 

for booting once you have made the install usb or make a fresh usb install with the script given in that thread and try.

 

Will be out of town for a week, so no net access, hope you are able to get it going.

 

If all fails you can try with chameleon .



#1527
Peter_sm

Peter_sm

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 289 posts
@macq

I'm in the middle now with installation of Yosemite :-)

#1528
Peter_sm

Peter_sm

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 289 posts

Installing went well. Needs some help or input for Sound

iCloud and App Store working (after fixed en0 for ethernet) Trim(SSD) fixed by clover :-)

 

iMessages/FaceTime not working,but this is not critical, or is it a easy fix ?

Brightness not working

Power Management Not working

Sound Not working

 

Will go trough my system and see if there are more things to fix

 

EDIT

 

Trying to instal Clover to HDD, but still Cham is active, renamed the boot file, then I get a boor error, so it's looks like Clover can't be used on our DV laptop? using same clover settings during install as in earlier post

 

Moved boot file from USB to HD ,now Clover works and EFI partition on my HDD is OK.

 

//Peter



#1529
JL6569

JL6569

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

How do i get brightness control working?



#1530
yehia Amer

yehia Amer

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 250 posts
  • Gender:Male
  • Location:egypt

Hi everyone, hope that everything goes well with your hackbooks :)

For anyone having issues with Sound: use this Kexts, i am using it and it works Great , if any bugs found just Report to update it (i am very lazy to do so :D )

 

 

Installing went well. Needs some help or input for Sound

iCloud and App Store working (after fixed en0 for ethernet) Trim(SSD) fixed by clover :-)

 

iMessages/FaceTime not working,but this is not critical, or is it a easy fix ?

Brightness not working

Power Management Not working

Sound Not working

 

Will go trough my system and see if there are more things to fix

 

EDIT

 

Trying to instal Clover to HDD, but still Cham is active, renamed the boot file, then I get a boor error, so it's looks like Clover can't be used on our DV laptop? using same clover settings during install as in earlier post

 

Moved boot file from USB to HD ,now Clover works and EFI partition on my HDD is OK.

 

//Peter

Check this link, and use the latest Clover Configuration
it's not a very easy fix and need some effort !


if you like the post, like it !



#1531
Peter_sm

Peter_sm

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 289 posts
Thanks, will look into this for iMessages,do you know how to fix power management for the CPU? On Cham all was ok , but clover is not working

#1532
yehia Amer

yehia Amer

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 250 posts
  • Gender:Male
  • Location:egypt

Thanks, will look into this for iMessages,do you know how to fix power management for the CPU? On Cham all was ok , but clover is not working

yeah that's very sad :( , we Need to find a way !

the key people to a solution is "slice" and "piker-Alpha " those are the two guys who can help !

  1. i Tried to ask "piker-Alpha" for adding  "Clarksfield (i7-720QM & i7-740QM)" Support here to his ssdtPRGen.sh Script
  2. i Tried to ask Slice for adding support in clover directly, you can find the conversation here but nothing yet
  3. i Created a topic for the same purpose: [Help] Core i7-720QM Power Management & Speedstep

so for anyone interested try to ask them too, to make them feel that there is a lot of people who need it !

 

 

@Peter_sm, do you know which version of cham where Speed Step works !
what i only know now that sometimes when my mac go to sleep and wake, speed step work  :surprised:



#1533
Peter_sm

Peter_sm

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 289 posts

Version 2456 of Cham works with Speed Step

 

//Peter


But how can we make 10.10 boot with Cham ?



#1534
Peter_sm

Peter_sm

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 289 posts
It looks like I did get speed stepto work! Did the trick with Fn. F4 ...... I see it go between 7x to 15x, but 15 is strange , I have 13x max before with Cham... Will continue play withe some settings...... But I need also help to modify my boot menu , I have a own thread about that here
http://www.insanelym...ot-loader-meny/

#1535
blazinsmokey

blazinsmokey

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
I used AppleHDAdisabler and then newest Voodoohda. Sound finally works!

The slider doesn't work right,  but it's a nice temp fix if anyone else is having the same problem. 

You'll need to change the values for VoodooHDAEnableVolumeChangeFix to true in Voodoo's plist.

 

Below is the link that helped me.

http://www.insanelym...ommon-problems/


@Peter_sm, do you know which version of cham where Speed Step works !

what i only know now that sometimes when my mac go to sleep and wake, speed step work  :surprised:

 

 

It looks like I did get speed stepto work! Did the trick with Fn. F4 ...... I see it go between 7x to 15x, but 15 is strange , I have 13x max before with Cham... Will continue play withe some settings...... But I need also help to modify my boot menu , I have a own thread about that here
http://www.insanelym...ot-loader-meny/

 

yehia Amer, I was using a pre-edited DSDT file from this thread, assuming it was yours. If you didn't figure it out yet I narrowed it down to your DSDT file. I took it and compared to my unpatched DSDT file and found that the methods dealing with the CPU were different. My speed step/turbo boost worked with unpatched DSDT and the Fn + F4 trick but no webcam and extra usb port didn't work so I replaced the methods and now everything works.

 

Peter_sm I may be a bit concerned if I saw 15x on more than 1 core.

 

Specs on my processor, i7-720QM

Frequency 1600 MHz Turbo frequency 2800 MHz (1 core), 2400 MHz (2 cores), 1733 MHz (3 or 4 cores) 

Low power frequency 933 MHz

Bus speed 2.5 GT/s

DMI Clock multiplier 12

 

My P-States listed by DPCI manager are now 7,9,11,12,13. CPU is always running 4 cores up to or at 1.73Ghz so I'd assume we will never see 2.8Ghz on a single core on our machines in OSX. Not sure why multiplier is 12 but my HWMonitor shows 13 @1.73Ghz for all 4. I have spent plenty of time and everything seems stable.

 

Update:With MacBookPro 8,2 and Clover SSDT I get 6 states now, 7,8,9,11,12,13.

 

Now everything essential to me works.

I did not test HDMI/HDMI audio or VGA port so I do not know if they work.

Adjusting backlight and battery meter do not work but I do not care. Would be nice though  :lol:

 

Here are my DSDT and SSDT files if you'd like to compare or use. Attached File  DSDT.zip   22.45KB   7 downloads Attached File  SSDT.zip   3.72KB   2 downloads

 

Audio is fixed by using Mirone's patched AppleHDA.kext. Attached File  AppleHDA-267.0-IDT92HD75B3X5.zip   1.43MB   7 downloads

  • Set in Clover configurator, Device -> Audio -> Inject -> 3
  • You could edit your DSDT audio layout but instead I just install his HDAEnabler. Attached File  HDAEnabler3.kext.zip   24.29KB   4 downloads

The 2 audio kexts are installed in SLE. Other kexts used are FakeSMC, RealtekRTL81xx, and VoodooPS2Controller(touchpad and keyboard fully functioning), these 3 kexts I inject with clover. Attached File  Extra Kext.zip   350.26KB   0 downloads

 

Until the next update screws us all over, this is pretty much it.



#1536
yehia Amer

yehia Amer

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 250 posts
  • Gender:Male
  • Location:egypt

Hello blazinsmokey,

i don't know what DSDT Methods do you mean Scope (_PR) ? , i can't find the SSDT file did you attach it ?
 

 

also Could you check this : https://github.com/P...en.sh/tree/Beta

 

download the tool and then put this file Attached File  User Defined.cfg.zip   622bytes   1 downloads in "/Users/user/Library/ssdtPRGen/Data/"

then run in terminal:

./ssdtPRGen.sh -p i7-720QM -c 0 -d 3

and report back your Results

 

Thanks :)



#1537
blazinsmokey

blazinsmokey

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Added my SSDT files to original post

 

Restarted with DSDT still loading but without any of my SSDT files. Generated SSDT.aml with ssdtPRGen and placed into ACPI/patched. Then restarted.

 

My understanding is that Piker’s ssdtPRGen tool is not compatible with our processors. Regardless I tried for the sake of it.

 

When using your cmd line I get a warning and a error. It still creates a SSDT though. Terminal text output ->Attached File  ssdtPRGen.zip   1.93KB   0 downloads

 

Warning: 'cpu-type' may be set improperly (0x0701 instead of 0x0601)

 

Error: board-id [Mac-F22589C8] not supported by Sandy Bridge – check SMBIOS data / use the -c option

 

Update: error went away when I changed smbios to MacBookPro8,2. 

 

Using DPCI Manager to check P-states.

 

My DSDT and ssdtPRGen generated SSDT.aml(1 file) gives me P states of 7,8,9,11,12. 

 

My DSDT and Clover configurator generated SSDT.aml (5 files, 0-4) gives me P states of 7,9,11,12,13.

 

With MacBookPro 8,2 and Clover SSDT I get 6 states now, 7,8,9,11,12,13.

 

What P states and numbers are you getting? You can compare our DSDT files with a online tool like diffchecker and you'll see what I did and compare the changes. I remember I had to add External (\_PR_.CPU0._PPC) to the top of the definition block, the rest was with Scope(_PR) and other things CPU0 I can't remember. I did not edit any SSDT files only generate them with FN+F4.







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy