Jump to content

[Guide] Mammoth Method v2.00 - HP DVx 10.6.x: Fast, Easy, Comprehensive Installation. /// NEW MAMMOTH BOOT CD for i5 & i3 \\\

* * * * * 1 votes

  • Please log in to reply
1533 replies to this topic

#1401
yehia Amer

yehia Amer

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 249 posts
  • Gender:Male
  • Location:egypt

Could anyone help me with a USB problem?

I succesfully made a bootable USB with Mountain Lion on it. I found that I could only boot from the one USB 2.0 port on my DV6 (the other three are USB 3.0). The problem is that when I get to the installer, my USB mouse/keyboard doesn't work and I'm thinking maybe its because its plugged into USB 3.0. Is there a kext or something I need to get this working?

Thanks for any help! My hardware is in my signature.


your hardware is completely different than our's, but you can use a hub in the same USB 2 port until you Make suitable DSDT
Very Good hardware Specs btw

Good Luck

#1402
aabmass

aabmass

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

your hardware is completely different than our's, but you can use a hub in the same USB 2 port until you Make suitable DSDT
Very Good hardware Specs btw

Good Luck

Thanks for the help! And yes, the hardware should be pretty compatible with a higher end Macbook pro ;)

I found a USB hub and the mouse and keyboard worked! The installer couldn't detect my disks though :( Maybe it is a DSDT problem or a BIOS problem? Maybe I need more boot flags?

I extracted my DSDT from linux and tried to use the auto patcher, but iasl recompiled it with a few errors in both Arch Linux and Ubuntu. I don't know that much about DSDTs, maybe someone can patch mine?

Thanks for the response, I am making progress!

#1403
yehia Amer

yehia Amer

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 249 posts
  • Gender:Male
  • Location:egypt

Thanks for the help! And yes, the hardware should be pretty compatible with a higher end Macbook pro ;)

I found a USB hub and the mouse and keyboard worked! The installer couldn't detect my disks though :( Maybe it is a DSDT problem or a BIOS problem? Maybe I need more boot flags?

I extracted my DSDT from linux and tried to use the auto patcher, but iasl recompiled it with a few errors in both Arch Linux and Ubuntu. I don't know that much about DSDTs, maybe someone can patch mine?

Thanks for the response, I am making progress!


sorry i don't have much experince in DSDT, but you can search for help & post your "extracted non edited DSDT from linux" in here http://www.insanelym...forum/228-dsdt/
or fix it yourself using DSDT Editor & Patcher

Good Luck

#1404
aabmass

aabmass

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

sorry i don't have much experince in DSDT, but you can search for help & post your "extracted non edited DSDT from linux" in here http://www.insanelym...forum/228-dsdt/
or fix it yourself using DSDT Editor & Patcher

Good Luck


Thanks again! I posted where you said, hopefully I get a response!!

#1405
scristopher

scristopher

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
anyone have a DSDT for a dv7-6b55dx? I cant seem to find one anywhere
/me scours google some more...

#1406
tical2k

tical2k

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
  • Gender:Male
Ok new problem. I got an old i7-840qm on ebay. This is an upgrade from the i5-450m. I got everything working now, but my DSDT. Which was fine for the i5 now does not work for the i7. I get stuck at "Waiting for root device". I now have to boot with Peter_sm's dsdt he posted but with "GraphicsEnabler=Yes". Anyone got any idea?

Thanks!

#1407
vaitu

vaitu

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Does anyone successfully installed Mountain Lion 10.8 on HP DV8 or on another i7 HP Laptop?

If yes. What was the procedure used.

Thanks.

#1408
tical2k

tical2k

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
  • Gender:Male

Does anyone successfully installed Mountain Lion 10.8 on HP DV8 or on another i7 HP Laptop?

If yes. What was the procedure used.

Thanks.


I've installed it by basically using this method. All you need is cpus=1, FakeSMC.kext, NullPowerManagement.kext, and either a kext for the tarackpad/kb or a usb keyboard/mouse. I installed using a i5-450m, but have since upgraded to a i7-840qm. It's caused nothing but headaches for me and my DSDT, though. Probably for the best, though, I don't have speedstep working.

#1409
dgrx

dgrx

    InsanelyMac Protégé

  • Donators
  • 75 posts
  • Gender:Not Telling
Hi,
Thanks to all involved with this thread. Got my DV7 updated to ML 10.8.2 pretty painlessly, with the info found here. Not running at 100%, but very functional. Had to use the uploaded NV kext's and Applehda from Lion. Kind of a frankeinbuild :whistle: , but it works for now.
Thanks again :wink2:

#1410
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male
I have this HP DV7 7202.
The Graphics card Intel HD 4000 works fine, including graphics acceleration.
But I can not run the HDMI port, can you help?

#1411
tomdek

tomdek

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
All,

final holiday arrived; two weeks to try and get upgraded to 10.7.x.
I have succesfully installed ML using this method and was wondering if I can not just update through the app store and then replace the kernel? Chameleon and extra folder is still in place.Or am I better off starting from scratch?

Many thanks!!!!

#1412
prebenjensen

prebenjensen

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hi everybody!
This is my first post on InsanelyMac forums.

First of all, thanks to Mammoth and everyone else involved in creating this guide, and other very helpful resources. Without you, I would have given up on my Hac a long time ago.

Second, my problem now:

I have a HP Pavilion g6-2031so that I am trying to install Mac OS X 10.6.3 on, using Mammoth Method. So far, I have created a MIID and a XIID, on a partition each on a usb flash-stick.
The chameleon boot-loader opens up nicely, even though it will only open if I insert the usb-stick in the usb 2.0. slot, not on the usb 3.0. slots.

However, as soon as I start the Mac OS X Installer, I cannot get the mouse track-pad to respond. The keyboard works, but not the mouse. And thus, I get stuck a few steps into the installation, since I can't access the partitioning-tool :/...

Has anyone experienced similar problems? And what is the solution?


By using -x flag and a usb-mouse, I've managed to get further :).

The specifications for my laptop is as follows:


CPU: Intel® Core™ i5-2450M CPU @ 2.50 GHZ, 2501 MHZ, 2 cores
Chipset: Intel Panther Point HM76, Intel Sandy Bridge-MB IMC

BIOS: Insyde, Version F.22.
Memory: 6 GB (2048 MB + 4096 MB DDR3 SODIMM)
Video: Intel HD Graphics Family, Intel HD Graphics 3000
Sound: Intel Panther Point HDMI @ Intel Panther Point PCH – High Definition Audio Controller [C-1]
LAN: Realtek PCIe FE Family Controller
Wi-Fi: Ralink RT5390R 802.11b/g/b 1x1 Wi-Fi Adapter
Optical disc: hp DDDVDW SN-208BB
IDE-controller: Intel 7 Series Chipset Family SATA AHCI Controller

The DSDT.aml that I am using is pretty much a clean DSDT, extracted from my HP g6 in Windows 7 using Read-Write Everything. DSDT Autopatcher says there is a few errors in it, and the black boot-screen right after Chameleon and right before the Mac OS X Installer mentions quite a few errors.
I can post pictures of these, or copy-paste the Autopatcher errors, if this would help. I have left it out for now, to not bloat my 1st post with what might be unnecessary info.

Thank you for your time, and please point me in the right direction if this is the wrong thread for my question, if you need to know more about my laptop in order to help me, etc.

Cheers

-Preben, Denmark

Edited by prebenjensen, 03 March 2013 - 06:16 PM.


#1413
Peter_sm

Peter_sm

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 281 posts
It's very sad that 10.8.3 is no longer work on our (older) , its the graphic card issue, loos like everything else are OK.

The nv* files from 10.8.2( from earlier beta number 2) doesn't work..... any one that might have a solution, please let us know ;)

//Peter

#1414
tical2k

tical2k

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
  • Gender:Male
Back when I still had my dv8 (Let the magic smoke out of the cpu. Don't upgrade the cpu haha), I always had to roll back to the dp2 graphics files. There were only 2 I replaced, but it always worked, I think they changed how power management worked on the graphics in 10.8.3. Not sure, though. Also perhaps try the drivers straight from nvidia and see if those work.

#1415
macq

macq

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts
Hi guys,
to make 10.8.3 graphics work ,is it possible to Insert our card's ID into NVDAResman and NVDAGF100Hal?
I could not find any place in the info .plist where one could do that.
can some one try this if they are familiar with this.

are older cards working with 10.8.3, if they are we still have a chance?
Please suggest anything that would help.
Thanks

#1416
oskr66

oskr66

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
my computer was updated today to 10.8.3 and it does not work , how can I bring it back to 10.8.2 ? it says unsoported ship ID=0xffff
:wallbash:

#1417
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
Hi!

If it used to work with 10.8.2, just restore or copy from the Time Machine or CCC backup the kext correspondent to the issue and repair permissions. In the following restart use the flag -f (WithKexts in clover).

I.e.: your graphics cards stops to work properly with the update. Restore or copy from the Time Machine or CCC backup the kext correspondent to your card, and repair permissions if you manage to boot the system. In case you don't (or even in the case you do), reboot again, using the flag -f.

Don't you have a Time Machine or CCC backup? Gee, man! :(

All the best!

#1418
oskr66

oskr66

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
Hi , thanks for the help , I did not have a recent " Time Machine Back up " , but I was able to boot up by replacing AppleACPIPlatform.kext , and then taking all of the sensors kexts from the " extra folder " and just keeping fakeSMC kext , graphics are really bad and slow , not sure if there is a solution for this .... will continue to try ....

Attached Files



#1419
Hamoda

Hamoda

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
I this method works for HP Pavilion Dv6-6C50SE?

Thanks.

#1420
oskr66

oskr66

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
Any solutions for our graphics ?? Anyone ??





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy