Jump to content

[Guide] Installing Mac OS X Lion (Developer Preview)


  • Please log in to reply
157 replies to this topic

Poll: Please answer the poll! (62 member(s) have cast votes)

Did this help you?

  1. Yes (28 votes [42.42%])

    Percentage of vote: 42.42%

  2. No (18 votes [27.27%])

    Percentage of vote: 27.27%

  3. Somewhat helped (16 votes [24.24%])

    Percentage of vote: 24.24%

  4. Destroyed my system (4 votes [6.06%])

    Percentage of vote: 6.06%

Vote Guests cannot vote

#41
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 688 posts
  • Gender:Male
  • Location:South NSW, Australia
Mine booted the Base system, then loading mach_kernel, loading drivers went for a little bit then halfway down the screen the loading dots stopped then brings me to a new screen saying darwin v11 blah blah then nothing after that, i have tryed quite a few flags no luck :( is this build 11A390 or is this the first release of the dev build or second?

#42
DaviDemon

DaviDemon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
This is the first release of the dev build.

#43
jmacie

jmacie

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

This is the first release of the dev build.


Finally, Finally got it! I'm exhausted all the reading and messing. I'll get back with some info. It may all be because of my board, but I might be able to give a few pointers. It was like a puzzle that would never end. But, I'm glad I stuck with it. So far it's very smooth and fast. Will write back. Thanks to you DaviDemon et al!, johnm

#44
DaviDemon

DaviDemon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
Congratulations, I did say you needed patience.. And you got it!

Please post up some information so it will help others as well.

#45
lord_webi

lord_webi

    ./root86.com

  • Members
  • PipPipPipPipPipPipPip
  • 648 posts
  • Gender:Male
  • Location:Duesseldorf, Germany
  • Interests:WingTsun, osx86, western shooting
HowTo Lion on Asus P5W DH Deluxe

What you need:
1x USB Stick
1x free partition / USB HD

1. Boot Stick:

Windows: create with #####.zip (tool inside) your bootable stick

Mac: use tool inside folder new_version, copy #####.zip efi content to stick

2. mount Lion Dev Image
3. mount BaseSystem: open /Volumes/Mac\ OS\ X\ Install\ ESD/BaseSystem.dmg
4. restore Base Image to a 10GB partition
5. delete link "Packages" from Base System partition /System/Installation
6. copy Packages from Dev Image to Base Image Partition to /System/Installation using Pathfinder/ForkLift etc. … keep that invisible flag (!)
7. copy fakesmc.kext to Base Image partition to /S/L/E
8. activate superuser in Terminal: su
9. in Terminal: cd to folder /S/L/E on Base Image partition
10. chown -R 0:0 fakesmc.kext
11. chmod -R 755 fakesmc.kext
12. boot that stick, wait until screen turns black, press W
13. press U to 1024x768, or better 1280x1024
14. press M enter, BootArgs -v
15. press G
16. select Base System Image partition, hit enter
17. install Lion
18. go to Snow and delete /System/Library/CoreServices/PlatformSupport.plist from Lion installed HD
19. again copy fakesmc.kext to Lion installation, set rights
20. copy other needed Kextst (e.g. NVEnabler, Disabler, VoodooHDA) to /System/Library/Extensions on Lion installed HD
21. copy KextUtility to Lion installed HD
22. boot from stick, select Lion installed HD
23. in Lion execute KextUtility, reboot ...

That's it …

REMEMBER: on Asus P5W DH Deluxe set in BIOS USB Legacy Support to Enabled, AUTO will only work sometimes and you lose USB connections

./edit: putting Kexts in Kext folder of the stick will not work with P5W/#####

Have fun :)

Attached Files



#46
constil

constil

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 643 posts

HowTo Lion on Asus P5W DH Deluxe

What you need:
1x USB Stick
1x free partition / USB HD

1. Boot Stick:

Windows: create with #####.zip (tool inside) your bootable stick

Mac: use tool inside folder new_version, copy #####.zip efi content to stick

2. mount Lion Dev Image
3. mount BaseSystem: open /Volumes/Mac\ OS\ X\ Install\ ESD/BaseSystem.dmg
4. restore Base Image to a 10GB partition
5. delete link "Packages" from Base System partition /System/Installation
6. copy Packages from Dev Image to Base Image Partition to /System/Installation using Pathfinder/ForkLift etc. … keep that invisible flag (!)
7. copy fakesmc.kext to Base Image partition to /S/L/E
8. activate superuser in Terminal: su
9. in Terminal: cd to folder /S/L/E on Base Image partition
10. chown -R 0:0 fakesmc.kext
11. chmod -R 755 fakesmc.kext
12. boot that stick, wait until screen turns black, press W
13. press U to 1024x768, or better 1280x1024
14. press M enter, BootArgs -v
15. press G
16. select Base System Image partition, hit enter
17. install Lion
18. go to Snow and delete /System/Library/CoreServices/PlatformSupport.plist from Lion installed HD
19. again copy fakesmc.kext to Lion installation, set rights
20. copy other needed Kextst (e.g. NVEnabler, Disabler, VoodooHDA) to /System/Library/Extensions on Lion installed HD
21. copy KextUtility to Lion installed HD
22. boot from stick, select Lion installed HD
23. in Lion execute KextUtility, reboot ...

That's it …

REMEMBER: on Asus P5W DH Deluxe set in BIOS USB Legacy Support to Enabled, AUTO will only work sometimes and you lose USB connections

./edit: putting Kexts in Kext folder of the stick will not work with P5W/#####

Have fun :)

Hi Lordi

which Gra-Ka do you used in that System, have you got QE/CI

ciao
Herman the German

EDIT : habe gerade deine Sig. gefunden in (root86.org) ist das die getestet HW
C2Q8300 CPU @ 2.5GHz
Asus P5W DH Deluxe MoBo - 8 GB A-Data DDR2-800 RAM - 1x SATA SSD 64 GB - System - 1x SATA HD 320 GB - WORK
1x SATA HD 1000GB Archive - Zotac GT240 Zone 1 GB passiv

#47
lord_webi

lord_webi

    ./root86.com

  • Members
  • PipPipPipPipPipPipPip
  • 648 posts
  • Gender:Male
  • Location:Duesseldorf, Germany
  • Interests:WingTsun, osx86, western shooting
yep: 1GB GT240 fanless ... QE/CI fully working with NVEnabler x64 Kext ...

#48
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 688 posts
  • Gender:Male
  • Location:South NSW, Australia
Got further ran into a AppleUSBEHCI prob waiting for root blah blah, my work around hopefully i will extract the dmg, do the changes,burn to dvd then try run install from a dvd instead.

#49
jmacie

jmacie

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
'lord_webi',
We use the same board. In fact, our processes for lion install about the same. What I would say is, that I spent alot of time putting my dsdt in ##### in different locations, when it was not needed. If I could get restart and sleep, that would be my next tasks.

#50
flip360

flip360

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Skopje
Hello there,

firs off thanks for the guide, really helps ppl.
i have problems booting the Lion installer from #####, i have tried various flags, kexts and dsdt but it stops on loading drivers afew dotted lines.........and thats it, just hangs there. Any suggestions? I have P5Q PRO, thanks and keep up the good work.

#51
Taruga

Taruga

    Retired

  • Retired Developers
  • 528 posts
  • Gender:Male
  • Location:Portugal

Hello there,

firs off thanks for the guide, really helps ppl.
i have problems booting the Lion installer from #####, i have tried various flags, kexts and dsdt but it stops on loading drivers afew dotted lines.........and thats it, just hangs there. Any suggestions? I have P5Q PRO, thanks and keep up the good work.



Disable Serial Port on bios, also try removing other usb devices connected and try again

#52
flip360

flip360

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Skopje

Disable Serial Port on bios, also try removing other usb devices connected and try again


it booted after all, thanks Taruga :)

EDIT: Installed fine but very slow install (maybe the USB), with the proper kext and the kext utility i have everything working except sleep, restart/reboot. Boots fast and feels very snappy with full QE/CI, and the fabulous AppleHDA enabler :(

#53
Krishna21

Krishna21

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 322 posts
This is making me mad :\

I installed ##### from Windows using the utility to a flash drive and booted from it.

No white line, it went straight to a black screen but it was illuminated, in other words, the screen was on and still black.

I tried pushing W, U, D, and V to zoom/zoom out and detect, but I've been hanging at the black screen for over ten minutes..


Can anyone help? I've always wanted to be part of the group that tries the first OSx86 Port for a new OS X Installment..:(


Oh yeah, and there's no kind of option in my BIOS to enable or disable Serial Port.

#54
jmacie

jmacie

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
[quote name='edge.' post='1650235' date='Mar 6 2011, 12:09 PM']This is making me mad :\

I installed ##### from Windows using the utility to a flash drive and booted from it.

No white line, it went straight to a black screen but it was illuminated, in other words, the screen was on and still black.

I tried pushing W, U, D, and V to zoom/zoom out and detect, but I've been hanging at the black screen for over ten minutes..


Can anyone help? I've always wanted to be part of the group that tries the first OSx86 Port for a new OS X Installment.. :unsure:




If it's an asus, then in BIOS go to advanced tab, down to onboard devices config, then down to Serial Port1 Address. I tried disabled, but got 3E8/IRQ4 working. With #####, you have to be really patient. First, after (red) MBR START! flash the cursor drops down about 10 lines, over 20 spaces, then blinks about 20 seconds, then disappears. Then press "v" key, once. it's drive refresh. If you don't see refresh press v again. Then "u" key to adjust resolution It's a fragile gui, so be patient. Then you can add boot flags by pressing m key then enter, add flag, enter, then escape to write flag config, then wait and boot. If you don't have serial port address, which I'm sure you do, then that's your ##### problem.
P.S If you have an MBR drive as your first hard drive in bios ##### doesn't like that, change your cable wiring to guid drive as 1st drive on motherboard.

#55
Motawa

Motawa

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 220 posts
I Installed Lion sucesfully but when i want to start the partition with lion installed with ##### it says something like "This verison of mac os x is not supported on your platform. Board id: p5b(wich is my mainboard)


My system:

Asus P5B
Core 2 Quad
ati 5750
4gb ddr2

2x 500gb sata2

Right now im running 10.6.6 retail.



Edit.

Alrght Now it loads. But the cyrcle keeps spinning. Harddrive makes noise though. But nothing happens next.

#56
tdtran1025

tdtran1025

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 353 posts

Disable Serial Port on bios, also try removing other usb devices connected and try again


Taruga, what a surprise visit! You are a like a unicorn.
Can you teach me and others on this thread how to patch ALC888 to work on Lion? I always relied on other people's discovery of new kext on ALC888 whenever there's a new version of OS X. This time I need to learn it since none of the previous kexts of ALC888 work on Lion–not even VooDooHDA.
Thanks

#57
Motawa

Motawa

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 220 posts
Works now.
USB
ati 5750 incl. QE)
LAN
Sound doesn't.


edit: Sound works with VOODOHDA.

If my lexicon and logic works I'm gonna be lol :wacko:


edit. Ok everything works. I think I'm gonna stick with lion.

#58
Krishna21

Krishna21

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 322 posts
Okay, got into the bootloader.

I did the following:

-v: Hangs on "loading drivers................................................................"
-v -x: Hangs on "Loading drivers............................................................."
-v -x -force64 arch=i386: Kernel Panic, no reboot
-v -x -force64: Kernel Panic

I've realized for -v, -v -x, the USB stops working because the Mac OS X Base System USB Drive turns off (no flashing orange light) and so does my external HDD..

Ideas?

#59
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 688 posts
  • Gender:Male
  • Location:South NSW, Australia

Okay, got into the bootloader.

I did the following:

-v: Hangs on "loading drivers................................................................"
-v -x: Hangs on "Loading drivers............................................................."
-v -x -force64 arch=i386: Kernel Panic, no reboot
-v -x -force64: Kernel Panic

I've realized for -v, -v -x, the USB stops working because the Mac OS X Base System USB Drive turns off (no flashing orange light) and so does my external HDD..

Ideas?


Don't add your DSDT or any kexts inside #####, Kext's stop it loading and so does DSDT. For me anyway.

#60
thanh hoang

thanh hoang

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
I have problem with post USB. error on boot verbose mode. But in Lion work like speed 1.1 and if i put my DSDT work good on Snow into #####=> Boot Frezee=>Any help me. Thanks





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy