Jump to content

[Guia] Instalando MacOSX Lion Developer Preview 3 (IBOOT)


  • Please log in to reply
260 replies to this topic

#61
Plugged

Plugged

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:São Paulo - Brazil

Chameleon

-usecache
http://netkas.org/?p=660


Eu instalei o Lion usando um case externo USB ligada ao iMac. O Lion instalou e rodou perfeitamente no iMac. Então retirei o HD com o Lion do case e conectei diretamente ao meu hackintosh. Daí não entra no Lion. Tentei usando diversas versões do Chameleon, mas nenhuma fez o Lion entrar. Instalei a versão do Chameleon indicada aqui no HD que tem o Lion, mas não consegui entrar em nenhuma das instalações que tenho no hackintosh usando esta versão (nem Lion, nem Snow). Também já tentei criar a pasta /Extra na instalação do Lion e tentei inúmeras configurações nesta pasta, mas nada funcionou.

Meu Snow Leopard, por outro lado, está rodando muito bem no hackintosh na versão 10.6.7 sem problemas. Só uso a DSDT a smbios e a pasta Extensions com 3 kexts (fakesmc, rede e som). Tentei usar esta configuração para iniciar o Lion e também tentei uma outra que usei antes que não usa DSDT. Nenhuma funcionou.

Alguma dica?

#62
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 11,137 posts
  • Gender:Male
  • Location:Rio de Janeiro

Eu instalei o Lion usando um case externo USB ligada ao iMac. O Lion instalou e rodou perfeitamente no iMac. Então retirei o HD com o Lion do case e conectei diretamente ao meu hackintosh. Daí não entra no Lion. Tentei usando diversas versões do Chameleon, mas nenhuma fez o Lion entrar. Instalei a versão do Chameleon indicada aqui no HD que tem o Lion, mas não consegui entrar em nenhuma das instalações que tenho no hackintosh usando esta versão (nem Lion, nem Snow). Também já tentei criar a pasta /Extra na instalação do Lion e tentei inúmeras configurações nesta pasta, mas nada funcionou.

Meu Snow Leopard, por outro lado, está rodando muito bem no hackintosh na versão 10.6.7 sem problemas. Só uso a DSDT a smbios e a pasta Extensions com 3 kexts (fakesmc, rede e som). Tentei usar esta configuração para iniciar o Lion e também tentei uma outra que usei antes que não usa DSDT. Nenhuma funcionou.

Alguma dica?


O Chameleon ainda dá problemas na maioria das placas
use o iBoot, use um pen drive de 8GB e siga o tutorial

#63
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,837 posts
  • Gender:Male
  • Location:Brazil
Se já está com o Lion instalado no HD externo, nem precisa pen drive de 8 GB, pode ser de qualquer tamanho, só para instalar o iBoot mesmo.

#64
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 11,137 posts
  • Gender:Male
  • Location:Rio de Janeiro
mais fácil ainda, é só seguir a primeira parte do tutorial

o Chameleon até nas placas que funciona, dá mt KP na inicialização

#65
C.Frio

C.Frio

    InsanelyMac Legend

  • Pandora Team
  • 1,131 posts
  • Gender:Male
  • Location:Cabo frio - Brasil

Opa amigos do insanely,to aqui na tentativa de por o lion,desmontei minhas partiçoes todas e meti o snow em GUI aqui sosinho em um hd de 1tb com 4 partições todas em gui,na primeira partição de 250GB.

1-Baixe o ##### e as "format tools", links no tópico do ###### no irc.moofspeak.net/6667
http://www.mediafire...4h5j80ap145rk74 Novo #####-1.4 Estável
http://www.mediafire...u69azl1nqut4q2f
*nesse link tem o ##### 1.4,ai abri o arquivo e notei a falta da pasta(Copie o DSDT.aml para a pasta efi/acpi/oem do pen drive.)ou seja /acpi/oem tem que ser criada ou põe o dsdt na pasta dsdt que existe?

2-montagem da imagem,aqui esta minha maior duvida,meu pen drive tem 8gb,então montei como fala no tuto,em duas partições formatado em mbr a primeira em fat-dos(300mb) e o restante para montagem da imagem em (mac os reg cronologicamente)pelo DU.
a pergunta é como se monta a imagem,cliko no dmg e direciono para a partição do pen?

agradeço desde ja ajuda :)



Ola...

1-coloca na pasta DSDT...


2- monta o Lion....click no .dmg para ele abrir....uma pasta sera mostrada no desktop com isto " Mac OS x install ESD" dai vc roda o comando "open /Volumes/Mac\ OS\ X\ Install\ ESD/BaseSystem.dmg" outra pasta ira aparecer com " base system .dmg" e faça o "restore" desta pasta para a particao maior do pen drive...

eu deixei meu pen drive formatado fat-32,MBR so para o boot...usei um hd externo com 2 particoes,("journaled" e GUID) para o "restore" e para a efetiva instalacao do Lion...

c.frio

#66
Crosx86

Crosx86

    Hacker soul !

  • Members
  • PipPipPipPip
  • 239 posts
  • Gender:Male
  • Location:Brasil

Ola...

1-coloca na pasta DSDT...


2- monta o Lion....click no .dmg para ele abrir....uma pasta sera mostrada no desktop com isto " Mac OS x install ESD" dai vc roda o comando "open /Volumes/Mac\ OS\ X\ Install\ ESD/BaseSystem.dmg" outra pasta ira aparecer com " base system .dmg" e faça o "restore" desta pasta para a particao maior do pen drive...

eu deixei meu pen drive formatado fat-32,MBR so para o boot...usei um hd externo com 2 particoes,("journaled" e GUID) para o "restore" e para a efetiva instalacao do Lion...

c.frio


Opa vlw c.frio,ontem eu fiz esse procedimento e parou na tela do erro do #####,acho que vou esperar mais um pouco,pq eu não uso o windows então não da pra usar a ferramenta da hp para formatar a unidade flash,fiz com os 4 #####,1,2,3,4 e deu o mesmo erro,ele para na tela BErr... e esse arquivo que no tuto manda mover ou renomear aqui pra mim ele não existe.

Dica do zet120

7) Entre no Snow Leopard e mova ou renomeie o arquivo /System/Library/CoreServices/PlatformSupport.plist da partição do Lion.
...,muito obg pelo seu retorno ;)

#67
C.Frio

C.Frio

    InsanelyMac Legend

  • Pandora Team
  • 1,131 posts
  • Gender:Male
  • Location:Cabo frio - Brasil

Opa vlw c.frio,ontem eu fiz esse procedimento e parou na tela do erro do #####,acho que vou esperar mais um pouco,pq eu não uso o windows então não da pra usar a ferramenta da hp para formatar a unidade flash,fiz com os 4 #####,1,2,3,4 e deu o mesmo erro,ele para na tela BErr... e esse arquivo que no tuto manda mover ou renomear aqui pra mim ele não existe.

Dica do zet120

7) Entre no Snow Leopard e mova ou renomeie o arquivo /System/Library/CoreServices/PlatformSupport.plist da partição do Lion.
...,muito obg pelo seu retorno :(


Partindo do principio,que o boot foi dado....apareceram na tela do "menu as opcoes quando teclado "M" e conseguido mudar a resolucao com "U"...

Faça o "restore" e apos o "restore" apague o arquivo "packages" conforme no "tutorial" e reinstale outros no terminal com a sintaxe disponivel...
De boot com o pen drive e escolha a particao com o MAC resultado do "restore",siga os passos e instale o lion na particao destinada a ele , apos instalar de novo boot para o snow leopard e, atravez do " snow leopard" remova o arquivo "PlatformSupport.plist" em.. "/System/Library/CoreServices/

de novo boot agora com o pendrive, e coloque como opcao no menu -v -x e escollha apos, a particao com o Lion instalado...

c.frio

#68
Plugged

Plugged

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:São Paulo - Brazil

mais fácil ainda, é só seguir a primeira parte do tutorial

o Chameleon até nas placas que funciona, dá mt KP na inicialização


Blz! Fiz isso. Tive que formatar o pendrive em FAT32 com o utilitário da HP (tem no Baixaki também), mas agora está entrando no #####. Configurei tudo direitinho, mas está dando KP com a mensagem:

"No HPETs avaliable...CPU(s) configurede incorrectly"
e dá o endereço @/SourceCache/AppleIntelCPUPowerManagement/AppleIntelCPUPowerManagement-149/pmThread.c:156

Minha placa mãe é Asus P6TD Deluxe e o processador é o i7-930.

#69
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 11,137 posts
  • Gender:Male
  • Location:Rio de Janeiro

Blz! Fiz isso. Tive que formatar o pendrive em FAT32 com o utilitário da HP (tem no Baixaki também), mas agora está entrando no iBoot. Configurei tudo direitinho, mas está dando KP com a mensagem:

"No HPETs avaliable...CPU(s) configurede incorrectly"
e dá o endereço @/SourceCache/AppleIntelCPUPowerManagement/AppleIntelCPUPowerManagement-149/pmThread.c:156

Minha placa mãe é Asus P6TD Deluxe e o processador é o i7-930.

dizem que a Null funciona no Lion(eu não testei)
ou
editar o HPET no DSDT, mas em algumas Asus o iBoot não estava lendo o DSDT, não sei essas novas versões

#70
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,837 posts
  • Gender:Male
  • Location:Brazil
Na versão atual (1.4) o problema continua na minha Asus (P5E).

Só consigo usando o module AcpiPatcher, ele faz algo que evita o KP do HPET
http://www.insanelym...p...t&p=1649035

#71
Crosx86

Crosx86

    Hacker soul !

  • Members
  • PipPipPipPip
  • 239 posts
  • Gender:Male
  • Location:Brasil

Partindo do principio,que o boot foi dado....apareceram na tela do "menu as opcoes quando teclado "M" e conseguido mudar a resolucao com "U"...

Faça o "restore" e apos o "restore" apague o arquivo "packages" conforme no "tutorial" e reinstale outros no terminal com a sintaxe disponivel...
De boot com o pen drive e escolha a particao com o MAC resultado do "restore",siga os passos e instale o lion na particao destinada a ele , apos instalar de novo boot para o snow leopard e, atravez do " snow leopard" remova o arquivo "PlatformSupport.plist" em.. "/System/Library/CoreServices/

de novo boot agora com o pendrive, e coloque como opcao no menu -v -x e escollha apos, a particao com o Lion instalado...

c.frio

c.frio vou fazer,olha só acabei de instalar o windows denovo,para poder passar a ferramenta da hp no pen,ai vou montar com calma na madrugada e posto aqui o resultado,mais uma vez obg... :help:
Eu ainda tenho duas partições no hd(tudo em guid) e ainda a do pen para o ##### e restaurar a imagem... :unsure:

#72
Plugged

Plugged

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:São Paulo - Brazil

Na versão atual (1.4) o problema continua na minha Asus (P5E).

Só consigo usando o module AcpiPatcher, ele faz algo que evita o KP do HPET
http://www.insanelym...p...t&p=1649035


oldnapalm,

o ApciPatcher que você se refere é este? http://www.insanelym...howtopic=142434

Se for, tentei e ele não consegue rodar o patch no arquivo da minha bios. Tentei usá-lo para rodar um patch em uma dsdt básica e na que uso para ver se fixava o problema do hpet. Contudo, não entra.

Um detalhe: o ##### 1.4 não está entrando na minha instalação do Snow também. Dá o mesmo erro... Como minha MB é X58, pode ser mais complicado mesmo.

#73
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,837 posts
  • Gender:Male
  • Location:Brazil
Não, o AcpiPatcher que eu falo é esse (vai na pasta "module")
http://www.insanelym...p...st&id=88247

Edit: Refiz o processo e na verdade não é bem como eu pensei, só funciona com a versão 1.2 e fazendo os passos abaixo.

iBoot 1.2: http://www.mediafire...lh72vnah1plmc3f

- instalar o iBoot 1.2 no pen drive (procedimento padrão citado no primeiro post)
- copiar o AcpiPatcher.efi para a pasta efi/modules
- fazer boot pelo iBoot (o AcpiPatcher vai extrair as tabelas e parchear algumas)
- pressionar M, colocar "Debug=Y" e "Kernel flags=-v" (talvez não seja necessário)
- pressionar G (o iBoot vai extrair as tabelas)
- tentar o boot, vai dar KP do HPET (talvez não precise)
- copiar todos os arquivos de efi/TrialMac/AcpiTables/Originals para efi/TrialMac/AcpiTables/Patched (substituir os existentes)
- copiar o DSDT.aml parcheado para efi/acpi/oem (substituir o existente)

Agora o boot deve funcionar sem o KP do HPET e usando o DSDT.aml de efi/acpi/oem.

Se você usa as funções GeneratePStates, GenerateCStates e GraphicsEnabler do Chameleon, aplique os patches correspondentes no DSDT.aml, já que o iBoot não tem estas funções.

#74
Crosx86

Crosx86

    Hacker soul !

  • Members
  • PipPipPipPip
  • 239 posts
  • Gender:Male
  • Location:Brasil
Bom pessoal,eu conssegui bootar aqui em verbose,mais ele para nessa tela:Attached File  IMG_0065_1_.JPG   612.84KB   21 downloads

não sei se estou errando na montagem da imagem,quando eu dou o comando no terminal(cp -R /Volumes/Mac\ OS\ X\ Install\ ESD/Packages /Volumes/Mac\ OS\ X\ Base\ System\ 1/System/Installation) ele escreve em todos,no suchi file or directory.

poxa falta pouco :)

ajuda :)

#75
C.Frio

C.Frio

    InsanelyMac Legend

  • Pandora Team
  • 1,131 posts
  • Gender:Male
  • Location:Cabo frio - Brasil

Bom pessoal,eu conssegui bootar aqui em verbose,mais ele para nessa tela:Attached File  IMG_0065_1_.JPG   612.84KB   21 downloads

não sei se estou errando na montagem da imagem,quando eu dou o comando no terminal(cp -R /Volumes/Mac\ OS\ X\ Install\ ESD/Packages /Volumes/Mac\ OS\ X\ Base\ System\ 1/System/Installation) ele escreve em todos,no suchi file or directory.

poxa falta pouco ;)

ajuda ;)


Ola...

Eu tb nao consegui com esta sintaxe... entao, o q fiz foi criar no meu desktop uma pasta como nome "packages,

depois, no terminal coloquei isto "open /Volumes/Mac\ OS\ X\Install\ESD/Packages" , com isto, vai ser aberta a pasta "Packages" na qual existem varios "pacotes" ; copie todos esses pacotes para a pasta que vc criou no Desktop.

Isto eu fiz para facillitar as varias tentativas feitas.....

Com a pasta do desktop e com os "pacotes" ,copie para o lugar de onde vc removeu aquele "packages" anteriormente

"Faça o "restore" e apos o "restore" apague o arquivo "packages" conforme no "tutorial" e reinstale outros" Copiando a pasta "packages" do desktop para la...
Esta pronto para dar o boot (com -v -x) e colocar para instalar...

Acho que clareou um pouco...

c.frio

c.frio

#76
Crosx86

Crosx86

    Hacker soul !

  • Members
  • PipPipPipPip
  • 239 posts
  • Gender:Male
  • Location:Brasil

Ola...

Eu tb nao consegui com esta sintaxe... entao, o q fiz foi criar no meu desktop uma pasta como nome "packages,

depois, no terminal coloquei isto "open /Volumes/Mac\ OS\ X\Install\ESD/Packages" , com isto, vai ser aberta a pasta "Packages" na qual existem varios "pacotes" ; copie todos esses pacotes para a pasta que vc criou no Desktop.

Isto eu fiz para facillitar as varias tentativas feitas.....

Com a pasta do desktop e com os "pacotes" ,copie para o lugar de onde vc removeu aquele "packages" anteriormente

"Faça o "restore" e apos o "restore" apague o arquivo "packages" conforme no "tutorial" e reinstale outros" Copiando a pasta "packages" do desktop para la...
Esta pronto para dar o boot (com -v -x) e colocar para instalar...

Acho que clareou um pouco...

c.frio

c.frio


Clareou e muito,to indo montar,vlw c.frio :)

#77
C.Frio

C.Frio

    InsanelyMac Legend

  • Pandora Team
  • 1,131 posts
  • Gender:Male
  • Location:Cabo frio - Brasil
Ola....! :)

Instalado em uma GA-P55M-UD2 com um i5 7500 ,4GB e uma 9500GT, levou uma "vida" para instalar de um pen drive de 16GB para um HD externo,Seagate ,
Apos varias tentativas...a instalacao nao progredia quando no mesmo HD estava o "restore" em uma particao e instalando em outra...bem como no pendrive... a solucao foi colocar o boot em um pen de 8GB, o" Restore" no pedrive de 16GB e coloquei para instalar no Seagate externo...ainda sem som, video com resolucoes e rede...mas ,chego la... :wacko:

vou ver se tirando os pacotes de idiomas, deixando so o ingles, fica mais rapido para instalar... UFA!!!!

c.frio

EDIT: o sistema esta muito lento e so esta rodando com boot em "safe mode" caso contrario ,durante o carregamento para na mensagem..."nspace-handler-set-snapshot-time: 1300198900"

creio que pode ser devido ao hd externo Seagate...

#78
Crosx86

Crosx86

    Hacker soul !

  • Members
  • PipPipPipPip
  • 239 posts
  • Gender:Male
  • Location:Brasil
Ainda não tive sucesso,fiz da forma que voçe sugeriu c.frio e caiu na mesma tela,fiz de varias formas,inclusive como manda no tuto e infelismente não sai dessa tela:
Attached File  IMG_0065_1_.JPG   612.84KB   21 downloads
Algum outro método que eu possa tentar...?kkk a vontade de instalar é grande,mais eu percebo que so isso que impede,ele ta bootando normal em -v -x arch=i386 e boota rapido o rei dos felinos,mais quando cai na tela de escolher a linguagem é isso que voçes vêem na imagem acima,se puderem me ajudar eu agradeço :)

#79
C.Frio

C.Frio

    InsanelyMac Legend

  • Pandora Team
  • 1,131 posts
  • Gender:Male
  • Location:Cabo frio - Brasil

Ainda não tive sucesso,fiz da forma que voçe sugeriu c.frio e caiu na mesma tela,fiz de varias formas,inclusive como manda no tuto e infelismente não sai dessa tela:
Attached File  IMG_0065_1_.JPG   612.84KB   21 downloads
Algum outro método que eu possa tentar...?kkk a vontade de instalar é grande,mais eu percebo que so isso que impede,ele ta bootando normal em -v -x arch=i386 e boota rapido o rei dos felinos,mais quando cai na tela de escolher a linguagem é isso que voçes vêem na imagem acima,se puderem me ajudar eu agradeço :)



Vc esta esperando quanto tempo o "arco iris" ? rodando...? coloca tb o "-f" no boot...,nao faz muito sentido pois o "-x" eh para entrar em "safe mode",mas....o meu tem e pelo menos nao atrapalha

o meu neste outro (P55) esta demorando um tempao...achei varias vezes que tinha travado,mas a luz do HD estava trabalhando...

o caminho eh esse...se todos os passos foram dados,desculpe mas nao me ocorre nada de diferente.

esta dando boot, o restore foi bem sucedido, aparece a particao para ser instalado....BUMP...?!!


c.frio

#80
Crosx86

Crosx86

    Hacker soul !

  • Members
  • PipPipPipPip
  • 239 posts
  • Gender:Male
  • Location:Brasil

Vc esta esperando quanto tempo o "arco iris" ? rodando...? coloca tb o "-f" no boot...,nao faz muito sentido pois o "-x" eh para entrar em "safe mode",mas....o meu tem e pelo menos nao atrapalha

o meu neste outro (P55) esta demorando um tempao...achei varias vezes que tinha travado,mas a luz do HD estava trabalhando...

o caminho eh esse...se todos os passos foram dados,desculpe mas nao me ocorre nada de diferente.

esta dando boot, o restore foi bem sucedido, aparece a particao para ser instalado....BUMP...?!!


c.frio

Pois é c.frio,eu tambem não to me conformando,mais eu deixei na tela de espera por uns 5 minutos,olha so não vou desistir,mais tarde vou bootar ele denovo aqui e deixar.vlw :)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy