Jump to content

OSX86 ati mobility radeon HD5870 working perfectlly with QE/CI


  • Please log in to reply
83 replies to this topic

#21
fredzed

fredzed

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
anyone have success on other ATI Mobility 5xxx cards with this method?

#22
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 724 posts
  • Gender:Male
  • Location:South NSW, Australia
5650m i'm using 10.7 kexts, I can only get full resolution, still haven't chosen the right FB.

#23
Ruddy

Ruddy

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

Thanks both guys for confirmation. So the method is working on MSI GX660 and Asus G73JH. I think that will be working also for another series of HD5xxx - need to use the correct atirom file.
Good luck!



Olda are you using the MSI GX660? is it the MSI GX660-260US?

Im shopping for a laptop and had my eyes on this one...

thanks!

#24
checcco

checcco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts

Hi guys,
download the files from link below.
http://www.mediafire...qpev3oov7icafk3
There is modified boot file - the framebuffer for mobility card was changed to right one(Nomascus).
Also, there is atirom for mobility hd5870, device ID 68a0.
Follow the instruction above and your card will be working.


Is this boot specific to 5870 or can it be used with other mobility too?

#25
Fb2003

Fb2003

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

Hi guys, as you can see on the picture, my mobility radeon is fully supported in 10.6.6(QE/CI).
1. Install 10.6.6 - do not reboot
2. Install chameleon bootlooder
3. Replace the boot file
4. Create the Extra folder
5. Use ati rom into the Extra folder
6. Use com.apple.Boot.plist into the Extra folder
Restart the computer and your graphics acceleration should be working.

Ati framebuffer in boot file was changed to Nomascus - fb for mobility cards.


I have a Clevo W870CU laptop with i7 / Intel PM55 chipset / HD 5870 mobility card

I did exactly what Olda written above. (I used the boot file form last post)

But after restart my laptop doesnt boot anymore.

Does the Extra folder need to contain more files than only the ati rom + com.apple.Boot.plist.

For instance there is also a Extensions.mkext file in olda's zip file, which I haven't copied in.

Should I install more kexts...? Like FakeSMC etc. ?

Please help me

#26
Olda

Olda

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

I have a Clevo W870CU laptop with i7 / Intel PM55 chipset / HD 5870 mobility card

I did exactly what Olda written above. (I used the boot file form last post)

But after restart my laptop doesnt boot anymore.

Does the Extra folder need to contain more files than only the ati rom + com.apple.Boot.plist.

For instance there is also a Extensions.mkext file in olda's zip file, which I haven't copied in.

Should I install more kexts...? Like FakeSMC etc. ? On my Desktop I only need to run #####.

Please help me


Hi Fb2003,

here is the list of additional kext which I am using for 10.6.6: dsmos.kext,fakesmc.kext,NullCPUPowerManagement.kext,OpenHaltRestart.kext,PlatformUUID.kext,
RealtekR1000SL.kext,AppleACPIPS2Nub.kext,VoodooPS2Controller.kext,VoodooHDA

Extensions.mkext is containing all of them.

Did you have hang during the booting before the using of Extra folder also?

#27
Chaosstorm

Chaosstorm

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I have a clevo w860cu also with a hd 5870 but this laptop has external HDMI and dvi instead of the vga that the MSI laptop has, should i put my own vbios rom in the folder or the one provided in that upload of yours?

The result i had was a scrambled screen, i had used my vbios and i also had the 1.7 kext of the ati card installed. (and my audio drivers caused severe errors so i cant say for sure what caused my problem)

Im now trying with a total reinstall, altho this might take a while because i dont know what fixes i have to select >.<

#28
kch0pa

kch0pa

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

Hi Fb2003,

here is the list of additional kext which I am using for 10.6.6: dsmos.kext,fakesmc.kext,NullCPUPowerManagement.kext,OpenHaltRestart.kext,PlatformUUID.kext,
RealtekR1000SL.kext,AppleACPIPS2Nub.kext,VoodooPS2Controller.kext,VoodooHDA

Extensions.mkext is containing all of them.

Did you have hang during the booting before the using of Extra folder also?


There's no need for dsmos. Fakesmc replaced the decrypters.

#29
potfur

potfur

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 5 posts
  • Gender:Male
i already contacted interrested people - i can provide mobility radeon 5650 bioses (madison & park variants) so maybe with them "onboard" we'll manage to make osx run like it should on many acers/dells/asuses :)

#30
Olda

Olda

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

I have a clevo w860cu also with a hd 5870 but this laptop has external HDMI and dvi instead of the vga that the MSI laptop has, should i put my own vbios rom in the folder or the one provided in that upload of yours?

The result i had was a scrambled screen, i had used my vbios and i also had the 1.7 kext of the ati card installed. (and my audio drivers caused severe errors so i cant say for sure what caused my problem)

Im now trying with a total reinstall, altho this might take a while because i dont know what fixes i have to select >.<

Do you know the device ID of your card? The atirom file provided by me is for 68a0. If you have a different device ID, you must use atirom of your card and provide the renaming of the atirom file.
Also, if is your device ID different, check ati3000.kext and ati5000.kext, if both kexts are containing your device ID.

#31
tanja48

tanja48

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Hi, great work!

I've got a mobility 5730 (68C0) nd couldn't extract my bios, because its integrated in system bios.

Has somebody that atibios or a compatible?

The atibios given here isn't compatible (68a0) i think

Best wishes

tanja48

#32
IncognitoMan

IncognitoMan

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I'll definitely have to try this on my Asus G73 as well... Thanks Olda for your discovery.. much is appreciated by this! :)

#33
Fb2003

Fb2003

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
I hereby confirm my HD5870 is W O R K I N G :)

Great stuff ! Only that DVI-out isn't working. Internal + HDMI-out works great.

I did not use the chameleon provided, but did a 50/50 combination with #####.

First clean install -> 10.6.6 combo update -> ##### + necessary kexts -> swapped the boot file -> copies the rom file to /extra/ -> synced the plist file from Olde with the current --(restart)---> Screaming from joy :)

#34
Chaosstorm

Chaosstorm

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
My clevo w860cu works also!

I did a complete reinstall of OSX so i did not install the 10.7.0 kexts but just the one's that come with 10.6.6 and by following exactly your order it workerd (with the MSI vbios rom file)

Oh and powerplay works ALSO! because i had my powerplay clocked to 100mhz gpu 250mhz mem at 0.45V i got artifacts and that states that it does work because i get that also a few times in windows, now its at 400mhz and it boots up just fine (at 0.90V)

With a i7 920xm with 8gb ram and a hd 5870 its super fast (faster then EVERY macbook) i think i can compete against the imac's lol :gun:

Thanks alot for figuring this out.
Now i only have to find realtek alc888 audio kexts that work and then my hackingtosh is complete.

#35
checcco

checcco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
Using the boot file provided in this thread my 5650 was recognized as 5870! Is this something hardcoded in the boot file?

#36
Olda

Olda

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

Using the boot file provided in this thread my 5650 was recognized as 5870! Is this something hardcoded in the boot file?


Hi checco,

the boot file was modified for 5870, so if you want to have the correct description of the card in System Profiler, you must find the solution, how to rewrite red marked text in attached file(the attached file is part of the boot file).

Attached File  Bez_n__zvu.jpg   207.19KB   276 downloads

#37
Fb2003

Fb2003

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

Now i only have to find realtek alc888 audio kexts that work and then my hackingtosh is complete.


Me to! My W870CU also has the ALC888. I't easy to get it to work with #####...

ALC8xxHDA + NoneDSDT HDA enabler --> ALC888

But that doenst unilize the full possibilities of the device. Only internal speakers work. I need all the jacks to work :P. And so do you I think?

#38
Jorgen E

Jorgen E

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Any chance for HD6870M and HD6970M support using this method??

Considering the new Alienware M17x with the 6970M, would love some hackintosh love for that laptop.

Best regards // j

#39
Chaosstorm

Chaosstorm

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Me to! My W870CU also has the ALC888. I't easy to get it to work with #####...

ALC8xxHDA + NoneDSDT HDA enabler --> ALC888

But that doenst unilize the full possibilities of the device. Only internal speakers work. I need all the jacks to work ;) . And so do you I think?


I googled around i saw your post on hackingtosh.nl, im dutch too :P

Does any one know how to get the dvi port to work? (for MSI users the vga).
I managed to get the sound work :rolleyes:

#40
ukyo

ukyo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Any chance for HD6870M and HD6970M support using this method??

Considering the new Alienware M17x with the 6970M, would love some hackintosh love for that laptop.

Best regards // j


I think there are very few consumers who have 6970m's in their hands now. So only way might be trying it out yourself.
I personally am waiting for the card to come to clevo.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy