Jump to content

ATI MOBILITY 5650 WORKING FULL RES QE/CI ***FB EULEMUR***


  • Please log in to reply
51 replies to this topic

#41
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 701 posts
  • Gender:Male
  • Location:South NSW, Australia
i removed ATIRadeonX3000.kext and I can boot with full resolution, something display on laptop for a short while then external monitor also boot's up, i'm going to try and few FB's because I now have ATI5000Controller fully loaded. maybe i'll now try placing ATIRadeonX3000 back and see what happens now.




Ok so I removed ATIRadeonX3000.kext, it fully loads ATI5000Controller, now thats fully loaded I placed ATIRadeonX3000 back and now that fully loads. Now just have to find the correct FB using these kexts, I guess I will try at random.

Posted Image



I'm only using old 17" external LCD thats why 1024x768 lol

#42
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 701 posts
  • Gender:Male
  • Location:South NSW, Australia
Uakari - Loads, Internal LCD all lines but loads my external monitor as an extended desktop.

Hoolock only res change.
Megalodon only res.

Baboon only res change.
Nomascus - Black internal, black external but loads.

will keep trying as I go.

10.6.6 are out of the question. 10.7 get us further then 10.6.6. Heaps further, what is wierd is 10.6.6 Framebuffer kext contains all FB personalities whereas 10.7 Framebuffer kext has no personalities, maybe the Framebuffer is unfinished? Maybe I will go get 10.6.7 kext's and see what I get?

#43
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 701 posts
  • Gender:Male
  • Location:South NSW, Australia
I will try to load rom and see if Nomascus does anything.

The r700 ATI loads to the wrong connector or i'm using a rom file for 68c1 but it's a diff model laptop and normally diff brands use diff ports, diff locations so i will see if i can dump my ati rom file, i'm trying a few boot loaders as they do things differently.

There was someone here that posted success on 5870 mobility, installs chamelon rc5 rev746 then downgrades the boot file to 516 or something, this boot file wont work because it loads nomascus and loads our 5650 as 5870. so no good again :P




What jumps at me is that Uakari and Vervet load up as extended desktops using 10.7 kexts, my mission is installing Lion to peek around and see whats going on :(

#44
hjs89

hjs89

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male

I will try to load rom and see if Nomascus does anything.

The r700 ATI loads to the wrong connector or i'm using a rom file for 68c1 but it's a diff model laptop and normally diff brands use diff ports, diff locations so i will see if i can dump my ati rom file, i'm trying a few boot loaders as they do things differently.

There was someone here that posted success on 5870 mobility, installs chamelon rc5 rev746 then downgrades the boot file to 516 or something, this boot file wont work because it loads nomascus and loads our 5650 as 5870. so no good again :P




What jumps at me is that Uakari and Vervet load up as extended desktops using 10.7 kexts, my mission is installing Lion to peek around and see whats going on :)


You can dump your ati bios with Everest. I did and compared with the extracted with radeondump and was the same file :(

#45
mojtabazarei

mojtabazarei

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:IRAN

You can dump your ati bios with Everest. I did and compared with the extracted with radeondump and was the same file :(


hi dumped m5730 with everest its about 60KB and has dmp extension is it ok?

how to get rom file please help

#46
checcco

checcco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
Once we have vga bios I think that what we need is to enable 5650 in kabyl's boot... Is anyone able to do so? Device id is 68c1

I hope someone can help...really struggling here, I've tried everything...

#47
hjs89

hjs89

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male

hi dumped m5730 with everest its about 60KB and has dmp extension is it ok?

how to get rom file please help


I think you're right. You can check it with RBE (RadeionBiosEdit) in Windows and Radeondump in OSX. If the dump it's right you'll see information about your graphics card.


Once we have vga bios I think that what we need is to enable 5650 in kabyl's boot... Is anyone able to do so? Device id is 68c1

I hope someone can help...really struggling here, I've tried everything...

What is wrong with kabyl's boot?

I think that you can test the same as me. Use Lion's kext except ATIRadeonX3000.kext from Snow.

#48
mojtabazarei

mojtabazarei

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:IRAN
Hi

I installed 10.6.6 chameleon r748 and used ATIRadeonX3000.kext from Snow leopard

and 3 other kexts from lion and used

<key>GraphicsEnabler</key>
	  <string>Yes</string>

in chameleon have full resolution in external monitor with QE/CI

the bios i extracted from Everest

doesn't make any change i think i need a specific boot loader who has any suggestion to make laptop

display working? i have time to test

Edit : i decided to test with kabyl boot loader and there is a diffrent between r748 and kabyl

by using r748 have full resolution on external monitor and see the pic

[attachment=88678:2.jpg]

and with kabyl boot loader this section is empty

#49
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 701 posts
  • Gender:Male
  • Location:South NSW, Australia
Got it Fully working with the help of checco's boot file and the correct FB which is Eulemur!

http://www.insanelym...p...ded&start=#

#50
mojtabazarei

mojtabazarei

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:IRAN

Got it Fully working with the help of checco's boot file and the correct FB which is Eulemur!

http://www.insanelym...p...ded&start=#


i think this topic should be deleted

#51
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 701 posts
  • Gender:Male
  • Location:South NSW, Australia

i think this topic should be deleted


It shouldn't be deleted as I figured out the right Framebuffer :P

#52
Neolo

Neolo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
Please help. I installed Lion's kexts but my ATI 5650 mobility still not recognized in profiler. Snow Leopard 10.6.7 Retail





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy